Tuya MCU Wifi Dimmer with Tasmota 8.1 password

I have TreatLife Dimmer DS01 (https://www.amazon.com/gp/product/B07CKNWGN4), which I was able to successfully flush with Release Tasmota v8.1.0 Doris for Hubitat · markus-li/Tasmota-Hubitat · GitHub following the procedure outlined by @MarcusD in [Release] Tasmota 7.x/8.x firmware for Hubitat + Tuya, Sonoff and other drivers. Was able to add the device using the "Tasmota - TuyaMCU Wifi Dimmer" driver.
To get dimming to work properly I had to execute following commands via console (based on TuyaMCU Configurations · arendst/Tasmota Wiki · GitHub)

TuyaMCU 21,3 (wait for reboot)
Backlog Dimmer 10; Dimmer 100
weblog 4 (increase logging to get dpId top range)
DimmerRange 10,255

At that point everything works well and as expected.

Next, I wanted to secure the device so I configured the "Web Admin Password" and set the same in the device configuration (Device Password field). Since than I observed the the hub is not able to control the device (click on buttons in the device configuration page do not do anything to the device). At the same time the "current status" is accurately reflecting the state of switch/level and updates as I change by clicking the device button or via Tasmota Web interface on the device.

I also noticed that since password was set the device web interface and responses are noticeable slower and seems like web/wifi may be restarting from time to time (few times the device stopped responding to ping and web, need to observe longer to confirm).

Thank you for help.

If you can provide the link to the device template page from the official device compatibility list as well as the dimming range I can add this device so it auto configures in the new driver still in closed beta.

When you use this setting you need to provide the password to the device on the device configuration page in HE.
The reason you get updates anyway is because those are pushed to HE.

I have updated the original post with the configuration commands I executed.
My device model (https://www.amazon.com/gp/product/B07CKNWGN4/) is not listed on the official list of compatible devices (Switches, Dimmers and Relays)
The driver used - Hubitat/tasmota-tuyamcu-wifi-dimmer-expanded.groovy at release · markus-li/Hubitat · GitHub

Re password.. I set the password in the device web interface first, test the Tasmota web page now required login with admin/. Than in HE device config page I added the same password in Preferences>Device Password field and clicked "Save Preferences". Is that not a right procedure?

I see it, that is enough for adding to the new driver.

It is, with that set it should work, and it still isn't?

No.. buttons on HE device configuration page do not control the device when the password is set.
Side note, I tried a complex password first, than simplified to simple alphanumeric (thinking maybe special chars in the password may be messing things up), but that did not help. When I remove the password in the device web interface and than in HE device configuration, buttons start working again.

I'll invite you to the closed beta, try with that driver instead. Try an all lower-case + number password. There is not supposed to be restrictions, but something could have changed in the platform. I will test some things here. I run with a password on all my devices, and it is not a simple one...

EDIT: I did a test with a more complex password: G3&%FnR5s
This works, adding a "*" to the password does not work since it is not even set as a password on the device.

@landon The device needs to be flashed with the tasmota-hubitat firmware. If you are new into these concepts I would definately recommend reading all documentation first and watch few youtube tutorials (like this example - YouTube)
Having that said, at this point my device failed and is no longer connecting to WiFi. I'll try re-flashing again and will share if I get it working.
While I had device working, I have tried the current 8.1 and new beta Hubitat driver and the new driver is definitely much better interface and seemed to work. With either driver I had one issue - as soon the device tasmota interface password is set, Hubitat would not be able to control the device anymore, even if the password option in HE was configured.