Treatlife WiFi Light Switch

I am working on how to integrate Treatlife's dimmer into Hubitat. Has anyone done this before? I think the design of these switches have great functionality, but can not figure out have to make the work with the hub.

Welcome to the community!

They are compatible with running Tasmota, for which I have written a driver. So yes, they work with Hubitat. Which model?

There is also this thread:

The DS01 model is what I have.

Then there should be no issues.

So I just load the driver into Github and follow that?

I'd suggest reading up on the driver by reading the first post and the last 100 or so in this thread to begin with:

I know it's a lot, but this really isn't something you should attempt without being well informed. There's also the official Tasmota docs:

@RobertLask has the same device as you and may be able to help, he has had some issues that may be hardware related however.

You will probably need to use my unreleased Closed Beta driver, once you've read up on this more, please tell me and I can add you.

I am trying to hookup the DS02 wifi dimmable switches. I cant get the drivers to make the child drivers, or actually interact with the switches. The link for the DS02 has a 404 error. Is there anyone else that have figured out how to set them up with hubitat? Thanks!

You should use the driver found here: [RELEASE] Tasmota for HE - Auto-detecting Tasmota drivers + Tasmota firmware 7.x/8.x for HE (for use with Tuya, Sonoff and other ESP devices)

It can also be installed using the Hubitat Package Manager.

1 Like

Thank you. I followed the instructions. I loaded the driver and used the app to try to add the devices. I made my router provide a static IP for each device and added each switch. But I never get a child driver automatically created. I wasn't sure if it was because Im using the DS02 vs the DS01.

Can you control it from the Tasmota device web page? Not the HE device page. There are some instructions regarding that type here:

Figure out which commands really needs to run to get it to work and I can add them so that the driver runs them automatically in the future.

Ahh.. sorry.. I’m a newbie. I never flashed the firmware to my switch. I will need to figure that out and flash it. I was wondering why I couldn’t get a web page when I connect to the device IP!

No worries, there's lots of good guides on that, also some youtube videos.

Si I recently purchased these and I dont believe they can be flashed anymore from what I've read. I've tried to flash them using OTA with no luck! I really cant flash them all by trying to sauder pins. Does this sound correct?

They can be flashed via either soldering to the pins with a usb serial adapter, or with a 3d printed jig (I've done over 30 of them this way). Best way to get started is watch videos from DigiblurDIY, and also go to that Discord channel. Very very helpful folks there. He even will 3d print a jig for people.

It takes a little effort, but so worth it. I have 35 Treatlife switches or dimmers with Tasmota on them, they are fantastic. It opens a new world to them, can do Node Red for automations directly to them via MQTT, as well as sync them together with device groups.

Good luck, hope you don't give up, it is so worth it.

Hi Rick,
Seems like you have a lot a experience with the TreatLife dimmers. I have been able to flash several of them myself as well except for recently. I have always flashed them with a USB serial adapter as I am pretty comfortable with a soldering iron.

However, I have run into some problems recently. I have several DS02S dimmers that I recently acquired. Upon opening some of them, I noted on the pc board that they were stamped with a 2020/06/23 build date.

I proceeded to make the connections as I have in the past (soldering tx to rxd, rx to txd, gnd to gnd, 3.3v to 3.3v, disabling the nuvoTon MCU from the TYWE3S MCU by grounding the nReset by keeping the restart microswitch pressed throughout the flashing procedure, and grounding GPIO 0 while powering up and a few seconds after booting). I’m pretty familiar with the procedure as I mentioned, I have done several of these in the past.

The TYWE3S seems successfully go into programming mode as no LEDs on the dimmer are active. I can also see the Tx and Rx lights flash on my serial adapter as they always do when trying to flash a new device (I use Tasmotizer). Tasmotizer tries to begin the process and runs for perhaps 30 seconds or so, then times out with the error message “Failed to connect to ESP8266: Timed out waiting for packet header”.

I’ve checked my connections multiple times (again, I have done this successfully many many times, but not with recent hardware). I am wondering if this may be due to the new Tuya firmware that bricked OTA TuyaConvert flashing. I thought that this new firmware only affected OTA, not serial TTL flashing.

Given your extensive experience, have you been able to flash Tasmota onto your TreatLife dimmers recently? For the life of me, I cannot seem to get my new DS02S’s to flash even over serial.

Any help from you or anyone else with recent problems with non-OTA flashing of the DS02S dimmers would be greatly appreciated. TIA for anyone’s input.

For me and many others, the DS01C dimmers need an external 3.3v power source to get them to work. This is because of the MCU it has. I am 100% successful with those with a 3d jig, and using an external power source, 0% with the usb trying to supply the 3.3v. I'm not sure if the DS02s are that way, I have 12 of the DS01Cs.

Instead of buying a bench power supply, I took an old ATX style pc power supply and used it. There are many youtube videos of showing how to make these really nice, mine isn't :slight_smile: It does the job though.

See this link also about shorting out tx/rx from the MCU.

Hope that helps!

Edit: I asked on the DigiblurDIY discord channel, and he said he did not use external power supply but held the reset and it worked. See that link above.

Edit2: Others said they used external power, and this is a very affordable 3.3v power supply via a 9v battery

I'm experiencing the same thing you describe and I have the same date stamp on my PCB. Did you ever figure this out?

Unfortunately, I’ve tried all the methods including external power supply, USB power supply, holding the reset, etc. None of the methods I used before on other DS02S’s seem to work. Not sure what to do. Let me know if you end up getting any resolution.