Turn on lights with a remote

Maybe a very newbie question, but I just got my Hubitat, smart lights, and remote. I have all my lights in Hubitat and can control them. I have also created a group for all my living room lights.

I'm now unsure how to use my Sengled remote to control the lights. Creating rules in Rule Machine or Simple Automation Rules seems to work, but it seems like I have to create a rule for each button on the remote. With 3 buttons that's going to add up to a lot of rules. Is there a way to program this remote in 1 setup?

Here's what my remote device page looks like:

Also I tested creating a button controller, but I'm not having any luck there whatsoever. This is as far as I can get there. I don't see any logical place to choose a button press number.

On the device page for the button device, set the number of buttons in the preferences, and hit Save.

Then Button Controller will give you all of the buttons available to create actions for.

Check out these apps:
Button Controllers
Button Central

My first screenshot is the button device page. I don't see where I would set the number of buttons in the preferences section. There's only two options there right now, unless I'm looking in the wrong area. :sweat_smile:

Doesn't look like the Sengled driver has that option, and since it only comes in one configuration (as far as I know, at least...the 4-button model), shouldn't the driver populate this automatically as part of installation?

@gamerkingfaiz, maybe try resetting and re-pairing the remote (no need to delete it from Hubitat first--a Zigbee-specific trick in that it will recognize it as the same device on re-pairing)? Hubitat staff can confirm from looking at the code we can't see, but maybe that will force it to run a method again that will populate numberOfButtons, something you shouldn't see (but don't) under "Current States." If nothing else, you could try this same thing and also remove the device. Sometimes, depending on the device/driver, hitting "Configure" would also help, but this device apparently doesn't implement that, so not an option you can try.

Here's a trick you can do to fix it. Change the type temporarily to Lutron Pico (from the pull down list), hit Save Device. Set the preference on the device page to 4 buttons, and hit Save Preferences. Then change the device type back to the Sengled Button Controller, and hit Save Device again.

No need or value to resetting and re-pairing the device. Don't do that.

2 Likes

I reset the remote and went to re-pair it in the Device Discovery page, but it states it's previously joined:

The hyperlink just takes me to the existing device page.

I also tried removing the remote from the hub, resetting the remote, and then re-pairing it. Still don't have any additional preferences.

See my post just above. It will get you fixed up.

That's the expected behavior, but per Bruce (above, which you probably didn't see yet when you were trying), that wouldn't help with this device--but his workaround should.

Perhaps I misunderstand your goal. To use one button to control an number of lights you might use either:

  • Scenes
  • Groups

In Scenes you can preset the dim value for each light and they will replicate those dim levels whenever enabled.

I believe the groups only come on at 100% but not 100% sure.

Sorry, I missed this post. Just tried it. I switch to Lutron, save preferences as 4 button, then change back to Sengled and it just resets the preferences. Here's a gif of my second attempt.

Let me know if I'm doing something wrong!

You should be good to go now with Button Controller.

Also, I did it the hard way. All you had to do was hit Save Preferences, and it would have set it to 4 for you with that driver, the Sengled Button Controller driver.

1 Like

Ah yeah, sweet! I see the actions in button controller now--thank you!

Can you post a picture of this device, or a screen shot of the data section in the driver?
I'm not aware of a three button sengled button controller...

Oops, that's a typo on my part. I meant to say "3 remotes". :speak_no_evil:

1 Like

Hi Bruce & @mike.maxwell , This is still an issue. Paired a 4 button Sengled remote, it wouldn't report button presses until I changed driver to virtual button, set 4 buttons, and then changed driver back. Before I did that I had paired & re-paired multiple times to no effect.
FYI- the device is really an engineering failure, there's almost zero travel or click on any of the buttons, very had to know if it actuated or not, so if you don't want to spend time fixing a POS, I get it.

I have no idea, maybe Mike does.

Can you post the data section of the driver and what driver the device paired as? Also a picture of it would help, been a few years since ive worked on these.

Sure
here's the data, which looked the same as the intial pair. It is identified correctly upon initial pairing and auto selects the correct driver " Sengled button Controller "

  • endpointId: 01
  • model: E1E-G7F
  • application: 09
  • manufacturer: sengled


Happy to provide anything else you need.
Thank You guys ! much appreciated

I have this one too and hate the thing. The buttons are mushy and like you say no travel or click. I have Philips Hue ones that are so much better and work great with Hubitat but their price has shot up from $25 to $60 so I'm not sure what the best option is now.

Download the Hubitat app