Troubleshooting z-wave wonkiness

Hi - looking for advice to work out some kinks. Been reading all I can on the forum here and believe I have a pretty clean setup but every once in a while (maybe every couple of days ~ once a week perhaps, I haven't been tracking precisely) I get some real poor response.

Here's my most recent example - this morning I tell Alexa (echo in the kitchen) to turn on "basement lights" which is a group of 4 dimmers, 2 switches, and a plug. Nothing happens... as I am walking down the basement I turn on one switch manually for the stairs then I tell Alexa (echo in the basement) turn on basement lights... some lights come on but a few don't. I open the Hubitat app on my phone to check the status and attempt to turn on the lights that didnโ€™t respond through the app. One of the lights I am attempting to turn on, turns on then off - I must have toggled it as it was finally responding to the voice command. I try to toggle it again through the app and its really slow to respond. I walk over and turn on the physical switch... whatever, I go about my morning routine. When I am done in the basement I tell Alexa (the basement one again) Turn off basement lights - everything responds as it should.

It doesnโ€™t just happen with a particular switch or this group. This is just my recent example.

I listed out my setup in this thread Tell of Z-wave security and mesh responsiveness, I wanna go fast! - #7 by kenrok1

I am running v and only have 3 built in apps installed: Amazon Echo Skill, Basic Rules, Groups and Scenes ... plus one user app: BWA Spa Manager

No ghosts that I can tell. Some of my devices have awkward routes but I've tried repairs and they seem make no difference. Sometimes air-gapping and refreshing will get a more direct route but it of course reverts back after a while.

Does anyone have any suggestions? I am happy to provide whatever detail helps.


Post your z-wave details page in its entirety so we can get a start


hopefully you see that - let me know if there's a better way to share. An export list would be nice- but I am sure this must have been requested by now. :slight_smile:

Your mesh looks pretty healthy. Do you have maker api installed? Are any of these non z-wave plus? Are you doing any power reporting? When this stuff happens what do your logs say?

As @rlithgow1 says your mesh looks pretty good...

Have you updated your zwave firmware? There was a new release a few Hub versions ago. The update was not automatic but is available via an "update" button on your zwave details page.

Do the devices work ok outside of the Alexa automation? And do they work ok when manipulated from the "devices" page?

no sir - just the apps I listed above, and the 3 that are using z-wave are built-in apps
all devices are 700 series z-wave plus (v2 except the Minoston MP31Z)

oh and no, no power reporting

1 Like

yes - VersionReport(zWaveLibraryType:7, zWaveProtocolVersion:7, zWaveProtocolSubVersion:17, firmware0Version:7, firmware0SubVersion:17, hardwareVersion:1, firmwareTargets:1, targetVersions:[[target:1, version:7, subVersion:15]])

as for devices working outside of Alexa... Alexa is usually my first stop but I tried to indicate above that I was getting odd response from the Hubitat app also. devices page would be my last stop, rarely would open it unless I was setting up some automation. Before the rejoining of everything with no security I was having some automation issues where not all devices were working on schedules, but I deconstructed and simplified everything to basic rules and groups too so I'm not sure what all helped in that regard

here's the log during this morning's event- dont know if there's anything here that would give any more insight

The only thing I see, is that you have a Z-Wave mesh that makes many jealous. :slight_smile: Please send me your hub id in a private message so we can take a look at your engineering logs. You shouldn't have latency based on the details you've shared.




Count me in that list... :slight_smile: As @erktrek noted, It's a beaut.

@kenrok1 - what happens if you command the same group of lights from the group device page for the group? Same issues/latency?

What are these by name (or node number) on the Zwave table?

Got your PM and checked your engineering logs. The logs look as clean as your Z-Wave mesh. I cannot think of a reason why you'd have bad experience. One explanation may be that occasionally you may have one or more devices that stop communicating properly. That would explain the need of "air-gapping" the device to get it to behave properly. Finding the device(s) with problems is not an easy task. I would replace those devices that need occasional "air-gapping ".


you guys are a trip :rofl:

... anyway I did not try the group from the device page - only the individual switches from the hubitat app. its random and thankfully only every-so-often so I am sure at this point they would be responsive

these are them:

Can you post the device page of that minostan plug?


I do have the Bar Accent switch direct associated to it so I could probably leave it out of the group and it would still get controlled.

Bar Lights or Bar Side are the ones I was referring to air-gapping and getting a better route.

I was looking for power reporting to see if it had it on... I guess it doesn't support that.

mmmm... I'm wondering if Z-Wave associations have anything to do with it. You're not grouping AND doing associations at the same time are you? Maybe there is some sort of conflict or race condition.