Troubleshooting parse not called for Zigbee power strip

@user5295 hold on, seems that Hubitat engineers have found a solution for these problematic Zigbee devices.

Wait for the next official HE platform update.

Thats really good news.
Unfortunately I've got only till 22nd of May to send them back.
:crossed_fingers: They will fix this issue sooner than 22nd lol

The Beta tests are successful !

We are talking about this device on C-8 hub, right?

Yes it's right

1 Like

Oh, this is a platform issue? I'm not up to date on such shenanigans.

Yes, see the upcoming update announcement

So... I have tried a new update.
Im so frustrated.
I can't even pair my power strip at all. I'm stuck on initializing and that's it. I have tried all of the methods mention and nothing.
Every time resetting the device as advised.
Any ideas?

I will try to repeat the pairing process to C-8 again when at home later tonight, but what I remember is that my first attempt failed also.

What I did was to hold the power button pressed for about 30..40 seconds. Observe the LED, does it blink or flash differently after 30 seconds when compared to the usual 4..5 seconds press that starts the pairing process?

Next, disconnect the power strip from the mains for at least 1 minute.

Then start the Zigbee pairing on the C-8, select the option “try to avoid repeaters”. This is the only pairing option that worked.

Press the power button for 4..5 seconds last.

My understanding is that the device is factory reset only after holding the power button pressed for a very long time, and power cycling the strip afterward. The short press just starts the pairing process, but does not reset the device.

1 Like

Hi @kkossev
Im gonna try again when at home.
Thanks for your help.

I have tried again today.
So far unsuccessfully.
I kept pressing on/off button for long time and haven't noticed any change of frequency of blinking. In fact on one occasion I kept pressing it so long that the pairing went off and that's it. Obviously every time unplugged form electric for about two minutes.
One thing I've noticed.
Sometimes there is a problem for device to be found by hubitat.
I will try again.
Won't give up that easy lol.

@user5295 unfortunately, after deleting the device ("REMOVE DEVICE" red button), I can't pair it again to my C-8 hub :frowning:

Hubitat platform version does not fix the pairing issue with these devices when they are never connected to the same hub before (or deleted).

I thought it was just me and my luck. :rofl::rofl::rofl:

Just spent over an hour trying to connect. No success.
Dammit :face_with_raised_eyebrow:

Do you know if anything is done to fix this issue???

There are a lot of efforts put in lately by Hubitat trying to fix similar Zigbee connectivity issues with other devices (non-Tuya), but I am not aware if any tests have been done with this device particularly, Usually, they need to have it in their lab.

I see.
Looks like my power strip is going back then.

Any news on this?

No news.
There are a lot of reports for other non-Tuya Zigbee devices that are problematic to pair to C-8 and C-7 at the moment, so I don't have high hopes for this problem to be resolved soon.

Do we at least know what is the problem?
Have I just made wrong decision investing in hubitat?

Well, for Tuya and Aqara Zigbee devices support there are no doubts that the best platform is HA (ZHA or Z2M).

For automations I still think that Hubitat is better and easier to use (Rule Machine and webCoRE).


Download the Hubitat app