Trouble with Exclude/Include Inovelli LZW36

I found that firmware updates for Inovelli devices are only working for me using the Z-Wave FirmWare Updater and that requires items to have no security. (I cannot get anything to update using the built in Device Firmware Updater). I'm also having issues with the hub becoming non-responsive and it was suggested I remove all security for all my devices.

When I went to exclude one of my Inovelli Fan+Light, LZW36 switches it wouldn't do it. I got the flashing blue LED when I held button A and tapped button B 3 times, but it was never excluded. I then went into the device and did a Force Exclude, which did make the device go away. I was unable to get it to be re-included, even though I got the same flashing blue LED when I held button A and tapped button B 3 times. I didn't have any trouble including it when I originally did it, and the range test (holding buttons A and B for 5 seconds) gave me a solid green light.

I then rebooted the hub. This time inclusion worked, but it skipped past the part where it asked for the DSK # and Security level. So it was included again with S2. BTW, this device is not being used by any Hubitat rule or an association, so I know those aren't creating any issues.

I'm 1/2 afraid to go through this again in case it doesn't re-include. But if I was to do so, what do I have to do to set it to ask me for the security level?

Use your zwave stick to exclude the switch then try again. The Zwave stick is your get out zwave jail pass. When you forced the exclude the switch still thinks its in your network most likely so put the zwave stick in exclusion mode then exclude the switch.

hmm cross your fingers :slight_smile: I don't think there is anything you can actually do. What you can do since your know how to update firmware using the zwave stick is try to include the dimmer using the zwave stick as a second controller, it might work out better for you.

I don't have a stand-alone Z-wave stick. I only have the Z-wave antenna built into the C7 hub.

I only have Macs, no Windows machines, which I thought meant I couldn't use a Z-wave stick.

Sorry about the misunderstanding :crazy_face:. Just factory reset the dimmer then reinclude you should be fine to do so. Make sure you don't have any ghost devices in the your zwave details page. Ghost devices are devices in your zwave details page that have no in & out clusters.

Thanks. I checked and no ghost devices. I'll try to do an exclude then re-include one more time. If that doesn't work I'll do the factory reset.

1 Like

just make sure the switch is excluded from the hub before factory reset.

Thanks

So I had to do another forcible exclude to exclude it. I then did a factory reset. When I did the include this time it kept stopping after about 15 seconds. After I tried this several times I went into the Z-Wave devices and now I do have a ghost device with S2 security, which I assume is it.

I've tried discover, with and without the switch in include mode, and repair and refresh multiple times but none of those let me get to the device or remove it. Repair said the device was unreachable. Now what do I do?

Did you, by chance, include it with SmartStart the first time? If so, try removing it from your list. (I'm not really sure what happens, as I'm apparently a Z-Wave traditionalist who has never used SmartStart but will have to if Z-Wave LR only supports it. But I digress). See: Z-Wave Manual - Hubitat Documentation, and the "trash" icon should be the key. Just one guess, since it should definitely ask!

I did not use Smart Start. It isn't in my list of devices since I forcibly removed it. I think it is that ghost device, but I can't get it to do anything with refresh, repair or discover.

keep hitting repair until you get a remove option then pull the airgap on the switch then click remove

BTW, I tried to exclude 2 other switches and I could not exclude them either. I saw they said they are being by in dashboards, but I removed them from the dashboards, but they are still showing up there.

if you don't get a remove option try pulling the airgap then repair takes a few tries. when you do get an option to remove make sure the airgap is pulled

1 Like

The ghost device is 0x3C (060).

I tried remove 4 times with the air gap in and then 4 times without it in. Every time I get this sequence of messages:

Screen Shot 2021-04-04 at 2.13.14 PM



BTW, one time it referenced 32 but I don't know why.

ok that looks like a repair not a remove? btw what browser are you using if safari try chrome I've had troubles just like your having when using safari.

I kept doing a "repair" as per the above posts. They said to keep doing a repair until I get a remove option. There is no "remove" option - only Refresh, Repair and Discover. I am using Chrome.

Removing the Dashboard tile that uses the device isn't enough; you have to de-select the device as being available to use on that Dashboard in the first place. The latter must be done via Apps > Hubitat Dashboard (note: "Apps," not "Dashboard"), then the "child app" for your particular Dashboard. That being said, it's not the cause of any inclusion/exclusion issues, just something you should to when removing/excluding devices to avoid messing up any apps that referenced the device.

Have you tried shutting down the hub instead? This will also ensure the Z-Wave radio gets restarted. The typical recommendation is to shut down, remove power for at least about 30 seconds, then plug it back in to restart. Recent fixes should have made it so this isn't necessary anymore, but if the Z-Wave radio got hosed, a regular restart used to not be enough to fix it.

This should say "Refresh," not "Repair."

To all, Shawn was extremely nice and had me call him. He spent well over an hour on the phone with me and we got it resolved (for now/ :-))

1 Like

I just installed my Inovelli LZW36 and it doesn't seem to pair correctly. I copied the latest driver from Inovelli. I included the switch in normal way and it does find the switch and allows me to name it. It doesn't create any child devices and it also doesn't select the driver that I downloaded. I can change to that driver but still missing the child fan and child light devices. I did reboot the hub and tried twice with exclusion and resetting the switch.

any suggestions??

Looks like a "Configure" or a "Save Preferences" in Inovelli's driver should create them if they do not exist.

However, since your device initially paired with Hubitat's built-in driver, I'd do some cleanup first to remove Hubitat's already-created child devices (may or may not work with Inovelli's driver) and whatnot: temporarily switch to Hubitat's "Device" driver (that's the actual driver name), then run the commands to remove all child devices and delete all state (really, nothing here can hurt, but I'd at least do the first). Then, switch to your desired driver and try either of the above to create the child devices.

Download the Hubitat app