Trouble updating Homeseer device with Firmware Updater app

Per the instructions, after uploading a new firmware hex code file into storage, then proceeding to update a device, the app errors out. There is no place to select a device to update with new firmware.

You probably had selected a device in the past which is no longer on the hub. Delete the app from your apps list and then install it again (then press done).

Should work again after that.

1 Like

Thanks! Deleting and reinstalling the app worked in showing the devices window, but the hex firmware file thats in the file manager won't show up for me to select it.

Is there another place for hex files I should be putting it?

Heres the hex file I need to use

If you are using the firmware updater app, you have to upload the file from within the updater app, not directly to the hub file manager. Its also possible it does not recognize ".hex" files, I have only used it with otz or gbl files.

Thanks for the help!

It failed the devices software update auth event.

I'm learning, right or wrong,
Homeseer products required THEIR zwave stick, and THEIR software, to update their products. UGH.
This device is 3ft away from the HE hub.

No more Homeseer stuff for me.

I think the hex files might work with the Updater driver instead of the app. You could try: [GUIDE] Z-Wave device - how to update firmware using the driver method

Unless you have already confirmed it will only work with the Homeseer software?

I am going to edit your post topic to maybe attract some Homeseer users.

I.updated mine there are two versions a 1.x and 2.x depending if the hsm200 has a tab or not.

Also.pair it without security. Too slow with security. Then reboot the hub and try the update with the device only a few feet from the hub.

No joy.

I have ver 2 w/ the tab. It's paired w/o security, rebooted the hub & it's 1m away from the hub

ya that comes up every time.. but then if you let it sit or check your logs you will see it updating.. also look at the zwave logs.

you can also try changing the driver for the hsm to just device.

1 Like

kahn-hubitat, thank you.
Again, no joy.

I did a Z-wave repair, because it was the comm routing was going thru another device, even tho, it was phsyically 1m away. By doing the zwave repair, it's got a direct comms path right to the hub, and I verified it in the z-wave diagram, No luck there.
I changed the type to device, and same error.

I appreciate your assistance.

ya there a pain but keep at it.. i recently just updated two of them.. you can tell if the zwave update starts by looking at the zwave logs..

i have one paired with security and i jsut changed devicer driver to device and also could not get it to start. it is on ve r2.03

i then moved in near the hub and unplugged and pluged it in.. took a couple of tries but then it eventually did start.. the light will flash oraange..

i think the key was unplugging and plugging it in and starting the f/w update during its 2 minute warn up phase..


i believe it is not going to finish though which is the problem i had when it is paired with security .. if the warm up phase times out.. which it does when trying the update when paired securly it fails.. i think i will have to unpair and pair without security and try again..

Thanks. Did it flash orange when you unplugged & replugged or did you do a factory reset & re-add to your network?

no it only flashes orange when it starts updated.. when i unplug and plug back in during the beginning of the warm up cycle it flashes pale pink

i didnt factory reset i just excluded (hit button on side once ) after hitting exclude in hubitat.

then reincluded it wihtout security..

i also noticed enve though it still is in the system after fw update you will need to exclude and reinclude to get it working correctly.. and i had to include with s2 security to get the light to work ...

also light will not work until after the warmup phase (about 2 minutes) is complete when replugging back in.

i am now on 2.08 with this device.. so it can work.. just very finicky.

Thanks. I'll keep playing w/ it, as long as I know it can be done via Hubitat & NOT having to buy something else from Homeseer. Which isn't going to happen.

trying to update the one i had in the basement to report temps and keep the lights on due to motion.. i always had issues with this one and that hasn't changed.. even after removing and re-pairing and having it 3 feet from hub.. after update starts the stupid thing drops connection speed to 9.6k and the update fails and times out.. Tried twice now.. guess i am giving up on that one and leaving it on fw 2.03!!!!