Traveler switch not detected by RM

I came to Hubitat to increase response time in one particular room with motion detectors. My functions were working fine with smartthings and the traveler switch. But RM and hubitat cannot seem to detect when the lights are turned on/off by the traveler switch. Any insight on this or a workaround? Or do I need to go back to smartthings?

Welcome to the community. Help us help you ... What do you mean by "traveler switch"? My first thought was a switch on a garage door opener traveler. But traveler could be referring to a 3-way/4-way switch. May I suggest adding details such as what brand/model switch and motion detector you have? Is the switch Z-Wave rather than Z-Wave Plus, for example. Also, look at the events associated with the devices to see if you can spot the issue (something that is a lot easier to do in Hubitat than SmartThings).

Not to pick at a nit, but I think you mean you want to decrease response time, not increase it. :slight_smile:

As @HAL9000 mentioned above, the brand and model # of your switches is critical to the troubleshooting effort.

My guess is that you’re using either older GE/Jasco switches or Leviton Z-Wave switches... :wink: Both of these are known to have issues reporting physical status changes to Hubitat, such as you’re describing. The Leviton switches can be improved by a firmware update (using tools other than Hubitat), while GE switches require replacements with newer Z-Wave Plus models.

If you have an add-on switch connected, you cannot detect the difference between the lights being turned on by the primary switch or by the add-on. Are you saying that the primary switch is not reporting as being turned on when turned on by the add-on?

Sorry guys. Trafeler/add on switch, I've bought two different ones and don't know which particular one is in this outlet. Either GE 12723 or GE 45610WB. When I flip that add on switch, it doesn't activate the rule that is attached to the main switch the add on is connected to. So, the add on is connected to kitchen main lights, and the rule is looking for when the kitchen main lights are turned on. When I flip the add on, the rule doesn't see the kitchen main lights turned on. Smartthings did.

Does the main device show as "on" in the edit device page? Are the actual lights on?

Yes, and when I use the main switch, everything works as it should.

As far as I know, the GE add-on switches don't have a radio (Z-Wave, e.g.) at all. It just sends change of state to the master switch. So is the master switch Z-Wave Plus?

No, the add ons do not have radios. The main is a zwave. I dont know if its plus or not, most likely not, but that shouldn't have anything to do with this as far as I understand the differences in plus.

I don't have any Z-Wave switches (all mine are Plus), but my understanding is that it makes a very big difference. The Plus switches actively report changes in status back to the hub. The non-Plus switches have to be polled.

Search the forum here for "Z-Wave Poller".

And then after you search for “z-wave poller” and find out how bad it works - throw away the old GE non plus switch and replace it.

2 Likes, when you use the add-on switch, the main switch is turning on in Hubitat? Then it is working perfectly.

The Plus switches actively report changes in status back to the hub. The non-Plus switches have to be polled.

@HAL9000 Not doubting what you are saying, but:
1/ If that was the case why did it work flawlessly....minus the sensor cloud response smartthings?
2/ Correct me if I'm wrong, but the instant "reporting" of the plus as you put it is based on manually clicking the main switch...wouldn't I still be in the same boat if that was the case? Also, these standard switches (I verified that most of mine are the standards) are reflecting their state instantly in the dashboard, it's only when clicking the add on the state isn't showing instantly, it takes about 10 seconds. Also, I do recall, when I clicked the add on while this was connected to smartthings, it reflected instantly on the main switch.

And then after you search for “z-wave poller” and find out how bad it works - throw away the old GE non plus switch and replace it.

@mbaran That would be unfortunate, because I think I would rather go back to smartthings before I'm forced to buy more devices because HE cant seem to handle things in a better fashion., when you use the add-on switch, the main switch is turning on in Hubitat? Then it is working perfectly.

@Ryan780 the switch itself is working fine, the problem is HE is not picking up the add on for 10-15 seconds.

So here is my setup. I have motion sensors in my kitchen with two sets of lights. Main lights, and Cabinet lights. When I walk into the kitchen the cabinet lights turn on. If I click the main lights, the cabinet lights should turn off, or if I click the cabinet lights and the main lights are on, the main lights turn off.
Now follow me here this is the problem, if the cabinet lights turn on and I click the add on switch to the main lights, the main lights will turn on, but the cabinet lights wont turn off (because the main switch doesn't see that the add on was switched on for about 10-20 seconds). If I go to click the main light switch instead of the add on, the cabinet lights will turn off at that time.
Also, If I turn the main lights on by ways of the add on, and then turn the cabinet lights on, the main lights remain on. If I turn the main lights on with the main switch, and then turn the cabinet lights on, the main lights will turn off.
So, the add on switch is not registering in a timely manner. If I was to go that route, would changing the main switch to a Plus really resolve this? Because again, isn't registering the state based on physically switching the particular device?


Check outthis thread. The problem is discussed in detail and should be helpful in your situation.

The use case provides context, but your sentence quoted above is really all we need to focus on. Working properly, the add-on switch should cause the main switch to tell HE that the light was physically turned on or off, whether it was the main or the add-on that was operated. Your testing appears to say that it works at the main switch, but not if operated at the add-on. We can agree it shouldn't be that way, but it is. So let's dig into why.

Could be the switch isn't handling the add-on correctly (if it is an old Z-Wave switch, I wouldn't be surprised). A wiring issue (not as likely)? An incompatibility between the main and add-on? Could be a driver issue (I'm beginning to like this theory)?

Why this worked with SmartThings and not Hubitat is certainly a good question. I vaguely recall some discussion about polling works differently on the two platforms, but since I've installed only Z-Wave Plus devices, it isn't something I paid much attention to.

So we can try to help, exactly what make/model of the main and add-on switch? What driver are you using?

By the way, an easy way to prove to yourself that you're right about the device status not being reported correctly can be seen by going to the Devices tab, then to device in question, then look at Events (refresh the screen frequently). You'll see a log like as shown below that will be useful in seeing exactly what is going on. Digital means Hubitat did it. Physical means the switch was operated manually.

But Hubitat has no link to the add-on switch. The primary switch is the only one that talks to Hubitat. So, I don't understand what you think Hubitat is supposed to do.

This is back in 2016 and this is a quote from an ST staff. I polled the heck out of my GE switches on ST before. Upgraded all my switches away from GE. GE add on switches are a pain!


" Yes the hub itself polls Z-Wave switches and dimmers that don’t send us status reports, and only reports state changes up to the cloud. It aims to poll each one every 10 seconds, though no more than one per second. Unresponsive devices get dropped down to a longer interval.

The GE/Jasco devices also send a node info broadcast when you tap (not hold) the primary switch, for add/remove purposes. This isn’t sent specifically to the hub, but if we’re in direct range we hear it and bump the switch up to the front of the polling cycle. That’s why you sometimes see a quick response but not always.

If you don’t get a state update for a Z-Wave switch within 20 seconds, some things to try are:

  • Hit Refresh in SmartThings to make sure it’s marked as responsive by the polling system. (Note that if refresh doesn’t work, polling won’t either)
  • Make sure there’s not excessive Z-Wave traffic (eg. Pollster) as hub-based polling defers to cloud-based commands
  • Reboot the hub and wait 10-30 seconds for polling to fully initialize before trying again."

Yes....this is true of Z-wave switches/dimmers. Not Z-wave Plus dimmers/switches. I have still not been able to find out what model of switch the primary is. There are a lot of theories flying around but no one is asking any questions to find out more information. Until you have all the information necessary, there is no answer that can possibly be given, just theories.

1 Like

I think those questions are being asked. Just not answered.

I just don't know how we can have a thread about a device that is this long and we don't even know what model of switch we're talking about! I mean, that's crazy.