Thermostat tile not working to set mode and fan

I have an Iris thermostat that I just hooked up today. I put the new tile on my dashboard and started messing around with it. I can set the temperature up and down just fine, and I can take the fan from On to Auto but not the other way around. I cannot change the mode at all. When I go to the device page itself, I can change everything just fine. When I change modes and fan settings on the thermostat they update on the tile. I just can't get the tile to change modes and the fan from Auto to On.

This is on my plate to look at shortly...

1 Like

can you do me a favor?
can I get the following info:
The current driver you're using with this thermostat.
The thermostat part/model number (located on the thermostat's mounting plate, should be something like GC-TBZ48), if its not that, then a picture of the thermostat would do.
a screen shot of the current state section in the driver details (upper right)
and a screen shot of the data section of the driver details (at the very bottom)

The next release will have a dedicated driver for the GoControl version of this thermostat, just want to make sure it's the same unit you're dealing with.
Thanks

There is already a 100% functional user driver for the GoControl version. :smile: Not sure why you would make an in-box one.

Doesn't matter in the end. I'll have to use my user one anyway, as I need sensor calibration exposed as a command/settable parameter, and I'm sure the in-box one won't do that - or most of the other 49 parameters on that device.

Because not everyone wants to install drivers (the OP could be an example), nor should they have to spend time in the community trying to sort it out.

1 Like

No worries. I'm just being selfish.

I'm looking for drivers / driver enhancements that we DON'T already have an acceptable user driver for... Like making GE fans support the dashboard fan template correctly, etc.

Having more in-box drivers is a good thing, in any case. I'll just rename mine to "Enhanced" GoControl GC-TBZ48 driver. :smile::smile::smile::smile:

I will try to remember to get that when I get home tonight. Thanks!

I'm experiencing the exact same thing with thermostats on my dashboard.
Using the built in Generic Z-Wave Thermostat Driver on two Remotec ZTS-110's.


The temperature buttons work just fine but the only mode button that works is Auto. All other mode buttons do nothing.


How do I find the driver information?

Part number - CT101

OK, different thermostat than the one I was thinking of, in any event that should do it!, thanks

I have the same issue. I have two ecobee 4 thermostats using the ecobee app.

When I try to set the cooling mode using the dashboard tile, the log shows the following message:

 [warn] Thermostat mode heat not valid for this thermostat
 [debug](http://192.168.86.70/device/edit/1)setThermostatMode- mode: heat

When setting the mode directly via the device page:

[debug]switchToMode- mode:heat
[debug]setThermostatMode- mode:heat

Here is a shot of the current states (note that this is after i set the mode to heat).

Current States

  • DeviceWatch-DeviceStatus : online
  • coolingSetpoint : 75
  • deviceAlive : true
  • deviceTemperatureUnit : F
  • heatingSetpoint : 70
  • humidity : 66
  • maxCoolingSetpoint : 92
  • maxHeatingSetpoint : 79
  • minCoolingSetpoint : 65
  • minHeatingSetpoint : 45
  • supportedThermostatFanModes : [on, auto]
  • supportedThermostatModes : [off, cool, heat, auto]
  • temperature : 73
  • thermostat : idle
  • thermostatFanMode : on
  • thermostatMode : heat
  • thermostatOperatingState : idle
  • thermostatSetpoint : 70

Data:

  • maxCoolingSetpointFahrenheit: 92
  • maxHeatingSetpointFahrenheit: 79
  • model: Ecobee Thermostat
  • minHeatingSetpointFahrenheit: 45
  • minCoolingSetpointFahrenheit: 65
  • manufacturer: Ecobee

I have same/similar one:

ALSO FYI, after using the new built in driver, I get this error on Zwave repair:

2019-05-01 09:18:20.320 am [error](http://192.168.13.46/device/edit/40)groovy.lang.MissingMethodException: No signature of method: rtcCT101.pollDevice() is applicable for argument types: () values: [] Possible solutions: collect() (pollDevice)

My device details:

  • deviceType: 25601
  • inClusters: 0x20,0x81,0x87,0x72,0x31,0x40,0x42,0x44,0x45,0x43,0x86,0x70,0x80,0x85,0x60
  • deviceId: 263
  • manufacturer: 152
  • lastRunningMode: heat

you will have to remove and rejoin this device to remove that error.

Thank you

Having a similar problem with the Advanced Honeywell T6 Pro thermostat. I can set fan mode to On, but not auto or circulate. Setting from device page works fine. I can set with rules also. Dashboard tile is the only place I cannot set fan mode to auto or circulate.

Download the Hubitat app