Thermostat Scheduler

It seems like my Thermostat Scheduler is stuck in "Control Thermostat Manually" and not following my schedule. I look in my log files and see the changes being made by the scheduler, but the thermostat doesn't change.

Changes made on my dashboard work and show up in the thermostat.
Changes made on the physical thermostat work as well and show up on the dashboard.

I can make changes to the temp manually and they seem to work here.

If I set the mode to away the thermostat turns off as set by the scheduler but when I return it goes back it to manual mode and doesn't follow the schedule.

What am I missing?

Thank for you your help

Look at the logs for the device, or better yet, look at its Events, from the button at the top of the device page. Those logs suggest that Thermostat Scheduler is sending the commands.

I set up the thermostat scheduler for "test2"

This is the result.

Looks like the unit and Value are missing for some reason but the thermostat is receiving the command. @bravenel

Here is the scheduler log file for that event. @bravenel


Installed a virtual thermostat and that seems to be working.
Changing drivers for my thermostat to generic drives didn't fix it.
All manual functions work fine scheduler does not.

Installing my backup and downgrading to fixed my problem.

Radio Thermostat CT101 doesn't work well with the latest update

1 Like

Which drivers have you tried ? .. You mentioned Generic.. Was that Generic Z-Wave Plus Thermostat or just Generic Z-Wave Thermostat ?

Radio Thermostat CT101 driver and Generic Z-Wave Thermostat drive. Both did the same thing.

I could set temp manually via my dashboard, thermostat and the app. Temperature would not follow the scheduled temperature / time set in the app.

Just out of curiosity .. Switch to the Generic Z-Wave Plus Thermostat driver .. Hit configure.. Then re-test..

Just wanted to confirm that was 2.3.1 that you rolled back to?

Yes, currently

I'll install again and see if that Generic Z-Wave Plus Thermostat driver
will fix the issue and report back.


Ok updated to again and I'm using Generic Z-Wave Plus Thermostat driver for my Radio Thermostat CT101. Still having the same issue.

Changes made on my dashboard work and show up in the thermostat.
Changes made on the physical thermostat work as well and show up on the dashboard.

I can make changes to the temp manually in the thermostat Scheduler "manual section"
they work fine.

12:01 pm logs show a heat set point of 57 from the time scheduler

The virtual thermostat setpoint changes but the other thermostat does not.

Value and units are missing from the real thermostat

Value and units show up in the virtual thermostat.


I have the exact same behavior with a ct100 and the generic zwave thermostat driver

Just came across this thread after reporting virtually identical experience in other posts with my Radio Thermostat CT32 using either the CT101 driver or the Generic z-wave driver. The difference in my case is that I only began experiencing issues reported above (and in my other threads), when moving up from or Prior to that time (about two weeks ago) all worked as expected when the Thermostat Scheduler transitioned from one time period to the next. Will be anxious to see that the Hubitat team discovers is the cause.

@bcopeland @bravenel

Hoping to see a solution to this also. I'm sure the guys are working on it. I won't be updating until there is.
I'd be willing to test if needed.

Has there been any progress on this? I see multiple threads with the same issue. I’ve done multiple updates with no change in behavior.

We are still investigating the CT100/CT101 issue. This is a problem that is specific to that thermostat, and involves it failing to respond to two commands sent in quick succession. Specifically, setting a heating setpoint and the thermostat mode in quick succession fails.

There is a work around until we figure out the cause of this: Don't use Thermostat Scheduler to set the thermostat mode. Instead, use a Rule that is triggered either at the same time, or upon whatever event makes sense, and after a 10 second delay, set the thermostat mode. Something along these lines should side step the problem.

We are a bit baffled by what is causing this, but will track it down until it is resolved.


Following up on Bruce's suggestion, I created a RM rule for the morning and evening that sets the desired temperature, delays 10 seconds and then set the mode followed by a 3 hour delay, etc. This works reliably and I plan to use this until the identified issue is resolved in a future update.

Picture 43

I now observe an interesting sidepoint that I'd like to understand a little better. Specifically, it now seems that the Thermostat mode is being set to the setting for the period when the mode changes from night-to-day and day-to-night. What seems strange is that nothing happens when at the transition from evening-to-night around 6:20PM. Actually, with the Thermostat Scheduler in the Hold mode, I wouldn't expect anything to change with the mode transition. Am I missing something, or is the Thermostat Scheduler just injecting a bogus mode setting?

Picture 44

Picture 45

Picture 46

Sure appreciate all thoughts as I come to better understand the household temperature challenges.

Bump for an important function as a new owner of a CT32 thermostat. (was unhappy with the wide 2°F swing of the GoControl GC-TBZ48 I had, and hoping the 0.5° adjust in the CT32 solves the issue).

Honeywell t6 pro z-wave also does 0.5

1 Like