Thermostat Scheduler [RELEASED]

I will look into it.

Thank you!

This feature does not override the minimum setpoint separation feature of the thermostat itself. If the thermostat has that feature, there is nothing that Thermostat Scheduler can do about it. Please clarify.

Let me see if I can find the thread where we discussed this before when you first implemented the required setpoint separation feature for thermostat scheduler.
image

The original request was to allow it to be 0. This was so that Thermostat Scheduler itself was not imposing the separation. But, one imposed by the thermostat is just what it is.

Found it!

You implemented this feature because when thermostat schedule sends both setpoints to thermostat, the thermostat either drops the heat or raises the cool to get it's minimum difference but it does it based on the order that it receives them, not based on which mode it is in. So, right now it's in heat mode and if both are 69, the heat setpoint ends up getting dropped to 66 because it sends the heat setpoint of 69 then the cooling setpoint of 69.

We discussed all this back when you implemented this feature. It's a little disheartening that we have to have this entire conversation again when the feature to fix it was already implemented but is no longer working.

That is not what was requested or what was implemented before. I can restore to 2.1.6 and capture logs if you like to show you that this not how it worked if you like.

Hey, it's been months, and I don't recall the specifics. Also, this part of Thermostat Scheduler has not been touched, so I'm not at all sure what is happening or why there is now a problem with it.

So, yes, please provide specifics as to what changed, prior behavior vs current behavior.

In 2.1.6, if you had a defined required separation,
image
it would modify the "other" setpoint to the defined separation. It would either raise the cool (if you were in heat) or lower the heat (if you were in cool) until the defined separation was achieved. So, if the separation was 5 and both setpoints were 70 and you were in heat mode, the cool setpoint would be raised to 75. If you were in cool mode the heat setpoint would be lowered to 65. Thus allowing the correct setpoint to be used by the thermostat.

In 2.1.7, this setting appears to do nothing at all.

OK, I'll investigate. Probably an unintended side effect from allowing multiple thermostats in 2.1.7.

Thanks.

Could you show me the Settings from App Status page for the 2.1.7 instance that doesn't work.

I had already captured one. :slight_smile:

Is there some one I can speak to about a large project I am working on. I would like to consider using this product

Can you show me the main setup page for TS.

Well, I modified my cool setpoints so I wasn't sitting here in the cold. So, here is both screens.

Also, after hitting apply setpoints, you can see that my thermostat is set to 66 (or 69-3, the minimum difference required by the thermostat.

image

What's very odd, is that Thermostat scheduler still thinks the setpoint is 69. Does thermostat scheduler not subscribe to events from the thermostat?

Correct, it does not subscribe to setpoint changes. Why would it? it is an app to control thermostats, not monitor them. It shows the current temperature from the thermostat, but all of the setpoints shown are the ones being sent to the thermostat.

I would think it would subscribe to the thermostat to see if the setpoint needs to be changed. For example, in this case, the thermostat setpoint no longer matched Thermostat Scheduler. Trrying to reset the setpoint from thermostat scheduler by clicking on set scheduled setpoints did not apply the setting back to the thermostat since thermostat scheduler still thought the setpoint was 69. Shouldn't it reapply it if the setpoint of the thermostat doesn't match, regardless of whether scheduler thinks they should match?

It is connected problem that I describe minutes ago in different topic, please read it

and that is way I've 11 thermostat schedular, when I've tried to set one temp on few trv at one time - it doesn't work (as described above) so I've created 11 scheduler with 1 minute delay between and it works. But when I want to use "away" option built-in thermostat scheduler it doesn't work because HE try to change temp to away on every trv at one time and right now it is a problematic and that is why I need to do it trv by trv not at one time.

Hope that now is clear :slight_smile:

There is a manual setting section if you want to set the thermostat setpoints independently of the schedule. The schedule is applied when the scheduled event occurs. Otherwise, you could end up in a fight with the thermostat. Don't you want to be able to set it manually at the thermostat? And not have TS come along right behind and set it to something else?

Download the Hubitat app