Thermostat Scheduler 2.0 cannot set Heating temperatures

I upgraded HE to and Thermostat Scheduler to 2.0.
In Select Period Settings I can click on the items in the Time, Cool, and Fan columns and change their values. When I click on anything in the Heat column, the screen flickers and a round circle of stars rotates to indicate something is happening, but then nothing happens and I am not offered any way to change Heating to a number, except for the Away item at the bottom where I can change all of Heat, Cool, and Fan. I can't change any of the regular Heating values to numbers.

Browsers: Firefox 104.0 and Opera 91.0.4516.20 under Linux Ubuntu 20.04.5 LTS.

1 Like

If I have the Scheduler control a thermostat, do I have any manual control of the thermostat set point using the buttons on the thermostat, or does the Scheduler continuously send set point temperatures to the thermostat, over-riding any manual changes (which is how the Thermostat Controller works).
I would prefer that the Scheduler only send set point changes at the times given in the table, so that I am free to adjust the set point manually between those times. Is that how it works?

1 Like

Will investigate.

You do have manual control. Thermostat Scheduler only sends setpoints when a new time period begins. So at that time it would override whatever you had set, but not otherwise.

1 Like

Same problem for me. Upgraded to this morning on C-7. Heating column is unresponsive.


This bug with 'heating' in the table has been found, and fixed for next release.


Fixed in 122: Release 2.3.3 Available - #3 by gopher.ny


I am currently running and am unable to get the Heat temperature to reliably set as scheduled. It is currently about 9:30AM and the thermostat Heat setpoint should have transitioned from the Wake schedule of 68 degrees to the 9:00AM Leave schedule of 55 degrees. Doesn't seem like the bug noted above has been fixed in my case. One would think that selecting the Set Scheduled Temperatures box in the App would correctly set the temp that was sent to the thermostat for the current time, but that doesn't seem to work either. Suggestions as to what I might do to test this further?

Post Logs from the app, and show a screenshot of the set up page.

Bruce, not sure what might have happened yesterday and the days before, but the transiton from Wake to Leave this morning worked as expected with the Heat being set to 55. Will keep watching.

1 Like

Well, guess I confused myself last week when the heat came on unexpectedly last week during the day (for the first time this winter). However, after fooling around in frustration and posting the question as to why the scheduled temp didn't change as the schedule moved from Wake to Leave, I pushed buttons, reset temps, etc., to what seemed like to no avail. However, I moved on to other priorities for the day and come to discover that without my poking around, Thermostat Scheduler 2.0 has worked as expected for the past two days, correctly setting the Heat temp when transitioning from Wake to Leave states. Pilot error, I guess. That said, I am still confused about the undocumented "Set Scheduled Temperatures" box in the Thermostat Scheduler App. It doesn't seem to do anything when the thermostat is in "schedule" mode until you also select the "Update" button.

And, even then, the change to the temperature shown for Heat doesn't occur immediately. I initially took this as a bug, but maybe the Hubitat team could explain how to use these two buttons in the next update to the documentation and relieve my stress.

Sorry to have exercised the community when it was probably my issue. And, thanks to Bruce for the quick follow-up.

It doesn't do anything unless there is something to actually do. That is, something about the current thermostat condition has to be different that how the app would set the thermostat.

Some thermostats are pretty slow to respond.

Set Scheduled Temperatures simply applies what is then current mode or period settings to the thermostat right then (if anything isn't set, as above). Update is just like hitting Done, but doesn't leave the app. That button isn't really needed in this app, unless you swapped thermostats, or added a second one. It could/maybe should go away so as not to confuse.

In case it has not been reported elsewhere, I had this on a site after the upgrade to 140. I noted that some sensors were no longer raising thermostat controller events so the controller would not respond t scheduled changes. This was fixed by disabling and then enabling events in the controller. Then the stats fired temp change events and the scheduled temps behaved normally. FYI.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.