Text notification not working anymore since I've added second user


#1

I'm very new to HE, it's been just a few days.

I used to receive notifications (not SMS but regular text notifications) on my phone when I've set up rules accordingly. A few days ago I added my wife as a user and her phone appears under devices as well.
But now only her phone receives text notifications, not mine anymore, even though both phones are checked to get notified.
What can I do? Any ideas?

PS: iPhone XR in case that matters. Phone notification settings are ok.


#2

Still can't get it to work.
I've now set up a brand new super simple rule "contact sensor opens -> send notification only to my phone" and it doesn't work. The opening/closing of the sensor shows up in the log but my phone doesn't receive a notification.
Could it have something to do with the recent hub updates?
As I said, it worked until July 2nd. Phone setting are ok.

Oh, I also signed out of the phone app, power cycled the phone, signed back in etc etc ...


#3

Did you use the same login info on the 2nd device?


#4

When you signed back in, did you select an existing Presence Device from your hub, or did you create a new one? Take a look through your Hubitat Device list to see if the Mobile App May have created a new presence device.


#5

No, I used new login credentials for my wife.
But I’m thinking it might not even have anything to do with the second user because now I can’t get any notification, not even when I want to send to my phone only.


#6

You said that ones to your phone weren't working. So, why would notifications to your phone only still work? Have you logged into the app on your phone to make sure that it is launching correctly?


#7

No, there's only one phone with my name, and another with my wife's name.
I just checked the devices.

BTW, when I pull up the device (my phone) in HE, then click on "Events", it actually shows the sent notifications. I just didn't receive any.


#8

Yes, I have logged into the app on the phone.


#9

iOS or Android device? Do you have notifications silented for that app on your phone?


#10

iOS. iPhone XR. Not silent.


#11

Try rebooting your hub via the Settings web page. Perhaps something is messed up with its cloud registration? Just a guess.


#12

I've rebooted the hub several times already.

This is the log from the phone's notification center. The last notification it received from Hubitat was yesterday at 7:37am.


#13

Do you have a dashboard that you can pull up via the cloud link? That is a simple method to verify the cloud connectivity is working correctly.


#14

Yes, cloud dashboard works without issues.


#15

Maybe it’s time to contact support@hubitat.com?


#16

OK, will do in the morning. Thanks for trying to help, guys.


#17

Hi Concan, did you solve this issue? Because I seem to have the same problem.


#18

Yes, I got it fixed by removing my phone from Hubitat, and then re-adding it.


#19

Thanx for the quick reply. I just tried it, but it didn't work. I think I'm gonna have to ask support.


#20

Same here.
Happened after adding a second user.
Just removed all users and re-added. The test message doesn't arrive on phone.

Just sent an email to support.

The weird part is, not sure if related, the debug info on the app says:
push token: nil
registered: false

I added my wifes' iphone again, and that one is receiving notifications.
I checked the debug info and i see: registered: true
Also a token is present.

Somehow my phone doesn't get a token.