Tale of a stubborn C7 Z-Wave Ghost and the Zooz ZST39 LR Savior

Ok a little melodramatic however it was a victory for my hub.

This has been going on for over 6 months.
A Z-Wave device was physically removed from mesh with no "remove" from my C7 hub, resulting in a ghost device. I don't recall the C7 firmware at the time and I can't suggest why this particular entry resulted in such a Stubbrun ghost.

Numerous attempts to remove using an number of forum suggestions were unsuccessful.
In the meantime I've had another ghost or two (due to failed sensors). These ghosts were easily removed in the normal manner.

I installed the SilLab PC Controller and it too failed. I purchased a C8 hub and now was determined to remove this ghost, even if I had to rejoin all the Z-Wave devices.
So I pulled up SilLab PC Controller again. Still would not remove the offending entry. However this time I noticed a warning suggesting my Z-Wave stick was not capable of the requested action (remove failed).

Hummm... I then realized (or at least thought) the issue was my Z-Stick was too old and having the 300 series chipset was inadequate.

So I purchased a Zooz ZST39 LR with the 800 series chipset. Upon receipt I had the ghost node removed in about 10 minutes.

So that's my ghost story...... now on with the transfer to the C8.

FYI @agnes.zooz


That's good to know.

Thank you for sharing this! We've seen a lot of issues with ghost nodes on older controllers so this use case is definitely helpful to all of us in the community :slight_smile:


To add, I add perhaps a slightly newer stick, but with out of date firmware. Would not remove anything.

Once I updated the stick's firmware, it started working

There were no error messages to suggest 'update the stick firmware', but that was the solution.

1 Like

I can't get any stick to fully include on my C8... it seems to time out. Just about a ZST39 hoping it would work. it gets further than my 500 series stick, but still times out trying to include. =( Was hoping to track down why my ZEN16 won't include on the C8.

I've only been successful with using classic inclusion, and I say that because many use NWI, but I could never get it to work

1 Like

I found while the SiLabs PC Controller was searching for the hub I had to start the hub in a Z-Wave include action. Else it would time out.

I had no issue with NWI for the devices. I followed the "Hubitat UZB Stick How-To.pdf". Step by step worked fine. I did have some trouble loading Z-Wave capability in the Silabs Simplicity Studio, I found I had to login to Silabs to add the PC Controller module.

Link to the SiLabs PDF

1 Like

What do you mean by "while the SiLabs PC Controller was searching for the hub"?

So do an include and let it partially include, then do another include?

I cannot be 100% sure but I believe at this stage (below) I started the hub in the Z-Wave include mode.

I will say when going through the PDF instructions I thought .... boy this is so intuitive I don't know why I need the instructions NOT


Basically the idea is start Z-Wave inclusion on the HE hub first, and then start the NWI process from PC controller.

This is what I do. Just times out.

Used to work perfectly on my C7 and C5.

1 Like

Are you sure the stick and hub are on the correct country frequency? Just a thought.

Yup - I assumed as much, just wanted to clarify just in case.

I'm not having any issues, fortunately for me, but means I don't have any first-hand TS to offer.

Yup. Sorry, don’t want to take over this thread.yes, positive same country. I have another thread talking about issues I’m seeing. Just hoping there’s some issue being worked on that will resolve. Will try classic inclusion (with 800 stick) tomorrow.

1 Like

I've not tried this on my C8. I will give it a shot and see what I get.

UPDATE: I was able to connect to the C8 Hub.


I'd be VERY interested to know:

  1. Do ghost ZWave devices transfer C7-->C8? (I'd guess yes)
  2. Is the C8 any better than the C7 at deleting ghosts?
    (without needing a stick, PC, and 14-page manual)

Put another way: Has anyone had success deleting ghosts on the C8 that the C7 wouldn't?


Not really. Though as previous stated, this isn't a Hubitat issue, it's a SiLabs SDK issue.

Now anecdotally some have been able to remove ghosts after the migration. That said, using a stick is the best way for stubborn ghosts.

I can't help but feel this answer is stuck in time. New Zwave chip, same problem; really?
Is your answer from C8 testing, or the "standard" answer for this issue?

SiLabs and Hubitat can't figure out how to address this? Or is it just easier to keep citing the answer from a couple of generations ago?

I'm a techy guy, so have no technical problem with the stick. BUT, I want to see home automation mature. It'll never become more than a tinkerer's hobby market until such problems are addressed. A non-techy user should be able to click the delete button and feel confident the device will be deleted. This is a solvable software bug. When will someone step-up to see it addressed? Will this be allowed to linger indefinitely?

@rlithgow1 , I appreciate that you're trying to help, but at some point, the answer should become "we're working with SiLabs to address this with a firmware update", instead of the old and tired, it's not our fault. I'm pretty sure the SDK evolves. Maybe this has too and we just don't know?

Download the Hubitat app