Sync multiple z-wave plus plugs

Hi,
I have multiple z-wave plus smart plugs:

  • Aeotec Smart plug version 6
  • Oomi smart plug (which also uses the same driver: Aeotec Smart Switch 6)

I connected them into my LED downlights, but I found they are not sync'ed up properly.
When I turn them on (through an APP), they are turning on at different times (sometimes by milliseconds, sometimes up to 3 seconds).
Similar thing when I turn them off.

I've done a repair z-wave and wait for a couple of days (to make sure the Z-Wave settles); it seems the issue remains.

I read that there is a Zwave association tool, but seems it is targeted for Inovelli devices.

What would be the best solution to this?

Thanks

How are you currently turning them all on/off at the same time? Do you have them grouped using a scene and you are activating the scene?

If the devices support associations you could try setting them up using this ZWave tweaker driver I ported from ST. What this would do if setup correctly is when one plug turns on or off, it would send a command directly to the associated devices to also turn on/off. This could possibly speed it up a little but if the mesh is causing the slow down it may have the same issue.

1 Like

There is no way to perfectly synchronize on/off on multiple zwave devices in Hubitat. There will always be some delay. It is typically in the tens of ms range PER DEVICE, but it depends on how healthy you zwave network is / if there are any retries needed to get the mesasges and ACKs all where they need to go.

As mentioned above, using association groups can yield more synchronous on/off though - where it can be used (association messages only work in direct communication with a device's neighbors and are not repeated, for instance, and devices are always associated once setup so only useful for things you ALWAYS want to operate together). How to configure associations is device/driver dependent.

1 Like

BTW, the inability to send broadcast Z-Wave commands isn't a Hubitat specific issue, it's just not something that Z-Wave supports currently at the protocol level.
There may be some WiFi devices that support this, but currently only Zigbee devices support this across the board.

2 Likes

Thanks for everyone's responses so far!

The way I tested this is, I created a simple rule: when a virtual button is pressed, turn on/off all of the switches:

How can I know whether the devices support this or not?
The following is one of them:





Update: okay, I installed your driver and the following are the results after running some of the scans; I suspect the device does not support association group?



My house is surrounded with metal beams (something like this); I wonder whether this has caused the zwave frequency to work slower in my house.

Interesting enough, when I created a similar rule for zigbee devices, it works instantaneously and sync'ed properly.

I personally like zwave devices (even though they are pricier) than zigbee, because it allows you to set more granular settings (such as the ability to always-on power failure recovery, power monitor, etc); but this delay rather defeats the purpose.

Thanks for this extra info

How much the "popcorn effect" of controlling multiple zwave devices bothers people is an individual taste thing.

Zwave Associations make it much faster, but as mentioned aren't always easy to do. Almost every device SUPPORTS associations (both the Aeotec and Oomi plugs do [association group 2 on both of them], for instance).

Hubitat does not expose associations configuration in any of their drivers, and only certain user drivers do (usually depends if the driver author personally uses associations or not). So sometimes it is a pain to setup as you have to do the commands manually.

As mentioned, zwave associations are an advanced topic - and have a number of limitations, considerations, etc - and work slightly different on different manufacturer's devices too. That's presumably the reason Hubitat does not officially support them - they would raise support tickets/effort (potentially substantially).

3 Likes

Hm...I used the ported driver by @jtp10181 ; seems my device does not have this ability - what do you think?

Interesting fact, thanks! I was under the impression z-wave devices are more standardised (thus it costed more).

They both do according to their zwave certification reports. No idea what that driver does, as I've never used it.

100% of all zwave devices have a minimum of 1 association group - group 1, the lifeline group. It is required by the spec, and is the only way a device knows where to send its messages by default (almost always, to the hub).

Here are the associations supported on an Aeotec Smart Switch 6:
https://products.z-wavealliance.org/products/3093/assoc?noFilename=True

Group 2 would be the one you would use to automatically control other device on/off status.

No idea if any of the user created Smart Switch 6 drivers support configuring associations or not, as I don't have any of those devices. If you want to pursue this, you might want to search on here and see if there are any user drivers for the device though.

That's as much as I know. So I'll bow out now

Good luck!

2 Likes

You may need to set the start and end association scan range, go to the bottom and hit save preferences. Then try the scan again. I would suggest starting with 1 - 5 (most devices support at least 1 & 2, sometimes more for other features.

I really need to clean up the interface of this driver, I really just ported it from ST and barely got it working and this is how it is as of right now. Its not very user friendly yet. Instructions would help also.

You will also need to check the manual for your devices to see what association groups do what. If you only find groups 1 and 2, then I would guess group 2 will do what you want. DO NOT CHANGE GROUP 1!

1 Like

Thanks for your reply! I understand that you just ported the driver from someone else's code and I really appreciate it!
What I have just done:

  1. Put in:
  • parameter scan range (start): 1
  • parameter scan range (end): 3
    Save the preference
    I chose 1 to 3, as indicated by JasonJoel in the above that most likely this device only has 2 association groups (Product Association Capabilities)
  1. Scan Assoc Groups
    Save Device => I might not need to do this, but done it anyway, just in case
  2. Wait for a couple of minutes
  3. Print Assoc Groups
    Save Device => I might not need to do this, but done it anyway, just in case

And the following is the result:

Looking at the log, I don't think this device has association group capabilities:
sync(): Device does not appear to support ASSOCIATION or MULTI_CHANNEL_ASSOCIATION command classes

Interesting concepts, I could go down the rabbit hole checking about this association group OR buy the zigbee devices and move on with life :joy:

You filled in the wrong boxes, those are for scanning the parameters. You need to fill in the Associations scan range as shown in my screenshot (1 and 2 below). You could also just go straight to setting group 2 using the boxes I marked 3 & 4 below. To set the association you would fill in 2 for the group (in box 3) and then you have to look at the zwave details to get the hex ID numbers for the devices you want to associate, which will be shown as 0xHH, the HH part is the hex you need to fill into box 4 with multiples separated by a comma.

After it is set I would run a scan again to confirm it took it.

2 Likes

Download the Hubitat app