Support for GE Appliances (SmartHQ)

It looks like you have a partial update of my package -- you installed from HPM, correct? Please do a repair and then update in HPM.

FYI, Iā€™m not seeing this, but Iā€™m on the tin standard, not the gold standard as you are. Still gathering refrigerator data when my wife lets me take over the kitchen.
SmartHQintegration 0.9.2 installed via HPM 1.8.7.

1 Like

Hey! Thanks for doing this, @tomw ! I'm trying to install this from HPM (selecting only refrigerator), and I'm getting this error:

When I try to install https://raw.githubusercontent.com/tomwpublic/hubitat_SmartHQ/main/smartHQ_system manually, I get this:

Help? Thanks!

What version of HPM are you on? You need version 1.8.5 (or newer) because I use a Bundle in this package, which @csteele recently added support for in HPM.

1 Like

It looks like I'm on 1.8.7, and HPM isn't prompting me to update any packages.

I am a bit stumped, then. Did you recently update to 1.8.7? You might want to try a Repair on the hubitat_SmartHQ package in HPM. Do you have that library installed in Libraries Code or any evidence of the bundle in your Bundles section in Hubitat?

1 Like

I just gave this a try... I don't have anything this code would work with, but I can at least test HPM :smiley:

It worked fine, of course. Always does for me :frowning:

Screen Shot 2022-07-13 at 3.24.43 PM

app:4 2022-07-13 03:24:04.033 pm info  Installing SmartHQ Refrigerator
app:4 2022-07-13 03:23:58.443 pm info  Installing SmartHQ System
app:4 2022-07-13 03:23:56.577 pm info  Installing hubitat_SmartHQ
app:4 2022-07-13 03:23:56.307 pm info  Downloading SmartHQ Refrigerator
app:4 2022-07-13 03:23:56.207 pm info  Downloading SmartHQ System
app:4 2022-07-13 03:23:55.932 pm debug Install beginning
app:4 2022-07-13 03:23:55.929 pm debug prefInstall
app:4 2022-07-13 03:23:51.599 pm debug prefInstallVerify
--- Live Log Started, waiting for events ---

I looked in Library code and there it was...

and there was a Bundle too, showing that's how the library got added.

3 Likes

There should be two libraries. Do you also see smarthqHelpers @csteele?

1 Like

You're right :smiley:
Both are there.

2 Likes

That did the trick. :grinning:

2 Likes

One thing I'm struggling with is getting the Smart AC set up as a thermostat for use with Sharptools.
I'm using Advanced vThermostat Manager to control my dumb knob ACs (Office and Guest Room "thermostats") since it just turns the smart plugs on/off based on some Aqara temp sensor readings, but I dont think it would work that well here since the only function AvTM can do is turn the power on or off.

Using the device in Sharptools as-is only lets me cycle through the fan speeds, but doesn't provide any option to display current temp, change setpoint or operating mode, or power it on or off.

Any thoughts on how you would integrate this device into a dashboard? (Totally understand that this is not the Sharptools forum!)

image

I didn't support the full capability "Thermostat". There's a LOT there, including some things that are probably not supported by all devices and that are usually hard to get "right". I went with a more basic approach as a first pass for this integration.

@josh, could you advise on which capabilities and commands are required to have a relatively complete experience in SharpTools?

@snackpickleson, I'll ping you back on PM to see if we can add enough more to make it more useful to you.

1 Like

I didn't have any evidence of SmartHQ installed anywhere (HPM, apps code, drivers code, bundles, etc). I still couldn't get it installed via HPM. I was able to work around the problem by manually installing the bundle (giving it the URL listed in packageManifest.json), and then installing the drivers with HPM. Seems to be working now. Thanks!

@tomw A request: Can you please add turning on and off "Sabbath mode" as a feature for refrigerators? Thank you!! Here are some logs (turned on at 10:15, turned off at 10:16).

dev:4682022-07-14 10:16:17.911 am debugparse: {"item":{"applianceId":"D828C9B56A78","erd":"0x0009","time":"2022-07-14T14:16:15.708Z","value":"00"},"resource":"/appliance/D828C9B56A78/erd/0x0009","kind":"publish#erd","userId":"xi2ndaa8sadfxgd"}
dev:4682022-07-14 10:16:17.820 am debugparse: {"item":{"applianceId":"D828C9B56A78","erd":"0x1016","time":"2022-07-14T14:16:15.708Z","value":"000001FF"},"resource":"/appliance/D828C9B56A78/erd/0x1016","kind":"publish#erd","userId":"xi2ndaa8sadfxgd"}
dev:4682022-07-14 10:15:45.925 am debugparse: {"item":{"applianceId":"D828C9B56A78","erd":"0x1016","time":"2022-07-14T14:15:43.493Z","value":"000000FF"},"resource":"/appliance/D828C9B56A78/erd/0x1016","kind":"publish#erd","userId":"xi2ndaa8sadfxgd"}
dev:4682022-07-14 10:15:45.848 am debugparse: {"item":{"applianceId":"D828C9B56A78","erd":"0x0009","time":"2022-07-14T14:15:43.493Z","value":"01"},"resource":"/appliance/D828C9B56A78/erd/0x0009","kind":"publish#erd","userId":"xi2ndaa8sadfxgd"}

That's a weird one. Seems like something got out of sync, since it works for myself and others. I guess we'll see if it is really fixed when you try to upgrade to the next version. :wink:

Sure, I can add sabbath mode. I am not really familiar with that functionality. It looks like it might apply to multiple appliance types. Can you explain what it does so that I can add it in a place that will apply wherever it might be useful?

HPM does not inspect code. If HPM's DB has an entry for the package, then it believes its DB. If the package has 5 pieces, none optional, then HPM believes its DB and assumes 5 are installed. If you manually delete one of the 5 pieces of code, HPM continues to believe its DB and won't fix it. That's what Repair is for, HPM doesn't check the code, it simply downloads/installs the package again, overwriting what might be there.

If there's a solid square at the right end of the displayed package:


then HPM has the package in its DB and won't permit it to be installed. Repair is the mechanism to use in that situation.

  • Screen Shot 2022-07-14 at 7.49.16 AM

  • Screen Shot 2022-07-14 at 7.51.12 AM

I just now tried this to confirm: Manually deleted the SmartHQ bundle and manually deleted the two Library files. I then checked Update and there was no update available (HPM believing its DB) I then did a Repair, and after, was able to see the Bundle was back and Library Code had both back. :slight_smile:

1 Like

Yes, it applies to several appliance types, but the only smart one that I personally have is a refrigerator. (Just bought a U+ Connect this week!) Essentially Sabbath Mode is a way of accommodating people with certain Jewish practices so that they can use their appliances on the Sabbath in ways that are permitted according to their practices, without running into activities they may consider forbidden, such as turning lights on and off. In older fridges, I might have unscrewed a light bulb on Friday afternoon and screwed it back in on Saturday evening; with this fridge, that's not an option, so instead I activate Sabbath Mode (either with a manual button combination, or now through the app), which turns off the lights and also disables the water dispenser and a couple other things. Similarly, Sabbath Mode in ovens will disable the oven light, disable the digital display, cause the buttons to respond in particular different ways, and things like that. It's a key feature for some Jewish people (though unfortunately, a smattering of other people run into it by accidentally activating it, even though doing so is difficult, and then thinking their oven or fridge is broken in very strange ways).

1 Like

OK, that is really helpful. Thanks for the explanation.

I will add it to refrigerators and ovens to start. I'll PM you something to try first just to make sure I got it right. :wink:

1 Like

We're basically looking for one (or more) of:

  • Thermostat
  • Thermostat Heating Setpoint
  • Thermostat Cooling Setpoint

I'll send you some more details via PM as well. :slight_smile:

1 Like

I just posted v0.9.3, which adds Microwave support (thanks @gassgs for your testing and feedback) and a Sabbath mode command for refrigerator and oven (thanks @joshr for your suggestion and testing help).

2 Likes

Download the Hubitat app