Super slow/non-responsive devices

So I've been having one issue that I keep posting but never seem to get any definitive answer to - which is that sometimes my switches that are only connected via a neutral and line, and are being used in a virtual 3 way, take like what seems 20-30 seconds to turn on, or else just never turn on at all. Likewise, I have the same issue with the config button on the Inovellis having the same issue. I don't have any issues with switches that are controlling the actual lights directly.

What I'm totally unable to figure out, and which I've never gotten an answer to, is what is causing the problem? Are the switches not sending the proper command to the hub? Is the hub not reacting to the command properly by failing to send it to the switch? Is the receiving switch not responding to a properly sent command?

Virtually all of my devices are Inovelli Red Dimmers with 5 of their fan+lights, a couple of Aeotec 7 Range Extenders and a couple of Aeotec 7 plugs. I am using a Hubitat C7 hub running 2.2.7.126. (I am mentioning the other equipment just to give a complete view of what I have).

I tried a Z wave repair. That seemed to help for a very short bit. I tried turning off energy reporting (setting param 18. Active Power Reports to 0). That seemed to do nothing.

After doing the above the situation was as bad, if not worse than before, particularly with a couple of switches. Alexa would also say "ok" but then not do anything when I said to turn those lights on.

So I did an air-gap on those devices. That seemed to work for a day or two.

As they started misbehaving again I even did a controlled shutdown, and then pulled the plug from the wall (not the hub) waited 30 seconds and then powered up again. That didn't seem to help at all either.

I did notice that once they do turn on, they seem to turn off rather instantly and then, for a while, will turn on virtually instantly. So it seems like the turn on command is either not being sent properly to the hub or the hub isn't properly sending it to the switch that is physically connected to the light or the receiving switch isn't properly reacting to the "on" command.

I usually see the LED go up to 100% when I push the switch, but the light is not coming on - or again - takes an insanely long time to come on. But, not always. Sometimes pushing the switch to turn on doesn't even make the LED show it is on.

I am using Switch Bindings instead of an association as the red dimmer called the Wegitorium is controlling the light on an Inovelli Fan + Switch, which will not work via an association (like I could with 2 red dimmers). I'm also using Switch Bindings as it seems there are no real clear instructions on doing an association with Inovelli red dimmers as at first it was associate "groups" 2 and 4, now it seems to use 3 and 4, and it isn't clear which dimmer should get param 12. Association Behavior set, and what to set it to. (And even if that would fix my (Stuart's) closet, I would still have the problem of not being able to do an association with the red dimmer and fan+light). BTW, all of this had been working for a good couple of months. So I don't know why it started to become so problematic.

I don't know how to really read the logs but here are a few shots of what happened when I tried to turn the Wegitorium and Stuart's Closet Near Right Side on. If more/other screen shots or setting info is needed, I will, of course, be happy to post those as well.

Can you post a copy of your z-wave details page? And do you have any zooz stuff installed?

1 Like

No Zooz stuff. These are my Z-Wave details:




Overall your table looks normal (I was thinking ghosts) You do have a lot of super slow things in your mesh that should have a higher rate. Maybe adding some more beaming repeaters in will help. (I'm looking at those 9kb things)

2 Likes

I would recommend running a repair on those specific devices. I was surprised to see any 9.6 kbps devices considering that all of @Stu_The_K’s devices are zwave+.

3 Likes

Depending on a couple things like metal boxes, and distance to hub as well as other stuff in the walls on the way to the hub or next hop could also be causing slowdown. But yeah a repair on the individual stuff may help.

2 Likes

I did notice 1 thing, and that is 0x60, the Palm Room Ceiling Fan and Light, was not showing any speed. I've tried using the Repair button several times, but it says it is unreachable. The physical switch does turn it on and off. (It is an Inovelli Red Series Fan+Light). If I use the Dashboard in the mobile app I just get an hour glass, but nothing happens. If I go into the child app. on my Mac and click the "off" button I see it sends the below command, but nothing happens;

I air gapped it and now it is showing up.


And it is working via the app.

While I saw 0x60 in several clusters, 60 wasn't appearing in any routes, so I don't know if that was part of the problem or not.

FYI - cluster numbers reflect capabilities/command-classes supported, and not the devices that any particular device is “talking” to or routing through.

I had thought they had nothing to do with the routing.

But, besides solving the immediate problem, this brings me back to my original, ongoing question that no one has ever really answered for me: What causes these to simply not respond in a reasonable time period, or in some cases, not at all? Is this the dirty secret about Z-Wave (and maybe Zigbee and/or all home automation?) that none of this stuff is really 100% ready for prime time yet? Or is there a source of it all, like the switches or the hub or Z-Wave itself? I'm not trying to point fingers, but I am trying to understand it. It certainly kills the acceptance factor when a light switch doesn't come on for 30 something seconds, or at all, when we've all grown up with them coming on instantly.

Are we all driving around in pre-Henry Ford horseless carriages where only ones that work really well virtually 100% of the time (from what I've read) are much more expensive than the rest (and I"m thinking Lutron) while the affordable ones still have issues all playing nice together or else, just aren't up to snuff yet? Does anybody have an answer (or even a guess)?

1 Like

You can read lots and lots about zwave here, and come to the conclusion that zwave is garbage and no one in their right mind would use it. But there are plenty of people here (and elsewhere) who have few (or no) problems with it. I am not one of those people. Most of my issues have been because of specific devices (the dread zooz 4:1 sensor, for instance) or ghosts created by devices that won't pair correctly. At this point I may have as many zwave repeaters as I do zwave devices, and everything seems more or less OK, but I do sleep with a zwave stick under my pillow. I had similar issues with Wink / ST so I don't blame HE, but I have read that the silicon labs ZWave 700 stack may not be winning too many awards for stability. I do not have the same problems with zigbee. (In full disclosure my house is lath-and-plaster construction, invented by Michael Faraday himself.)

All of my switches are Rolls-Royce-Lutron. Don't care about the cost, never looked back. Never, ever had an issue with a single one of them, ever. Except when I fat-fingered the integration configuration. I asked Alexa to turn on the kitchen table light and the front porch fan came on instead, but it did it quickly and reliably. And of course my house was built before wiring, let alone before wiring with neutrals. In fact if they made a Lutron switch for gas lighting I'd be golden.

Perhaps I am reading too much into it, but it looks like the new ZWave LR standard has moved away from meshed networking technology.

1 Like

In my experience, Z-Wave has always been prone to traffic related delays. Routing, flooding, speeds... all affect response times. It's the reason why I moved my home over to Lutron and haven't looked back.

I used to be a Z-Wave champion for frequency, range, etc. No more. Just wasn't worth it to me to spend hours and hours troubleshooting all to have it happen again days later. I've minimized my Z-Wave footprint and been happier for it.

1 Like

That is applicable to devices within a mesh, not only between protocols. If you have devices at the outer edge of your mesh, regardless of the protocol used, you will experience latency. Some protocols handle "spotty" devices better than others. Z-Wave is probably at the bottom of the list when it comes to problematic devices. One or more unresponsive devices can introduce significant latency and could cause missed events. I would focus on node 60 to make sure that is connecting to the hub and maintains a good connection, it may be a problem with the device itself.

In your particular case, running a full Z-Wave Repair may resolve some of the issues observed.

Check this newly released video for more details about Z-Wave and Zigbee networks:

1 Like

Thanks all. I never went with Lutron for several reasons: 1) The 3 way is only the Pico remote and I didn't want something relying on batteries; 2) There is no favorites button on their main switch (like on the Pico - and it drives me (and seemingly a lot of people) crazy why they haven't added it to the Caseta line in all these years). THE #1 thing I use my Inovellis for is the config/favorite button to turn lights on to a dim level late at night or early in the morning; 3) No multi-tap. While I'm pretty sure I could live without this, if I also had a favorites button, it is nice for the couple of places I actually use it; and 4) Price. IF the Caseta line had a mains powered 3 way and a favorites button and was as stable as I hear, then I would pay the price for them.

1 Like

Just a note. I've had my pico's for around 8 years and I've not changed one battery. Not saying they won't eventually need it, just saying is that they last a long time.

2 Likes

That's very reassuring, but the lack of the favorite button is the real deal killer. I have a bunch of switches that are not 3 ways so a Pico wouldn't help.

1 Like

Reliability is subjective. It greatly depends on the mix of devices, environmental factors and a grain of luck. There are success stories with all protocols. I, for one, have a house full of Inovelli and wouldn't replace them for Caseta. In fact I started my Home Automation journey with all Lutron and gradually moved to Z-Wave/Zigbee (that was long before Hubitat Elevation existed). I have nearly 200 devices and a mix of 40% Z-Wave and 60% Zigbee. Never had a problem since I moved my production hub to C-7 model. I guess that grain of luck is playing in my favor :wink:

3 Likes

Hey if you have any of the caseta left you want to get rid of...... :stuck_out_tongue:

2 Likes

You are about 6 years too late lol

2 Likes

Guess so, because I've never gone more than a week or two at most without something not working. My Alexa goodnight routine is supposed to turn off my home theater system (which it does without fail) and also turn off 7 lights and turn on 2 lights for 2 minutes. It virtually aways turns off everything OK, but is very hit or miss as to whether or not it will turn on 1 or both lights and how long it takes to turn them on. It is supposed to wait 1 minute and then turn those 2 off. Again, it is very hit or miss if it does. I've tried putting in some time with Alexa between steps and rearranging the order, but have never found one to be reliable for any length of time. Even worse, is how often even basic controller rules, which I have for all my Inovelli config buttons and the 3-4 3 ways I have, won't work for 20-30 seconds or don't work at all.

Today I had to air gap the one in the Palm Room (see above). I know all smart phones and computers, etc., still need to be/should be rebooted every now and again, but feels like I"m back in the blue screen of death days when it was a regular occurrence instead of a rarity.

Download the Hubitat app