Sunset action did not trigger today (post Spring Forward)

I created a new rule yesterday afternoon to turn on outside lights at sunset. This worked yesterday (I left and when I came back the lights were on). However, no dice today. As far as I can tell, 6:43pm was sunset today where I am. The hub time looked to be a couple of minutes off from my PC time (when are we getting ntp?), but I couldn't see anything in the logs to indicate anything happened.

I believe you should have NTP unless something in your network is blocking it . . .

My stuff triggered at the correct time here (US EDT).

Ok, I didn't see any ntp settings. If they're automatic they should work.

Glad to hear it might just be me then.

It something in HE time zone hour change

I posted the same here

It should work tomorrow correctly

Interesting! Was it an hour off (as you might expect)?

Great! I figured it was something wonky with the change.

Ya mine seemed off too. My weather app had sunset set to 6:40 but everything else I checked said 7:15 so not sure exactly what is right. I figure tomorrow it will all be corrected.

I didn't see anything in the logs for 5:43 or 7:43, but I had manually turned the lights on around 7:00.

I'm not familiar enough with the logs (yet) to know what I'm looking for.

If you check the location in the settings you should see what the sunset and sunrise is set to.

Interesting, 8:36pm... 9 minutes from now.

That ain't right...

I just redid location, hit update and now it's 6:43, the correct time.

I have two Simple Lighting rules that run 45 minutes before sunset one executed correctly the other did not. I tried opening and hitting done but it still won't turn on. The light is responsive both manually and through the device settings

Both rules have been working without change for 6-8 months at least


Yep, same with mine... Didn't trigger even after the correct sunset time tonight. I'll give it a day and see what happens tomorrow.

+1 here. Shocking that they would not have this thoroughly tested.

I also had this issue today. Rules based on sunset all triggered an hour late. Seems daylight savings time was not accommodated. When I go to settings>location, I see that the sunrise/sunset times are correct. So does that mean the internal hub clock did not adjust for DST?

Mine (time) keeps drifting... Which is why I asked about ntp. We should be able to set up our ntp servers via the web or sync to a local ntp server if off grid.

Time in general is hard programmatically, but things should get wonky around 3am when the time shifts (having two "3am's", etc.).

My clock is correct, but the sunset event triggered an hour late, and 2 hrs later than yesterday. Yesterday it was 17:40, today it should have been 18:40, instead it fired at 19:40.

This is my third time change with Hubitat, and third time that it didn't adjust correctly. This was supposed to be addressed last spring, but doesn't appear to work. I believe that clicking update in the location settings more or less fixes it, but I can't confirm until tomorrow morning.

1 Like

I believe even after updating my time and hitting update like you’re suggesting the sunrise and sunset are not updating.

The time in the hub did....