Subscriptions - How to cancel?

Ok, I feel really dumb having to ask this, but I'm going around in circles trying to figure this out. I signed up for the free trial of the remote admin about 8 or 9 days ago. I've already decided that I don't need/want to use this, so I am trying to cancel this before my free month is up and my credit card gets charged.

How do I cancel this? I can't seem to find the way to do it. I keep looking at "My Account" and "Subscriptions" but it just keeps taking me to same place where I can connect to my hub.

  1. Go to https://my.hubitat.com/ and login with your username (email address) & password
  2. Click on Subscriptions
  3. Click on "View" (green box)
  4. Click on "Cance Subscription" (green box)

Please refresh the browser, then click on "Subscriptions" again. If your problem persists, and it keeps throwing you on "Registered Hubs" page, please send us an email at support@hubitat.com and we will cancel it for you, as well as further investigate why this happens.

2 Likes

Thanks. Yeah...this is where I thought it would be, but after click on "Subscriptions," I don't see the green box labeled "View" that you mention. Here is what I've got:

Then in the upper right corner all I have is this:

@bobbyD any updates on this? I see the same thing maxq10 does. Both the "Subscriptions" and "Registered Hubs" cards take me to https://my.hubitat.com/hubs. There's no way to get to my list of subscriptions.

Could you please try to refresh the browser manually? I haven't been able to replicate the problem consistently and the number of reports are very low, so that makes it harder to identify the root cause so we can fix it.

I've refreshed the page multiple times (hitting Ctrl-R). Is there some other refresh method you're talking about? I tried an Incognito window too in case it was some cookies problem, but I see the same issue.

Browser is Chrome 91.0.4472.123.

1 Like

Very odd, please check your PM.

I have the same thing going on. Go to subscriptions and it takes me to the /hubs page with no options regarding the subscriptions. Tried in Chrome, Edge, and Firefox. Tried refreshing the various pages. Don't ever see a "View" green box on any of the pages.

I tried to locate your subscription/hub by your community email but it appears that you may have used a different address. Please send me a PM with your hub's MAC address or the email that the hub is registered so we can further research.

1 Like

Please try holding shift and then click refresh. This will flush the page cache and reload it.

Yep, I accidentally used my work email address when I set up my hub. I'll shoot you a PM

I have the same problem - no green box.

Another thread said the phone app might work - it worked for me.

So when you select Subscriptions card, it takes you to "Registered Hubs" instead of subscription details?

Download the Hubitat app