Stuck on adding new GE Z-wave motion sensor

C-7 Hub:
Device: GE Z-Wave Portable Smart Motion Sensor 34193

Yes, this device is not listed in the compatible devices list, knew that going into this. However found several posts here in the community with success including sharing of a custom driver to control the motion sensor. I have that driver loaded and ready.

The issue. When I include the sensor on the discover new devices screen it shows the new device but gets stuck at "Initializing" and never allows me to save a device name. I then go to the Z-wave details page and the device is added, says OK, and displaying all the normal data. However It will not let me "Discover" the device so I can add a name and assign the driver. It looks otherwise normal with neighbor info, route, etc.

I can exclude the device no problem and have tried this process of include/exclude half a dozen times with identical results each time. I've done this with the sensor sitting right next to the C-7 hub.

This is a ghost node (no in, out clusters). Unsuccessful pairing. It needs to be removed. Not a bad idea to reboot the Z-Wave radio (shutdown to red light, unplug at wall, not fragile mini-USB connector, power up after 30 seconds).

Thanks for the clarification this is technically is a "ghost mode" as I was fuzzy on exact what they look like.

So I excluded, did the 30 sec power down and powered up. I knew about that and should have tried earlier, it did work, however with a caveat. I was only successful when the sensor was within 1ft of the hub. I could not get the sensor to include "network wide" from it's final install location. That concerns me because the sensor is now taking a direct route to the hub which will not be ideal when installed in its final location. I hope over time it changes the route, even though it's battery powered and doesn't happen very well.

Well, try a node repair (just that node). That could hasten new routes. Just before the repair, trigger the sensor to wake it up.

Was thinking the exact same thing, will give that a try. Thanks again for all the help!

1 Like

P.S. This Z-wave motion sensor has VERY impressive response to motion trigger events. I tried a couple other Z-wave motion sensors before switching to Zigbee versions due to slow response. Glad I grabbed a couple of these on clearance (50% off at Jasco).

1 Like

Totally agree. These are great sensors. I have four in service and I bought four more about a year ago when they were on sale at deep discount. Just tried to put one of these new ones in service today. Unfortunately, I have not been able to get it to pair either. I can include and it detects, but gets stuck on initializing. I can exclude it and try again, and I get the same problem. I excluded it, did a factory reset on the sensor, removed two ghost nodes, powered down the hub, waited 30 seconds and restarted. Put the sensor 1 foot from the hub and tried again. Still stuck on initializing,
Also note that I did add a garage door tilt sensor and a door closure sensor successfully before trying to add the GE motion Sensor.
Nonetheless, I tried once more. Power down to red. Unplug for 30 seconds. Factory reset sensor. It was stuck on initializing again. So when the count was down to about 30 seconds, I pressed the sensor button once again and poof, it successfully added. I'm guessing that this is the trick to get the sensor to add. After the device is detected and it is stuck on initializing, wait a little while and then press the button on the sensor once again.