Stuck on initializing

Ive got two different sensors that will not pair for the life of me. One is the GE/Jasco motion sensor, and the other is the Sensative Guard strips. When I try to pair it, nothing happens on the 'Device Discovery' page. But if I wait a couple minutes and go into the 'Z-Wave Details' page, there is a new node that says 'OK', but has no name and nothing on the 'in/out' section. I can't click on it to change the driver or do anything. Sometimes when I click refresh it will change to pending. But I've waited like 3 days and it never changes or updates. I have tried resetting, excluding, removed batteries, etc and get the same result. I don't have any ghost nodes showing in my z-wave details. Have reset, shut down, unplugged the hub and have done a z-wave repair as well. Any advice on what can be done to get these paired?

Yes you do.

That’s pretty much the definition of a ghost node - no in, out clusters.

1 Like

Ok. I don't have any other ghost nodes. I understand that ghost nodes can stop a device from pairing. But the actual device I'm trying to pair is what you are calling the ghost node. So I would not consider it a ghost node, its a pairing that is failing. It happens immediately after I pair and I can remove it no problem with remove, but the issue is that the device will not pair. Looking for other reasons it may be failing.

It’s failing at least in part because of that ghost node. You need to reboot the Z-Wave Radio (shutdown hub (Settings > shutdown) to red light, remove power at wall (not at micro USB, which is fragile and can break at the solder joints to the PC board), power up after 30 seconds), then get rid of it (hit Repair several times until Remove button comes up). You will not be able to remove it if the hub can ping it, so remove power to the device while trying to remove. Then power the device, and do a factory reset of the device (how to do this depends on the device).

If you are able to remove the node, then still need to reboot the Z-Wave Radio (see above) and reset the device to factory defaults (see above).

Then try to pair again.

I can remove that node no problem. Ive also tried resetting, shutting down, and removing power in exactly the sequence you described above with no success. The issue isn't that there is a ghost node (I've dealt with that plenty and have a zwave stick to deal with them), its that the device creates a ghost node any time it tries to pair. It can't fail pairing because of the ghost node if the ghost node isn't created until I pair. And the same thing happens with both devices.

Got it. The one step you didn’t say you had done is the reset of the device to factory defaults before trying to pair again.

@bommar2 See my post below from just the other day where I had this exact same issue with GE motion sensors. Every time I tried to include the motion sensor would result in a non-initialized ghost device.

@672southmain helped me in that thread as well. The solution for me was two-part; 1. power down and unplug power to the HE hub for 30 seconds to clear the Z-wave radio, 2. power back up and bring the sensor to within a foot of the hub when you perform the inclusion.

When I did that I was able to successfully include/initialize the motion sensors and assign the custom driver I downloaded from the community. The sensors are working perfectly!

1 Like

I understand that many in the community are insistent that it’s not necessary to bring the device very near the hub to do inclusion, and that NWI (Network Wide Inclusion) should work. Perhaps, but NWI has never worked for me. I either have to bring the device to the hub (battery powered devices) or the hub to the device (mains powered devices).

I suspect bringing the hub to the device (long Ethernet cable) is the better approach because, at least then, the device sees its neighbors, and the only false neighbor is the hub, and that’s correctable by a node repair, or by just waiting for the network to re-route automatically.

Thanks for the suggestions but I'm getting nowhere. I just tried again. Removed the ghost node. Powered down. Unplugged. While it was unplugged I reset the device by clicking the button 10x. Plugged back in about 5 minutes later. Went to include, nothing showed up. Checked zwave page and the blank node is back. Getting real frustrated with HE as I got 4 new sensors and none of them will pair (2 GE and 2 sensative).

One other weird thing as I was troubleshooting this - I did a zwave exclude and hit the button on the GE device to exclude, and instead it excluded my master bathroom sensor that has been installed and working for months. I dont know how that got into pair mode or what happened, but I had to re-pair that (and it re-paired no problem).

Here are my exact steps.

  1. Exclude ghost device
  2. Shutdown the hub and remove power for 30 seconds
  3. Power back up, start inclusion
  4. Don't click the button 10 times, click it just once and look for a single blue LED flash on the motion sensor. Sometimes I would click the button once again maybe 3 seconds later

Finally , what HE version on are you running? I've seen people complain about inclusion issues with 2.2.5.x. I actually reverted to for reasons.

My experience has been hit and miss based on the brand/model of Z-wave device. AC powered devices have network wide included for me 100% of the time. Battery powered devices I always start by trying network wide inclusion in the final install location but depending on the device have to move next to the hub. The downside is devices included near the hub always pair direct and battery powered devices are hard to post-include repair to a better route.

1 Like

I finally got them paired. No idea if this is a consistent issue or just me, but what I had to do was constantly hit the pair button every 5 seconds or so while 'inclusion' was active. I dont know if these devices go to sleep so quickly that they need to be woken up to pair or what, but that is what worked for me. It actually showed up as just 'Device' but I was able to go in and change the driver to 'Generic Z-Wave Motion Sensor' and its working fine. Now to see if the same thing works on the Sensative strips...

That is what I mentioned above in my steps. Sometimes I had to click the button once every 3 seconds for it to successfully include.

Glad you got it working! I'm now very happy with these sensors, they trigger and report motion to the HE fast!

BTW, here is the SmartThings DTH ported driver I am using instead of the generic Z-wave motion sensor driver built-in.

Thanks. I'll check that driver out. And yeah, I'd clicked it like 3-4 times before during pairing, but I had to do it close to 20 times in those 60 seconds to get mine to pair. Wonky little things - hopefully I never have to mess with it again.

1 Like

I just clicked it once and it paired but it was a new device a community member sent me.

I just added two of these motion sensors. What finally worked for me was to hit the button once and it shows initializing and seems to get stuck there. Then I waited until I had 30 second remaining and I hit the button again and it immediately added. I also held the device about 1 foot away from the hub. This worked twice in a row for me.