Struggling with migrating to C8

Did the back up first on the C7, both to the cloud and to a local file.

On the C8, I first tried to restore from a local file. Seemed to work, but I could never get past pages demanding that I register (I registered on the C7 long time ago and didn't remember my password. There was no option for a password reset.

Created a new account--was surprised I was allowed to use the same email. Maybe that's the source of my current woes.

Even though same email, C8 hub didn't see any of the cloud back-ups. And, I could not figure a way to use a local back-up file. Always ended up "Starting Over" (gosh, so many times!).

Finally, brought the old C7 hub up and found a place to get a password reset. Did the reset, then went back to the C8 and use it to login.

Tried doing the resto, but I've been getting a spin box for 15 - 20 minutes. Should it take that long? If not, what should I do next? (I closed the web page, came back in, but still just spinning)

Got tired of waiting, so I tried power cycling the C8.

When it rebooted, went to the web page--still green spinning circle.

They are probably NOT registered to the same account.

Go to My Hubitat > Registered hubs. Do you see both hubs?

On the hubs go to Settings > Hub Details.
Look at the bottom, Emails Linked to this Hub
Both hubs should be registered to the same Admin account.

I may have misunderstood, so did you get them both on the same account now and able to use the cloud migration backup and restore?

You did that and now the C-8 is stuck with a loading screen?

Yes to both questions.

On same account (I think, else I couldn't have authenticated) and the C8 is hung up.

First try just going to another page like /logs or something see if that loads.
If still stuck, go to diagnostic tool and first, do download latest firmware, then restore prior version and update to current firmware. Then do a soft-reset after it reboots (from diagnostic tool).

Then you can try the cloud restore again.

Diagnostic tool docs:

1 Like

Go to another page? How? Connect to the IP and can't get off that page.

Ah, just guess at the URL (add /logs).

I already loaded latest firmware-- I can go to other pages.

Ok, I'll try the diagnostic tool after dinner.

Then you should be fine, that spinning circle is probably just some sort of stuck cache issue.
Try an incognito window or something and see if it goes away.

I need the URL for the diagnostic tool or somewhere where I won't get prompted to agree to the terms of service. Once I click yes, back to the same page, spinning.

Maybe I need to find the factory reset button?

Got to the diagnostics page.

Did all that. After reboot (before trying to restore from C7), back to the devices page with the spinning green circle.

As icognito, I avoided the spinning circle. I am asked to login, then a message about no cloud backups found (after I click the "reload cloud backups now".

On the C7, I see seven or eight backups.

Is it possible there are two accounts for the same email and that's confusing things?

I dont think it lets you do that, unless maybe your old account was from a "social media" link like google login. I think they stopped using that for new accounts and there was some sort of migration process. So maybe the old one was a social link and the new would be a direct account.

If thats the case you can send in a ticket for an account issue here: Account Issues – Hubitat Support

I am sure they can sort it out for you.

1 Like

I went back to the C7 and created another migration backup.

C8 still doesn't see any.


I'll try submitting a ticket.

Only other thing I can think of, is are you sure the C-8 can get online to the internet?
You can try setting it up as a new hub, and then go to the network settings > tools. Try to ping something like and/or some other random web page URL. This will test the DNS and internet connectivity.

Besides that it sounds like maybe you have two separate accounts, possibly due to what I described above with the social accounts.

Checked your hubs and both are registered correctly, and the C8 is online and connected to the cloud. I recommend following the refresh backups link on Backup and Restore page and/or reboot the C8.

1 Like

Says database was restored successfully and the hub will restart. Also says not to refresh the page.

It's been spinning on that page for a few minutes now.

If I start another icognito browser, I'm back to the window asking me to login. When I do, back to the same "No cloud backups found" window.

There's no way to get off that page other than typing another URL into the address bar (e.g /hub).

If I choose Devices, "no devices currently installed.

No issues pinging.

The fact that I have to keep agreeing to the terms of service would seem to imply the C-8 thinks I'm a new user--even after agreeing to the terms at least 20 times.