Sonos symfonisk not found

I know there is some similaire question that I've already been posted, but I didn't find my answer in those posts.

So, I've recently both sonos symfonisk ikea speaker specifically because, I though it would have been easy to integrate it in HE. I've made the first setup with the Sonos app just to make it work and connected.

Now, my sonos speaker in directly connected to my same router than my HE hub. I've unpluged it and replug it a few times from the power source and even internet. However, even after 1 hour of search still not found with the built-in sonos app.

Is there something that I'm missing to make it found by the built-in sonos app?

Seems like a common issue, I struggled to get mine to join my network as well. Finally found out how to factory reset it and was then able to join it to my network and HE.

1 Like

Thanks for the prompt response! I don't have any problem to connect my sonos to the wifi network. My problem is my sonos does not get find with the built-in app for sonos intergration.
From the link you share, I've tried the factory reset, reconnect my sonos to my network. But does not work for now.
However, maybe by repeating the process or waiting longer, it will finish to work. I will let you know.

Just found from my log, that I have the following:

Anybody know what it means?

I found my solution here, I don't know why, but I didn't find that post first.

Maybe it's me who does not quite understand the solution, but can you elaborate on what it is about?

1 Like


Yeah, I did effectively not elaborate. What I did was to manually add the sonos device. Which is briefly explain here (A link refered in the shared solution):

Sorry, if I don't use the right terminology or term in my explanation, since I'm no expert in that area. To manually add your sonos device, you need to know its IP address. If you have a smart router, it is relatively easy to get that IP address: simply log into your smart router app, and you should be able to find your sonos device, if your sonos device has been added to your network via the sonos app. If you don't have a smart router, I think you should be able to find the sonos device via the Network if you have a Windows computer.

Once you know the IP address, simply follow the abovementioned link. To convert the IP address in Hex, tap on google (IP address to Hex) one of the first link should be a converter.

Hope this help you!

1 Like

PERFECT! :clap: :clap:

I bought a Symfonisk yesterday from Ikea, got home last night and tried to add it both through the Sonos Integration and through the aforementioned suggestion of adding a virtual device via the IP > Hex approach. With the Sonos Integration, I get the logs like others have posted about UNVERIFIED PLAYER. With the virtual device nothing happens at all.

Anyone have any other thoughts? I pretty much bought this to play around with Plex and Hubitat. I can't control it with Plex yet, as I have a double NAT to contend with, and for Hubitat the speaker appears to be a boat anchor for me.

I am on the latest firmware. Any thoughts/suggestions would be appreciated!

You can add it manually as long as you know the Symfonisk's IP address. Follow these directions from @mike.maxwell

Thank you for your response @aaiyar. In my post, when I mentioned the comment about adding a virtual device via the IP > Hex approach, that was me trying to relate that I did precisely that and it didn't work for some reason.

Does anyone have a screenshot of their device they could provide?

This is my Symfonisk. I added it just using the IP address as a hexadecimal.

Thank you for posting, but, the strangest thing happened. I came home and the device was working. ELVES I TELL YOU! IT'S ELVES!! First they make all the shoes for the lady who lived in the shoe and now they are making my Sonos work with Hubitat!

1 Like

I have 3 Symfonisk speakers that just will not discover, and throw errors in the logs during discovery. Earlier hub firmware did not have this issue. Something had to change in the built in app to make them non-discoverable. I no longer have the early version, but at one point, I reverted to it and discovery went fine, then upgraded the hub, and all worked.

I also do not see how to add a stereo pair manually, which also used to be discoverable early on.