Sonos App Finds One Device But Not Two Others

Hi there,

I have three Sonos devices. A Sonos One, and Two Ikea Symfonisk Bookshelf speakers. All are connected wirelessly via an Eero Pro network. When I go to discover Sonos devices, the Sonos One is found almost immediately, but I have never been able to find either of the Ikea Symfonisk speakers. I have tried everything from physically moving them to the main router and plugging them in via ethernet to unplugging the Eero closest to them so that they connect to the same router that the Sonos One is connected to, to moving my Hubitat and putting it on the same Ethernet switch as the Symfonisk. All the Sonos speakers are on the same subnet and I've set their IP's as static in the router configs. In fact, After setting up the Hubitat, they were the next thing on the list, so Hubitat's IP is, and the Sonos's are, 71, and 72.

I have no idea why these aren't found. UPnP is on and it's odd to me that one device is found wirelessly without issue, but the other two, wired or not, won't appear. Any thoughts?


1 Like

I finally stumbled across a thread simply named "Sonos Move" that got me going. You can add devices manually. Doing this, I was able to add all of my speakers without issue. I'm guessing there might be something odd going on with the Ikea branded Sonos speakers. See here and simply use an IP to Hex converter and they'll be found immediately. Sonos Move

1 Like

Glad you got that sorted! And welcome to Hubitat!

The two symfonic's I have were discovered like all other sonos devices I have, so I don't think it is an issue with the Ikea versions...

1 Like

Yeah, I'm not sure. There were a few warnings in the logs talking about unverified devices. Could it be that they were found but didn't show up because they have a slightly different model number or something?

We don't look for specific model numbers, its all based on the sonos SSDP response, no matter, glad you got them connected.

I just had to remove the Sonos integration and reinstall it. I went through discovery and it would not find the 3 symfonisk speakers, but found all of the Sonos speakers. All worked fine before this, all were discovered. The only difference would be hub firmware versions between the dates of app discovery.

This seems to reoccurring issue here lately here is the workaround I used.

1 Like

I tried that, but it was very laggy, and it would not operate a "pair" of speakers, and only wanted to operate the separately. I did a hub restore to an earlier point, before removing the Sonos app, then i searched for the speakers and it found them just fine. I then had to delete the older, originally discovered devices. There seems to be an issue in the Sonos app, because problems came after it was uninstalled then reinstalled, maybe a slightly different version upon reinstallation?