Sonos App Causing Trouble

Hi, so recently i reconfigured my wifi router only to now discover the Sonos integrated app won't work, I've tried deleting the app it won't delete either, I just get a spinning wheel for eternity, I've done a soft reset yet no joy, I can't do a factory reset as that will wipe out my entire Zwave and Zigbee networks along with the rules, drivers, integrations & dashboards ill have to re build, invested a lot of time in this, a factory reset is the last resolution, any solutions ?

I had the Sonos Integration app installed.
I just removed it with no problem.
I clicked on the gear box (black left) and removed it.


Try what @gdkramer had recommended first. If that doesn't work contact support.

1 Like

Hi, Thanks for the reply, I’ve tried that option also, all I get is a loading browser stuck on a progress bar

All resolved now, I was able to delete the app from a mobile phone browser not sure why the desktop didn’t work, thanks for your prompt reply guys x


Was it a supported desktop browser?

Well it was safari on a Mac so I’m assuming it’s supported,

1 Like

Sure is. That's what I use most of the time.

What was the reconfiguration you did? Is it making the Sonos components unreachable? We had a long thread about what Sonos requires in terms of networking.

1 Like

Hi Eric, I basically reset my WiFi router to factory default settings, changed the SSID & Password also changed the DNS Range as I was getting triple numbers at the end of every device IP address e.g instead of single or double numbers, which made it impossible for the synology, assistant to locate my NAS, on completion everything worked fine as it should outside of Hubitat Sonos was reconfigured, it was just that there wasn’t a way to refresh the Hubitat Sonos app so I tried rediscovering devices and got the spinning wheel for eternity, selecting the delete button will spin the wheel also, I thought a soft reset will do it but no luck, eventually I tried on my phone browser and must have just left it on the table as the wheel rolled on, came back to it some minutes later and it was sorted, all back to normal again running butter smooth.

Interesting. Is the router providing dhcp for the sonos devices? I wonder it they got new ip addresses and it just took forever for it to rediscover them. Anyway, glad it's working. I remember from SmartThings days (as well as Hubitat) that sonos discovery was (is) incredibly slow.

Indeed the Sonos speakers are directly connected to my router which is a mesh WiFi configuration, as I get much better coverage all around the house so no need for Sonos net or a boost, your likely right in thinking the new ip addresses might have been the case, Thank you for your assistance super awesome x

Are they hardwired to mesh points? Or are you using WiFi? Gen 2 Sonos One speakers have a hard time with WiFi meshes. I had issues with them until I hardwired them.

My Playbar and Sub have never had issues with a WiFi connection.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.