Sonoff without tasmota?

ok i didnt try those sequence of events.

Let me pull it out and try this again.

Can you confirm, using tasmotizer do i need python?

1 Like

I can't recall exactly....I'm using a windows PC. I think i just installed the exe from the github. But I think I had python installed already.
Sorry, not much help on that.

ok no worries ill give it a shot and see what happens!

Good luck!

sorry 1 follow up question. I didnt research it to much because i wanted to get the device flashed first. but once its flashed ive seen MYQTT online. is that what im supposed to do next in order to integrate with Hubitat?

I just use this stand alone driver.

I only have the one Sonoff device so far. And this works perfect for my usage ( Pool heater temp and power control ) There are other options out there.

1 Like

ok so I think im making progress.

I noticed when trying over and over to plug and unplug the power pin that if I left it like half way plugged in, it would flicker the light on the usb to ttl device. so I tried to tasmotize. but it said it failed because it couldn't find the header.

which I think is happening because the sonoff device doesn't blink or anything. I can't get it to start the pair mode. ill keep trying though.

I don't think the TH16 will blink or light up at all. are the tx/rx hooked up correctly? tried reversing them?

oh I was waiting for the blinking light on the sonoff hmmm.

I have rx to tx, and tx to rx. I can switch them

That should be correct. Keep trying :slight_smile:

going to keep at it lol

It's been a few months now since I did it, But i remember it being very frustrating. Then it all of the sudden worked. I think it's all in when you let go of the button. try holding a bit longer. Also, I don't think you will actually need the sensor .bin file. The standard release will do everything needed on the TH16.

Ok I’ll switch bin files

Here is my soldering job. My fear is I messed this up and that’s why it’s not working.

I don't think that looks bad.... Might want to reflow these two

The two on the opposite end look great to me.

ok I think i made it a little better. back to trying lol

I wonder if its my usb device. maybe its not providing a enough power. I am using this one

I used the exact same one. I think the older revision of the th16 must have been easy to flash...these new ones are a pain. Keep trying different timing on letting the button go. If I remember right it was longer than I thought it should be.

are you putting it into programming mode by holding down the button when connecting the usb?

Yea I’m holding the button on the sonoff. But doesn’t seem to be working.

You might want to restart the computer or even try a different one if you have one available.

I feel for you. I was ready to give up too at one point.