Sonoff SNZB-01P not staying connected to C-8

I've just bought 2 new Sonoff SNZB-01P buttons. I got 1 a couple of weeks back which works fine. I can't get either of the 2 new ones to stay connected to the C-8 hub. I pair them once, switch to the Sonoff driver then re=pair them. Once that is done I can see button pushes on the device page and it shows on my Zigbee graph. After a few minutes though it disappears, buttons don't work and it doesn't show Zigbee graph. Does anyone know what to try next?

I read some issues with the C8 and Zigbee devices. I think it's they work best paired directly to the hub, not via a repeater. Try re-pairing next to the hub, maybe even shutting off repeaters

1 Like

Thanks. I've tried next to the hub and it does the same. The weird thing is that it is actually pairing, and the button does work, but then drops off.

I wouldn't give up hope yet. Once the button becomes a little more popular, a specific driver will likely be built for it. Can you change the driver to "Device", save the change. Then hit the get info button that shows as a result of changing the driver. Go to the logs and post that get info that shows up there.

2nd thought, are you in an area where you have close neighbors who might be running a zigbee network?

Do you have other Zigbee devices on your hub that are stable long term?

PS _ I see you found the other thread. @kkossev is very good at developing drivers

I’m confused… Are you suggesting that a driver would help with it dropping off the network?

1 Like

I already have another Sonoff SNZB-01P on the same driver that works fine. I don't have many ZigBee devices, about 10, no repeaters.

I'm a bit frustrated with my C5 to C8 update, never had any issues with the C5 but upgraded to future proof it. So far I can't pair IKEA devices, which worked on the C5, and this.

No, Zigbee 3.0 connectivity / pairing issues can not be fixed on a driver level.

Thanks, and that’s what I thought. While I’m sure a driver could help ‘tweak’ things a bit (or not. It is just a button, after all.) what it sounds like we really need is a stable Zigbee connection. It works well as-is without a driver today. (Again, in function, not necessarily connectivity.)

Yep, this is a simple button - all that is needed is to add the new model fingerprint into the stock HE driver, so that it is assigned automatically when paired as a new device. The fingerprint was provided in the other thread.

I get that. But mine pairs fine then vanishes. Surely it'll be the same when pairing with the fingerprint initially.

If the Zigbee 3.0 device leaves the network a few seconds after the pairing, this is a well-known Hubitat problem reported 100 times ..

1 Like

Exactly, I am on that thread already with the IKEA issue.

Maybe slightly different though, the sonoff button pairs and works for a bit. The IKEA button doesn't work at all

Maybe just my bad luck but it's rendering my C8 useless, my needs are simple :rofl: all this would have been fine on the C5.

We should have been told about these potential issues when buying the C8.

These will work on a C-7 hub.

1 Like

Yeah, can they fix the C-8 though? Nobody seems to want to acknowledge it's issues.

I still have a C5 backup should I get a C7 but I want to invest in a system I trust

I suppose that fixing the pairing/connectivity issues is a matter of priority.
This problem affects mostly Tuya, Ikea, now Sonoff - all of these are not used widely in the US.

1 Like

Fair enough but as a developer you don't break the interface, if you do then you should make that clear.

Eg I would expect everything that worked with pre C-8 hubs to also work with the C-8

I'll give it a few weeks to see if Hubitat address this but it seems like this has been going on for a while


Re not widely used in US

Is this discussed elsewhere? Hubitat sell globally, they should be testing this.

This is only my personal observation/opinion.

1 Like

The usual way is to ask Hubitat engineering team to add the new device... If they can't obtain it locally (not all devices are available in the US) they can ask to loan the device for the development needs.

You mentioned you have a C-5 as a backup - did you try pairing the SNZB-01P to the C-5 hub?

I don't have a C5 hub anymore, I sold it. I just have the backup file