Sonoff S31 Lite Zigbee Smart Plug US not pairing


Just bought a 4 pack of the Sonoff S31 Lite Zigbee Smart Plugs on an amazon lightning deal, but I can't get any of them to be seen by my C5 Hubitat hub. I've tried shutting down the hub and bringing it back up, and I've tried holding the button on the plug for 5 seconds to reset it and put it in pairing mode. The hub never finds any of the four. The plugs are sitting 1 ft from my hub when I'm trying to pair them.

Anyone else using these recently with success? There are plenty of Amazon reviews and Hubitat community posts saying they work with Hubitat, but so far it's a no go for me. I only have one other zigbee device paired to my hub right now (a button), so I don't think there is anything wrong with my zigbee network.

Any suggestions are appreciated before I give up and return them for something else. Thanks!

They work great for me! I have quite a few, never an issue. Strange you cant get even get one of them to pair, never got sent the wifi version by mistake did you?

1 Like

This happened to me last year via Aliexpress last year. Similarly, they were priced quite well, so it is not a far-fetched suggestion.

Otherwise, I have had no issue with my actual ZB Lites. They have been moved, removed, re-added ... all without issue. I don't recall any special rituals that needed to be performed.

1 Like

They are indeed the zigbee versions, so no mistake there, thanks for the suggestion.

I reset my zigbee radio on the C5 last night as a last ditch effort, still a no go. The bulk of my devices are all z-wave, so I wasn't sure if I was just doing something wrong with the zigbee devices.

Currently, I'm plugging in the lites, they start flashing green immediately indicating they are in pairing mode (I reset them too just for good measure using the 5 second hold on the button), then I put my hub in zigbee pairing mode. Nothing is ever found by the hub. They are right next to each other too during this.

Once this snow lets up, I'll go out and get some new batteries for the zigbee buttons I have and make sure they still pair to my C5. If they do, I must have got a bad batch of the Sonoffs.

Do you guys @chad.andrews @Hatallica also have a C5? Or do you guys have the C7?

Thats a strange one, and all 4 the same issue. DO you get the alternating red and green light? SONOFF S31 Lite Zigbee Smart Plug UNBOXING WORKS WITH SMARTTHINGS - YouTube
Kinda makes me think something else is at play here. I have the C-7. You are right, best check your radio with a good know device to see if any issues there

I get a single blinking green light when I plug it in, which is what I think is happening in the video. If I long press the button for 5 seconds, it cycles the relay a few times which cycles the red light on a and off before going back to the blinking green light. The box and device look the same as the one in the video. The instructions in mine though now tell me to pair it to some Chinese app, but it still includes the smartthings and Alexa instructions too.

I'll report back once I'm able to dig myself out and get some batteries for the other buttons I have. Thanks for the help thus far.

Well that's a good sign, re. the lights. The wifi version, I think has blue and red lights, vs. the Zigbee versions red and green. I think the Chinese app is if your using the Sonoff bridge I suspect, which is not required in your case. So bizarre.

My zigbee button paired right up, so there isn't a problem with the zigbee radio in my C5.

I must have gotten a bad batch of the sonoffs, or they changed something that made them incompatible with Hubitat. Will be returning them and trying something different.

Thanks everyone for your help.

I think you need to do the 'Factory Reset' on the devices - they may be already set to
someone else's network.

I believe that is what the 5 second hold on the button does. Do you have a different way you factory reset yours @ccoupe ?

Not sure, mine were never a problem. Pair and reset can be two different activities at the device. Four dead devices out of four -- not likely.

The documentation says that a 5 second button hold will reset the device and put it immediately in pairing mode. So appears it might be one activity. :smiley:

I agree, seems like it's not likely (one of the reasons I posted for help). This is why it think it's a bad batch, or something changed on the device that no longer makes it compatible with Hubitat (manufacturers can be sneaky like that sometimes).

I'm willing to try a different method to reset and pair than I've outlined in my previous posts. Do you have a different way you reset and pair @ccoupe? If you're unsure, would you be willing to test it on your end on one of your Sonoff S31 Lites and let me know the method that worked for you?

@GRAUPS Just another data point for you: I also ordered a 4-pack of these 4 days ago (the price was too good to pass up), and they all paired without a single hiccup and all have been rock solid with my C7. These plugs are my only wired zigbee devices, everything else on the zigbee network are battery-powered sensors.
There's still a chance that something has changed in terms of hardware and they are shipping mixed inventory of old and new, but less likely.

One thought occurred overnight, What zigbee channel are you using? There are some devices that only use a few of them. I don't remember if this device is one of those crippled things but you can check. I wouldn't change channels just to find out but I'm kind of cautious

Excellent! Great data point, I was hoping someone had taken advantage of the same/similar deal I found. Thanks!

Another good thought. Looks like I'm on zigbee channel 20. @ccoupe @basilisk, what zigbee channels are you on?

Any chance this is a C5 vs C7 problem? Is anyone working with a C5 with these plugs?

I'm on channel 20, which was the default setting.

I'm also on channel 20 (x14). That won't be the difference then. I have used the outlet on a C5 - I'm currently on a C7. We are all talking about 'Sonoff S31 Lite zb' printed on the back? I bought the 4 pack too but it was some months ago.

Yeah, I've sanity checked myself multiple times, it says "S31 Lite zb" on both the box and the device itself.

I ordered a couple Innr Zigbee Plugs yesterday. I'll probably wait for those to arrive before I return the S31 Lite zb plugs. Until then, I'll keep messing with them to see if I can get them to pair.

Thank you all for your comments and suggestions, let me know if you think of any more!

I missed the part about this being the second zigbee device. Since you don't have many devices you don't have a mesh to speak of. Try pairing close to the hub - with a yard (or meter) - if it works then it can be moved outward.

All this testing has been carried out right next to the hub (within 1ft). Good thought though.