[Solved] Zigbee Instability is back!


#41

Ok, I see your point now, thanks


#42

Simply remove Alexa TTS if support feels it is causing your hub to crash. There have been some updates to Alexa TTS that are all documented in that thread. I have been running it for many weeks now with no ill effects on my hub. If someone can tell me what to change to make it better, I will happily do so!


#43

3 posts were split to a new topic: Lutron vs Zigbee/Z-Wave


#44

I'm perfectly okay. But the thread was specific to locks and no further discussion has taken place. I'm perfectly willing to continue that method of communication.

You are not kidding! I had a ton of issues with those in my early days with SmartThings. Finally purged them and replaced with Hue.

I did for now. But I'll certainly come back and revisit it. If I can stabilize my environment, I'm seriously considering a stickless hub for running cloud integrations and some of my more resource intensive automations (if I ever get to building those).

I moved for the exact same reason. But in my case, under Hubitat Z-Wave performance is phenomenal. Although it was much improved on the v3 hub, in HE my Z-mesh has never been more responsive. I will certainly give kudos to the team for that.

If I can just get Zigbee (and the boss) to fall inline, my own personal quality of life will improve greatly.


#45

Lol, WAF is always first. Please keep us informed, I always enjoy reading how problems are solved, even if I'm not helping at all. Good luck.


#46

@bobbyD I've now had also a complete shutdown of my zigbee network from several devices stop reporting on the same minute, to get home and all the zigbee devices dropped from the hub, to this:

I have no community apps installed. My setup worked flawless in ST (with the exact devices on the same place).

I think you guys need really to serious start looking into the zigbee radio instead of trying to figure out if it's a or b third party.

But that's just my 2 cents.
I sorted the issue for today by reverting to .116 than back to .117, them reinitialized all the devices. Let's see how long it holds


#47

As a counter, you may have no user apps, but you have already stated (in other posts) that you have user drivers.

Drivers can kill things just like apps can.

I'm not saying that's the problem, but you certainly can't rule out user code. Because you do have some.

Regardless, report the issue to support and I'm sure they will look into it.


#48

If me and others were using same code... yeah potentially. I have no iris plugs for example.

Which is the same code that me and srwhite are using?


#49

Thats not good. I hope it holds too. I believe there is a bug in the Zigbee stack on HE. I don't know what it is, but the stack is just not as stable or robust as Iris or SmartThings.

That said some of my Zigbee devices came back online, but a very large number absolutely refuse to connect again. As I write this, I have a motion sensor that dropped off that refuses to connect. The device is blinking a few short blue blinks, then two or three green blings, followed by a long solid red, then the process starts all over.

I took the motion sensor to the basement and it connected right up to SmartThings. I also connected my Iris hub and it connected it in seconds. Took it back upstairs and it's been trying to connect to Hubitat for over 15 minutes. And that's where it sits...

And there are still dozens of devices offline..


#50

Just a side note... I sent @mike.maxwell my SmartPlug code. He found nothing wrong with it after a quick review but was going to test it further.


#51

Who knows.

I only have 24 zigbee devices, but they have been 100% stable. And my signal strengths aren't even great - all are -70 to -80. I only have 3 flavors of devices - keen vents, ST water sensor, and Ikea outlets. So that's not a very large set of devices.

Have 10 xiaomi / aquara temp sensors coming next week. So we'll see.

I hope it IS a bug in HE... Because sooner or later they will figure it out and get it fixed. If it is wacky user drivers, or interference, well... Who knows.


#52

Yeah its just strange that I have completely different drivers than srwhite and we face similar issues.

Nothing against your view but ear that is almost certain the custom code the root cause of troubles is baffling. Until any topic is properly investigated you can't assume that the culprit is A or B. You can consider it through the troubleshooting process to help expedite the resolution, but you cannot in any instance assume it as the sole cause.


#53

That certainly implies you are assuming it is NOT 3rd party code. I don't know if it is or not, I'm just saying you can't rule out 3rd party code at this point.


#54

No I'm not assuming it is custom code or not. What I'm not is Excluding that is not HE native code


#55

Fair enough, and I agree that is a distinct possibility. But is it that isn't how your earlier post came across.


#56

Hmm not expecting to be confusing when I even wrote "Until any topic is properly investigated you can't assume that the culprit is A or B."


#57

I'm not here to argue. I quoted the part that makes it sound that way above. You clarified that you didn't mean it that way. So fine - duly noted.

In any case, none of this banter is getting your problems fixed.

I hope support is making some progress. Would be good to get this resolved.


#58

Not arguing :smile:
Just also try to understand as I'm mot English native and if I can gain more finess in my English also a good thing


#59

You can't rule out 3rd part code, but based on the facts presented here by myself and others, running different combinations of hardware and code, the odds are significantly stacked AGAINST that possibility. Not to mention, if the system is that fragile, then I would still consider it to be a platform issue, and not one with custom code.

Speaking only for my experience, when my Zigbee network crapped out the first time a couple weeks ago, I was pretty much only running the Iriz Z-Wave driver for the repeater part of that plug. That driver wouldn't have affected the Zigbee network as they're different frequency bands, radios and network stacks. Concluson - unrelated.

The Iris Smart Plug driver I'm using is making standard zigbee.command() Hubitat API calls. I'm guessing you've never written a driver before. If it is determined there is an issue caused by the SmartPlug driver, than its almost certainly going to be attributable to a bug in their implementation.


#60

How many smart plugs are doing energy reporting on your ZigBee networks... could this be saturating the network ?
(More likely on ZWave though I guess)