[SOLVED] Z-Wave network isn't working after power cut


I went away on vacation and while away the electric company came and replaced the meter in my property. When we arrived home the usual ■■■■ clocks all our of whack ect. Nothing unnormal. However, I noticed hardly any automations were working, then I noticed it was all ZWave devices.

I went to the Zwave network section and there were no devices listed at all, I found a post that said to issue a shutdown and then power off and leave the hub unplugged for 10 minutes, then plug it back in.

This kind of helped I now have devices in the list but many of them don't have routes and hardly any will respond to any issued commands.

Doing a repair just says a bunch of nodes are not responding, Some devices with routes still dont work. It seemed like I had some devices that worked after I powered them off and then back on but then stopped working again later.

All in all I'm pretty confused, bar turning the breakers off for each room to power down those in wall devices like switches and sockets, which doesn't actually seem to fix them responding to commands.

I've never had this in the 5 years with smartthings previous to switching to hubitat, even after losing power for extended periods everything generally just came back up after about 10 minutes of being powered again.

It is possible that the meter swap caused a surge that damaged the hardware. Was the hub on a surge protector? I did have the same symptoms on my C-7 a few times, and powering down the hub, unplugging power for a few minutes, and booting it back up did bring the Z-Wave network back up to snuff. Maybe try that one more time? Also, have you tried restoring the hub database to the last backup prior to the meter replacement/power outage?

It is on a surge protected UPS, I'll try the shutdown and unplug again, I do have backups I can try one of those. It just seems a very odd situation.

Unless you have some high power devices like a computer plugged into the UPS, it should have kept your hub running. A meter swap is usually a fairly quick procedure. Since you were out of town, I presume a computer would have been turned off.

If the Z-wave mesh got messed up, it can take a couple of days for everything to settle in again. That is what happened when I migrated from C7 to the new C8 hub. I had to rebuild the network.

So I did another shutdown and unplug, Brought it back up after about 10 minutes

I have the same issue. devices in the list but the repair network says failed nodes with about 15 nodes there.

nothing is responding to command even devices in the list that show they have a route.

I wasn't here so I have no way of knowing how long my power was down or if the hub turned off or not. Its not the only thing plugged in to the UPS, I have a few other devices, routers, hubs, server, alarm panel ect.

All the integrated devices API devices work. Zigbee devices appear to be working, its just the Zwave stuff.

I tried restoring to an earlier backup same issue.

What's next do a zwave network reset and force exclude and reinclude all my devices?

my guess is the power surge killed one or more of your devices and a lot was routing through it and it make take time to rebuild.. try to find which has died.. it may have been a key device in your routing and now some are too far away and not working.. i have seen a key switch in my system die and take down half of my mesh.. the other possiblity is one device spammining too many commands into your mesh ... you could look at the zwave logs in conjuntion with debug logs. to see if you see anything strainge ie a device chatting too much ore constantily repeating commands..

Did you try a soft reset and db restore to a backup saved before the meter swap?

edit: I too have experienced that one crapped out device can destroy the mesh. Very fragile. How to find the bad device though?

edit2: I'd say if you keep on trying to exercise the devices via a dashboard, or device page, and they get better and then worse again, that there's a bad device, somewhere. I've exercised them after I've made a device addition or deletion, and the exercise seemed to do them good.

I've not tried a soft reset yet, I did try a restore from backup.

how do I enable debug logging?

LOL you were right, I started going through the devices one by one and turning on debug logging, I found an outside outlet that was continually saying it was being turned on.

I force removed the device from the network and now everything is working again....

Strangest thing I've ever had happen with the Zwave in th 6 years I've been using it,

1 Like


Interestingly the device isn't responding to factory reset either.

Nor will it let me put it back in pairing mode..

Maybe the damn thing really just crapped out.

Yep as i said power surges killed it. The radios are overly susceptible to power surges. Not uncommon.

Life for the outlet has got to be harder out in the elements.

Actually this is not solved, everything was working fine but it seem that is only the case for a short time. after about 30 minutes all the zwave devices stop responding again. However, now if I reboot the hub they respond at least for a while....

I did a soft reset and restore as above. This behavior might have been what I saw previously where I thought devices were working but then stopped again, it might have just been in that sweet spot timing.

Any ideas now?

I also tried to reposition the hub to be closer to more switches and hopefully allow more routes, I do see this in the devices list at least 4 or 5 devices have direct routes but are still unresponsive after 30 minutes or so.

is there a way to enable some kind of debug logging level or zwave network logging? I feel like there is more happening and not necessarily related to the mesh network or a single device.

We recently had an ice storm here and lost power for 18 hours. I was able to power down all the computers, home automation hubs and bridges in an orderly manner. I did not lose any Z-wave devices, but I did lose a couple of Zigbee smartplugs that also served as repeaters since they were mains powered and went offline when the power went out. One of the Zigbee plugs did the exact same thing as you Z-wave switch. It was constantly staying in ON position and I could not turn it off either manually or digitally. Thus, I had to replace the two damaged plugs. Fortunately, the plugs are inexpensive. I would not have wanted to lose the more expensive Z-wave actuator that controls my water inlet valve.

Alright I'm just about done,

I can't get my zwave network to be stable after 30 minutes no matter what I do it craps out and no devices are responding.

Does anyone have a tech support at Hubitat I can talk too? Perhaps the hub is damaged.

Should I reset the the hub to factory and start resetting up all my devices from scratch again?

Download the Hubitat app