[SOLVED] Hubitat cannot discover Aeotec Nano dimmer


This is my first post here and I'am a Hubitat home elevation user from New Zealand.

I would like to get some guidance on setting up my 2 Aeotec nano dimmer (Gen 5, 921.42Mhz) with Hubitat.
I tried the following steps (from: Join and Reset Instructions - Hubitat Documentation) to reset and join/discover my two dimmer in Hubitat:
- Factory Reset
- Paired by standard security i.e. single press button
- Paired by secured i.e. double press of action button

But still, Hubitat failed to discover the dimmer.

I'm not too sure if I missed something. Because when I searched the forum, it looks like everyone have a success of setting up their Aeotec Nano Dimmer with Hubitat.
Also, is there a way for me to tell if the my hubitat elevation is actually the AUS/NZ version? as I just want to narrow down what might be the root cause of this problem.

Thanks in advance.

Do you have an external USB stick connected to your Hubitat? That has the region-specific zwave radio. The internal zwave radio is North America specific.

1 Like

Yeah, safety shut down your hub and attach the dongle that should have came with your hub. You can then confirm on the box of the dimmer what frequency it is.

1 Like

Also, try excluding the dimmer first. Often times, z-wave devices will shit having been paired for QA check before leaving the factory. When in doubt, exclude it first.

1 Like

I don't know if my experience with a MultiSensor 6 is the same as yours (it is an Aerotec product) but....

Yesterday I tried to pair a Multisensor 6 with no luck. I must have tried 10 - 15 times no luck. Finally I just left it powered on the desk for about an hour, came back and it paired the next try. I don't know why but I suspect I was retrying to pair too quickly and the poor controller in the device got lost :slight_smile:
BTW I'm in the US.



Excellent point. I, too, have had this happen.

I would say that wouldn't be unheard of for battery devices. But a "settle time" for mains powered devices? That I would find a little strange.

Kia Ora, mate.
How far are the dimmers away from your HE ??
Are they in metal back boxes, behind switch plates or located at the lights ?
Are these the first devices your pairing ?


How far are the dimmers away from your HE ??

  • I moved the dimmers close to HE, it's like 1.2 meters away
    Are they in metal back boxes, behind switch plates or located at the lights ?
  • None of the above
    Are these the first devices your pairing ?
  • First Zwave devices, I successfully paired HUE hub and lights (which I believe communicates using Zigbee)


oopsy .. sorry about the multiple reply

Yes the external USB stick is connected to the hub, see attached photo



I tried to exclude the two dimmers multiple times, also reset the dimmer , reboot the hub - but still no joy.


Is there a label on the Zwave stick ?
Maybe post a photo of it along with the label of the dimmer.


The Zwave stick is the stick that came with the Hubitat elevation hub, no label of the Zwave frequency if that's what you're looking for. (see attached photo)

and the dimmer is the AEOTEC nano dimmer (Gen 5), label says that the frequency is 921.42 Mhz), see attached photo

Hope you can shed a light on the problem issue I'm facing, thanks in advanced for you help.

When you did this do you get a response from the hub in the logs, it would say something like unknown device excluded.

1 Like

There's nothing in the logs stated that an unknow device excluded when I hit the button 'Z-Wave exclude' the Zwave details page

[sys:1]2020-01-13 19:51:35.187 infoZ-Wave Discovery Stopped
[sys:1]2020-01-13 19:51:03.147 infoZ-Wave Discovery Running
[sys:1]2020-01-13 19:47:29.541 infoZ-Wave Exclude Started for 30 Seconds

That’s a bummer there’s no label on the dongle.
Under settings on your hub, Zwave radio is turned ON, eh ??
Think its probably time to get Support or @bobbyD involved.

Zwave radio is turned ON as per the Z-Wave details page:

I also email support - I'm still waiting for their reply.

Appreciate your help.

No probs.
Seems weird that there’s no label on the dongle, especially for international customers.
Of course the time zone for us, for Real-time support, is not the best but they’ll get you sorted.
But try changing the secure Zwave setting as that causes extra traffic etc

1 Like

Based on the user manual for the aeotec dimmer, when you pressed the action button once when in pairing mode the comms to the hub will be unsecured. But I have no way of testing that because it’s not even pairing/discovered by the hub.