[SOLVED] Firmware update to 7.17.1 takes a long time, then failed

@bobbyD I decided to test the firmware update on a hub with no z-wave devices paired - in fact I had the z-wave radio disabled on the hub and had to enable it before I could update to 7.17.1. It's been somewhere around 5 minutes now and the update is crawling... only at 34% done. Is this the right behavior?

New: my 1st hub (no devices) finished the firmware update after > 10 min. I decided to start the update on my 2nd hub, which hosts all my z-wave devices. After 6 min or so it failed with this message. What do I do now? @bcopeland

Yes, I think mine took close to 10 mins...

3 Likes

Go to Settings and Shut Down then unplug from wall outlet and wait 30 seconds before plugging in. Try to update again 10 minutes after hub is back online.

4 Likes

@bobbyD summed it up pretty good there.. This is usually the cause of the SDK component being busy which is the reason for the wait 10 minutes, to let all the startup processes to settle down..

3 Likes

@bobbyD no dice... the update got about 3min in and then gave the same error. Is there a "shut up" button somewhere I can use to tell everything on the mesh to quiet down for a bit while the update goes on?

There is not. Please send me a PM with your hub id and we will further investigate.

1 Like

Add me to the list of failed firmware updates. I've tried twice, with a full shutdown/power off in between each attempt. I did the hub update prior to attempting the zwave firmware update.

same error for me.. pm sent with hub id

For @eppower it turned out that many S2 devices are too chatty and may prevent the SDK update. If you also have many S2 devices, you may need to exclude and re-include without S2. If that's not the case, please send me a PM so we can further investigate.

I recently went through and put almost everything over to no security. I have two remaining devices at S2, Zooz Speaker and a Zooz Water/Leak Sensor, and one S0 device, a Fibaro Button

In my case I have a ton of Zooz switches that were included prior to 2.2.9, so they went in with S2 security enabled. No reason for this, other than I was too lazy to side-load them into the mesh with my z-stick. Now that I can say "skip the useless security for my light switch, please" when including, I'll hope for better results. Kind of a pain to re-include just about every switch in the house, but there you have it...

1 Like

only about 12 s2 devices and only 3 are switches i couldnt get to include without it..
1 is my garage door the other are ring extenders, nothing that should be chatting to the hub. nothing like temp sensors etc.

my guess is that i just have too many overall devices. around 95 or so.. if that is the case i am not sure what to do.. it is not feasible for people to rebuild their entire mesh just to get the firmware update.

1 Like

You could have 232 nodes that generate infrequent events, or 10 nodes that generate as many events as 232 nodes. It's not the size of the mesh, but how noisy it is.

2 Likes

Everyone was able to upgrade in beta.. This error is from an underlying silabs component.. If you get this reboot, wait plenty of time for everything to settle and try again..

3 Likes

Also after you get to z-wave details page wait a minute or 2 before clicking on the button.. Loading this page causes a lot of calls to the underlying components to get all the information.

2 Likes

did not work waiting on the details page.. said unable to start or something.. rebooting now.

instead of removing and repairing devices maybe just take the batteries out of all my temp sensors etc. and try again? i unplugged all the ring extenders and the other couple of s2 devices.

This should not be necessary.. No one had to do this in beta..

3 Likes

I got to 54% and then I got the failed message. I guess I will reboot and let things sit for a while and try again.

Same issue with me. Will send hub ID. About 15 S2 devices.

Download the Hubitat app