[Solved] Error in new Notifier app for humidity sensor


I'm using the new Notifications app to create a Notifier child app for a humidity sensor (the community Environment Sensor repeater some of you may have), and I noticed it's throwing errors like the following:

[error] groovy.lang.MissingMethodException: No signature of method: notifiApp.firstHumidity() is applicable for argument types: (null) values: [null] (humidHandler)

This happens both as soon as I create the app and (I think it was the same, though these logs have since been cleared) periodically throughout use of the app, possibly as the sensor values change. I don't see anything alarming on the gear/status page (all variables seem to be set), but obviously I didn't write the app and am not privvy to the code so don't know for sure. I can provide this if it would be helpful. Otherwise, there appears to be something wrong with at least this capability. I have a couple others and haven't noticed any problems so far (except maybe a specific lock code reporting all lock codes on that lock--yet not on another lock I've set up the exact same way, so it could just be something about my lock).

Update: my "when temperature falls below" Notifier is doing the same thing, I've noticed:

[error] groovy.lang.MissingMethodException: No signature of method: java.lang.Double.call() is applicable for argument types: (null) values: [null] Possible solutions: wait(), abs(), any(), abs(), wait(long), each(groovy.lang.Closure) (tempHandler)

Yes, I see the same error. If a value is required, please add logic to enforce it

I updated my notifier app and I'll see if the error goes away


No change for me, still getting the error


Any thoughts on this error?


Please show the app setup page. Will track down the problem.

I'm still getting the error I noted in my first post (not sure if that is also what the other poster is seeing):

app:2443 2019-04-29 21:45:38.998 error groovy.lang.MissingMethodException: No signature of method: notifiApp.firstHumidity() is applicable for argument types: (null) values: [null] (humidHandler)

Here are screenshots of my app:

Of possible note, this device above uses the (community, of course) HubConnect Ominpurpose Sensor driver. Not sure if there might be anything missing in there or if it's just an app problem.

On 2.0.8 (haven't tried on 2.0.9; gave up and used Rule Machine instead), I've also noticed that notifying about the use of specific lock codes (another problem I noticed above) still isn't working. I used to notice it on just one door, but when I recreated it, it affected all doors. I've deleted it since then so I can't show configuration screens, and I'm happy with RM, but could try recreating again if anyone wants me to. :slight_smile:

There is a bug in Notifier. Found and fixed. Will be in next hot fix. Temperature and Humidity were broken by mistake about 5 or 6 weeks ago.

In case this leads to something more. It's pretty simple actually. I selected a Zooz 4-1 as my temp sensor and setup a Push when >x


1 Like

This bug has been found and fixed, and will be in the next release.

1 Like

Thanks Bruce, appreciate the update


I cannot get Notification app or a specific rule to react to humidity change. Humidity value is reported in device manager and is seen in the trigger line of the rule. Simply trying to get an audio notification when level rises. Iris V3 motion sensor. Ideas?

Sorry to resurrect this but I'm wondering if the error I'm seeing could be related? I just recently created a notification for temperature and the logs show this error, it's not actually sending notifications.

The error repeats every five minutes, which is how often the temperature sensor is set to send updates (regardless of whether there has been a change). I'm on the most recent hub firmware, and the temp sensor is an Everspring ST814 that uses a community driver.

There should be more to the error than you're showing, including a line number. Please show the whole thing.

that's all there is to it, actually. Here is another live log tab with the same notifier app error messages.

Happy to share whatever else is helpful as well. Thanks.

Can you show the device events for the temperature device in question. That's from the button at the top of the device detail page.

Sure, here are the device events from around that time.

Please show me the Notifier app page itself.

There could be something wrong with this driver. Can you try using a built-in driver just as a test to see if it throws the same error or not.

Please give me a link to the driver code.

yup here's the notifier app page:

I'll try changing the device driver. The reasons why I have it report temperature every five minutes (even without a temp change) probably aren't worth explaining, but I wonder if that's got something to do with it. I'm pretty sure it's this one by @krlaframboise