[SOLVED] Discourse not updating read count etc

I'm wondering if this is just me.
For the past week or 2 the forum has intermittently not been registering that I have read a post or topic. I use the "Latest" posts to skim through new or updated threads but end up reopening already viewed threads because they still show as having unread messages. I have to manually refresh the browser, re-open the thread and go back to the "Latest" homepage. Sometimes it updates and sometimes it doesn't so I always ensure the last post I read loses it boldness when returning to the main list. If not I refresh the page, reopen that same post and it works for awhile longer.

The problem also occurs with PM's and @'s and likes. I thought it might be my phone browser. When I started seeing it on my desktop browser I decided it's not a phone bug.

Anyone else seeing this? @bobbyD, thoughts?
It's a minor but regularly occurring and annoying problem.


It works for me. Using safari (mobile) and chrome (mobile and desktop)

Thanks for the data point @dan.t
Forgot to mention..using Android Pie Chrome and Win10 Chrome.

Do the same Combo with Win 10 and Chrome.
Two things to try, if not already done:

  • log out of discord and log back in
  • clear cache
1 Like

Just did this on my android. Never tried to clear cache on my phone before so it was a learning experience. I deleted data for all things community.hubitat related from chrome. Thanks for recommending the obvious Dan :man_facepalming:

I should know soon enough if it works on my phone.

1 Like

Tree... Forest... Wait... What was I looking for again?

1 Like

I've noticed it as well. In fact it's happening on this thread. :smile:

Been noticing this for a while now too, both new and read counts. It seems like something has changed recently in how Chrome handles the page refresh, as we have not made any changes to the Discourse platform.

Try the following:

When you are in the thread, scroll all the way down. not just to the last text but all the way to the other suggested threads that come below the thread and see if that changes the indicators. I have seen that before

1 Like

I have tried this as well. Hit or miss on whether it works or not.

Unfortunately clearing the cache and logging out didn't work. It just happened on another thread...and I scrolled all the way down. Dang it google! It's the little things.

Hmmm, out of ideas right now outside of trying a different browser... I can only imagine what a PITA this is, I would go nuts trying to keep track of what I already read...

Yup...I only realized initially because of the Suggested Posts at the bottom of some threads had posts that I just read. I would open them and see nothing new. After a while I started noticing that my Latest page would be completely bold after reading a bunch of threads. I would have to refresh the browser and reopen each one of them again.

I now verify that the thread I just left always becomes unfolded before moving to the next.

Switched to Samsung Internet browser (never thought that would happen) and all appears to be working fine. Plus...dare I say it...I think I might like it better than chrome. The dark mode in this browser is True black and sharp.




Thanks for pointing this out. I always use the samsung browser on my s10 and had never pushed that button. The black is nice.

I'm having the same issue. Only on my phone though Android 9.0 chrome. If you select use desktop site and go through the pages again it will fix it or if you use the chrome on a PC that will also fix it. So the issue for me is constant and only on Android chrome using mobile.

Same here.

This issue has been resolved.