[SOLVED] Deleting a Device that is Locked Up?

So, I tried to implement a cam for a dashboard using this:


Worked fine at first, but now when I go back into device editor, it just hangs forever and never loads. What would your suggestion be to recover? I could just delete the device, if I could get into device editor. I am hesitant to just reboot the hub since other things are working. I can open other things fine and all my apps are working. I just can't get into device editor for this device.

Cut off the video feed to the camera. Then try to access the device.

I need to remove that code. The 2.0 changes seemed to have broken this.

That got the edit device page to load. The strangest part, I could issue the on/off command to the device from the maker API and it showed the video in the dashboard fine....I just couldn't edit it. So weird. So, you don't suggest using this anymore?

Well it is something in the way the pages load that cause it to hang like this. Aside from the small matter of not being able to access the device page it does work. I would say use at your own risk.

It is beyond me to figure out how to fix it.

I might have spoken too soon...the dashboard that I added the cam to won't load now either. Think i'm going to delete this one and just link to the cam.