[Solved] Critical built-in app bug with no way to reinstall it

I just received my Hubitat and I did what any user would typically do when receiving it: I played with some built-in apps. When I went to install the Simple Lighting app I accidentally left a required field blank. Rather than the GUI telling me a required field was needed to be filled in, the changes instead immediately took effect which ended up completely corrupting the Simple Lighting app.

Here's my critical issue now:

If I attempt to access Simple Lighting I now get an error which states, "Error: Cannot invoke method put() on null object".

If I attempt to uninstall it, I get 'Error 505'. It can NOT be uninstalled or otherwise accessed whatsoever now.

I contacted support and explained this issue. I was told to uninstall the app and reinstall it -- that'd be nice if I could do just that. I explained that wasn't possible in my email but I guess they overlooked that important bit. I figured so be it, I'll simply do a factory reset. That should be easy, right? Nope. After significant research it seems there is no way to do a factory reset without the guidance of customer support?! I initially thought that must be incorrect and there had to be a hidden factory reset function in the WEB GUI somewhere but nope.

Anyone have any suggestions on what I can try?

See if you can get to the status page of that app. The URL looks something like below.

Make sure you put in your hubitat IP address.

Replace the last numbers with the numbers specific to your app. They all have a number. You should see it in the URL on the screen you see the error when you go into it.


If this works you should see the status page for that app and a remove button at the bottom that should work.

Hopefully that helps.

1 Like

In your List View of the Apps, simply click the Gear-Shaped Icon to left of the App name. Then scroll to the bottom and you should have an option to Remove the App.

1 Like

Unfortunately that's part of the problem -- clicking 'Remove' results in 'Error 500: A server error has occurred."

It basically seems like the Simple Lighting app has somehow become completely corrupted. I suspect I'm SOL and the only thing that will save me is a factory reset. I'm still stunned a factory reset seems to be so complex and not something that's possible within the WEB GUI. That seems like a major oversight (in addition to there being no input validation during an app install but I digress).

Tagging @bravenel as I am sure he would be interested in this bug in Simple Lighting. Also tagging @bobbyD as he is usually able to get things fixed up quickly for users.


If you'd rather not wait, though... You can properly simply restore a backup from before you installed the Simple Lighting App.

1 Like

Are backups automatically created? If not, I sadly don't have a backup.

This is literally a brand new hub. I immediately installed the latest firmware on it and then started exploring the built-in apps and that's when the bug occurred.

Duh. I always forget that gear icon was added. I'm still doing it old school as a shortcut. Lol

I think I answered my own question... there's only one available backup and it seems to have been created after the corruption occurred. If only there was a standard known-good virgin configuration that could be restored (hint: Hubitat).

I believe the factory restore function is limited because it can mess with the registration of the device. This may not be the case, but I have seen users needing to have the registration reset.

Outside of that assumption, I canโ€™t help. But hopefully it doesnโ€™t take too long for official support to get back to.

Have you tried removing all of simple lighting? If this is the first you've created, then you won't be losing anything else.

I do have a 'Simple Lighting Rule' listed underneath the main app but clicking the gear icon results in Error 404 - appid not found. What's interesting is I did NOT create a rule but I did briefly explore the rule creation process page. As such, it seems this somehow caused a rule to be created in a half-complete state of some sort which is now causing the Simple Lighting app to hard crash.

Clicking on the gear icon for the main app results in a 404? Up above you said you were getting a 505 and then you say 500. Have you contacted support?

I don't see a reboot being done... the startup process does try and recover the DB. But it can take 15-20 mins.. so don't repeatedly try to reboot. Settings: reboot

Factory Reset is easy, but it would put you into a different hole.. your registration would be locked til Support was around to reset it. Same support, so you may just as well wait for them to look at this instead :slight_smile:

I've already contacted support and waiting to hear back. It's pretty confusing but the error I get depends on what I click. To sum it up:

  • Clicking the Simple Lighting app itself results in: Unexpected Error: Cannot invoke method put() on null object
  • Clicking the gear and then Remove button for the Simple Lighting app results in Error 500: A server error has occurred
  • Clicking the gear icon for the corrupted rule results in Error 404: appid not found.

In other words, no matter which way I interact with the app I get some sort of error.


Highly unusual symptoms... in reading these forums for almost a year and I don't think I've heard this one before. I've heard of apps needing to be removed / reinstalled... but those are usually followed with a "yes, that did it..."

And you did go to Settings:Backup Restore and click the link in the top paragraph for Platform Version click here ? { same as browsing to http://your_hubitat_ip:8081 }

Hah, I guess there's a first for everything. This happened literally within twenty minutes of booting the device. I guess that explains why my first response from support was "Simply uninstall the app and reinstall it. Here's how...".

I did try the platform rollback but it seems to be blank unless I'm missing something? There's a backup config but it seems to have been created after the app install occurred unfortunately.

A backup is done with each boot, total of 4. The platform rollback is blank, yes, for your "age" machine.

The two areas are independent.. the backup is JUST the database.. what you've done to the hub. The Platform area is the underlying OS of the hub.

A factory reset will delete your database and that includes your unique registration key. You'd be back to the portal waiting for the green Register button to show.

Because of these symptoms and the time of day, I'd do a reboot and see if the DB got 'cleaned'.

The backup will be used during the reboot if the os finds it usable... You get 4 backups plus a "live db" and if the boot process finds the DB corrupt, it trys to roll back, til it runs out of backups.

1 Like

Sorry forgot to mention I've tried a reboot without any luck. I suspect that given the uniqueness of my issue a factory reset will be in my future. I suppose its better now while the device is still new than at a time when I've got 100s of devices paired to it.

I'm coming from a ST hub with a ton of devices but intend to do a very slow migration to play it safe and troubleshoot any issues along the way.

Certainly a factory reset will "fix" the problem :smiley:

But you will find that we tag Hubitat staff quite often because they are so responsive, when they're not in bed :slight_smile:

I know that's why I'm hesitant to say "Here's how to factory reset..." because it will prevent them from seeing this particular problem and therefore preventing it in some future release. It's not unusual to have a "next day" hot fix but it's also common to hear "found it, fixed in the next release."

1 Like