[SOLVED] Aqara switches and buttons stopped working

Hi All, just wondering if anyone have issues with aqara or any zigbee devices in the recent days? Not sure if it was caused by latest updates, but I am now unable to control any of my zigbee switches nor buttons. I can repair them which will only work for 10-15mins, then they're unable to be controlled again. Scratching my heads here, not sure what's going on. Any ideas? Thanks

There has been no recent changes that has affected zigbee devices, at least I have not noticed any and there has been no reports in the forum.

This is not the right thread for zigbee mesh issues, but I'll write some here and if you need to look at that some more, please post in a zigbee mesh thread.

Have you added any new devices lately? Have you changed your WiFi Channel lately? Did you get a new router? Basically, first look for changes in your environment, has anything been added/changed lately?
If the devices fall off after just 10-15 minutes, that indicates mesh problems of one type or another, check the above and post in this thread. a zigbee mesh thread, feel free to @ me.

EDIT: This post has been moved to the correct thread.


Thanks @markus,ill find this thread. Sorry for posting it here. To quickly answer your questions, no, nothing has changed. This is why I'm scratching heads. They all just stopped working suddenly.

How does your logs look like? Any errors? How about the Zigbee logs?

What devices do you have in your mesh? Most importantly, which repeating devices do you have?


No issues with my Aqara devices (sensors, buttons) or any other zigbee devices.

I have posted earlier that these non-standard Aqara devices tend to "stick" with a particular zigbee router/repeater. If the router goes off line, then all those devices go offline.

How many Aqara zigbee end-devices do you have? How many zigbee routers? What brand/model number are the routers? Are you using @veeceeoh's drivers? Or @markus' drivers?


Thanks for replying guys. I've found what the problem was, it was the zigbee mesh network that got screwed. I dont know how it got screwed but I had to repair all of them to get them all connected again and seems to be running still now.
I basically have got around 10 aqara wall switches, 2 aqara buttons, and I 've got 3 Ikea wall plugs as my repeaters.
I only have 1 HE hub and that's my only zigbee hub.
as for drivers I use markus' one all the way!

the only changes I had was the update on HE hub.
everything else stayed in place. I also haven't been working on my node-red....so I'm not sure what caused the zigbee mesh to fail....


In my experience, these are not great repeaters. While they work with Aqara devices, I have experienced Aqara devices falling off when the Tradfri control outlets were the sole repeaters in my Aqara zigbee network. I had about 25 sensors and 5 of the plugs at the time.

I now have ~40 sensors, 6 Tradfri signal repeaters and 5 Tradfri outlets. Virtually none of the Tradfri devices repeat through the outlets.


Thanks @aaiyar. the weird thing though, I've always had them like this and all seems to be working fine until a few days ago.
I just found out that everything has dropped again...dont know when/what time exactly. checking thru, can't really see anything on any of the aqara devices.
I'll see in getting those repeaters when ikea here in UK is open again.

1 Like

Are these light switches that have a neutral?
I tried one of these and my network was OK for a short period of time, days I think, then my zigbee network fell through the floor.
I had to take it out of my network to get things stable again.
It was repeating and it was trashing the network when things started to traverse through it.
Are you using these? Just wondering how you find them.

1 Like

No, mine are the non neutral ones...I've just literally moved my hub, re-paired the ikea outlets only and all others seemed to be connected again....so I am hoping that I'm barking up the right tree here .....that the oulets are potential the culprits (as @aaiyar's advised). Which means I really need to get them repeaters....
but again...it's odd that they all have been working in harmony for months without fault....not sure what's happening now.....

if this happens again tomorrow, not sure if factory resetting the HE hub might be the next thing to try...though I'm not too confident if it will make any diff...nor if it worth the hassle......

Just realized this, I don't have drivers for those yet, so what are you using? If you're using one of my drivers with these, there could be problems because they are not made for them. Exactly which model(s) are you using?

I have the new D1 models and will write drivers for them, but for the older models which I can't buy here anymore, I would need Wireshark readings when connected to an Aqara/Xiaomi Gateway to be certain I get things right.

Really!?! :laughing:
it's been working great! I've got a mix of QBKG04LM & QBKG03LM no neutral)
I'm using your driver as it automatically picked them up.

That looks like devices created by Guyeebas driver. Exactly what is the name of the driver? I do not have any drivers creating child devices using "Generic Child Switch". I will write a driver for these, but I do not yet have any completed.

whooopsie..you're right.

I used the drivers from this page --> [Release] Xiaomi / Aqara ZigBee device drivers

I’m having the same problems it’s manly with one of my switches in my office it to is a no neutral one I also have a Ikea repeater in there
Did you ever solve this