Smartthings Multipurpose Sensor 2018 Model

I looked in many threads and I didn't find an answer to the problem if the axis working in this sensor. My reports temperature fine. It reports open/close with the magnet. But if I switch to garage mode (either of the 2 options) it doesn't report on the tilt. It doesn't matter which way I tilt it. And it doesn't matter if I have the contact attached to it or not. Of course, the way it was working it was no attached. It was just the tilt based on the axis.

I moved this from ST last night. It was working on ST. Here are two screen prints.

Any help will be appreciated. Thank you in advance.


It looks like you have the option to disable xyz events set to active, ie xyz events are off.

Change the β€œdo you want to use this sensor on a garage door” toggle to β€œno” and then click the configure button to send the new configuration to the device.

Thanks Mark. But unfortunately, as I mentioned in my post, I've tried both. None work.
Do you have one that works? Maybe something happened to mine when I disconnected from ST and connect to HE.

Did you click Save before clicking configure?

Yep "Save Preferences". And I have a log browser tab open where I can see that the mode is changed.

Have you done this step? After saving the preference.

Ok, let see if someone that has the same sensor has a better idea, I heard they use the sensor in the washer machine, dryer... so it should work.

The correct driver for this device will be out in platform 2.0.5...


Thanks Mike. Will that be the next release? Or are there a few dots before then? Just curious.

Current is 2.0.4, so next...

Okay good. I was just wonder at the fact that since we are at, if there were going to be more after the .4. I guess basically I was trying to determine how long more or less it would be. I'm a developer myself so I hate giving deadlines that I might miss or that I'm not be sure about so that's why I worded the question as I did :slight_smile:

we generally do a release every 2 weeks(ish)...

Great. Being new to HE, I wasn't aware. But that sounds great. Thank you.

Installed 2.0.5 and it is still not working. It reports temp. It reports regular open and close. But the tilt doesn't work.

Has anyone got this to work yet?

Did you join this fresh on 2.0.5?, or just change the driver...
If you just replaced the driver you need to click configure so the correct initialization configuration is sent to the device.

Join fresh. However, I did click configure too since it first didn't work. The configure didn't help.

This is the one I wrote that driver for.

I'll pair it again in the morning just to make sure nothing broke...

That's a bad sign, should work straight up after joining it.

Yep. That's the one I have. Thanks for looking into it.

I'm going to remove it and re-add it.

This is the screen print when adding it before I changed the name.


Notice that the Yes (xyz events on) is selected but there us no axis indicators in the Current States