SmartThings Multi Purpose Sensor crippled

I turned on the option to use my ST MPS (STSMLT250) as s garage door sensor and it seems to have crippled the sensor.

For a time the contact stopped working, thinking it had to do with the "Do you want to use this sensor on a garage door?" toggle, I toggled it back. It started working again, however now the acceleration and threeAxis readings are not reporting.

I set the driver to device and then back to SmartSense Multi Sensor V4, didn't clear anything, and it still doesn't work. Should I have cleared values?

Do I need to factory reset it and put it back in?



Check out this this thread and this excerpt

After many attempts at setting NO on the "do you use this sensor on a garage door to take" and having it actually work I found the answer. Looking in the log I found that even when setting NO the the garage option would be null. For functional open/close events it has to be No in the log. It would not properly set NO until I turned on description logging.

1 Like

"Enable description Text Logging" was turned on by default.
I tried toggling it off and back on and turned xyz on and off, then to NO and it's still not reporting under the "Current States" on the device page. However, if I turn on debugging it reports both axis and acceleration entries as I move it around. It sounds like activating the garage option broke something in the reporting code?

Any other ideas?



The garage option probably had more testing than the xyz, anyway, ill have a look at this.

Any luck figuring out how to reset my sensor?
Maybe rollback my hub to before I flipped the garage door switch?

nothing's changed in that driver since platform 2.0.6

OK, so how do I fix my sensor?

Since flipping on the Garage option, then turning it off since it wasn't working for me and I've decided to just go with contact option, both the xyz and acceleration are not reporting under Current States for the device. If I turn on debug and move the sensor I can see acceleration logging, just not reporting under Current States.




I don't know, haven't looked at it yet.
When I have some info, I'll let you know.

Have you tried resetting the sensor and pairing back to Hubitat?

To reset you need to press the pair button for 5 seconds.

1 Like

I just tested the unit I have and its working as expected.
When used as a garage door sensor the contact sensors magnet is not used and the sensor itself is attached directly to the overhead door with the case oriented long dimension vertical.
If the device is going to be used with the external magnet, then the sensor is attached to the door jamb and the magnet is placed on the door.

Try reseating the battery to wake it up then hit configure on the device page.

this isn't required (battery pull to wakeup), this zigbee device (like most) implements the Zigbee version of Z-Wave's FLiRS

1 Like

FLiRS was a new acronym for me. This document has a good explanation.

1 Like

Thanks everyone for responding. This is one of the older ST sensors and it appears you do have to hold down the reset button while re-installing the battery as @lewis.heidrick mentioned. Not to mention this one is a bit finicky, I finally got it on the third try.

It re-added the sensor without having to delete it, both acceleration and tilt are reading again and all the automations picked up where they left off. I re-saved each of the automations it was in just for good measure.

Thanks again,


1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.