Set the default on state for color bulbs

It would be nice to have the ability to set a default color when a color bulb is Off and receives an On. If any other command is received like color change or dim level the default is ignored.

This default could be set at the hub level as well as the device level (which would take precedence over the hub default).
In addition, being able to have defaults per mode.

Thanks, Glenn

With my Sylvania rgbws with prestaging enabled I send colortemp changes to them with each mode change. That way when they’re turned on they are already at the desired color temp, or color if you’re so inclined.

This looks like a near duplicate of your other post:

I would avoid posting the same thing in more than one area. If you want to "move" a post, Hubitat's forum software is a bit different from others you may be used to and you can edit the category and tag yourself the same way you'd edit your title.

However, you explained things differently here. It sounds like you're explaining what you want to happen, not what does happen. The suggestions in my other reply may still apply. But it sounds now like you might be looking for something more like Mode Lighting. With that, Motion Lighting, or even Rule Machine, you can specify level or (I think...haven't used this) color temperature by mode. There are some similar community options like a port of Circadian Lighting, but I don't know if anyone has had good luck with them.

1 Like

Oh didn't know or forgot we could do Mode Lighting in the Motion Lightning app. I'll give that a try. Thank you for the suggestion.

How are you turning the light "on"? Since bulbs do not have the native capability to turn on the same way that an in-wall dimmer does, for example, you should not be simply turning them on. Instead, whereever you are turning them on you should be setting the color/color temp and level. For example, in a motion lighting app, instead of turning the bulb on, set the color/color temp and level. This will have the same affect as turning the bulb on only it will turn on to the correct color.

You can do the same thing with a button controller. Instead of turning the bulb on, simply set the color temp/level.

Where are you currently turning these lights "on" that that they are coming on to the wrong color?

Good point. I was assuming he was using a voice assistant. That was a problem I had to work around. That’s where using level and/or color prestaging comes in handy. I have seven or eight modes throughout the day that I use as triggers to change the lights without turning them on. I have it send the change to individual bulbs if they are off, and to through group messaging if they are on. I just don’t set the level in the color temperature per mode so it Doesn’t turn on

Ah....yes, hadn't thought of voice assistants. I don't use them much.

The issue with setting a default level and color temp via an app is that if you turn the light on by setting it to another color temp/level, what you just commanded would be overridden by the app sensing that the light was turned on.

What you really would have to do is to use a virtual device with a custom driver. When that device received the on command, it wouldn't issue that command, it would setColorTemp and setLevel to what you told it to. You could then mirror that virtual device to your real device. Then, if you turn the virtual device on by setting level, it would set it to the level you chose in the command, not the default.

That's the problem with trying to solve a device issue at the app level. The solution isn't going to be 100% applicable but it will be 100% executed.

The way I do it doesn’t cause those issues. It would be very unlikely that I would turn on a light at the same time as a mode change. Plus one could set it to only change if the light is off. I just like my lights to follow somewhat of a circadian cycle. Or if you wanted to maintain a fairly constant default, you could set it as a periodic schedule for the trigger and have it only execute if the lights are off.

No, what I am saying is that if you set the level of the light with the light off, therefore turning it on, rather than being set for the level you requested, it would turn on to the default level. For example, I have motion lighting in my bathroom that turns on to only 50% at night. If I had something built to set the default level of the those lights to 100%, they would turn on at 50% and then go to 100%. Whatever you are doing with the default level would have to be adjusted. That complicates things greatly.

1 Like

If you use the Sengled driver you can set level without turning it on. I just found that you can’t set colortemp and level back to back or it will turn on the light, there needs to be a pause between the two commands. Also, the Sengled driver lets the lights dim to off which I found to be a deal breaker. The generic driver dims all the way without turning off.

1 Like

The generic driver does in fact dim the lights to off....the switch attribute just stays on. But there is no light coming from the bulb.

And level and color prestaging have absolutely nothing to do with what i am saying. You still have the same problem with the default level overriding what you have just requested. If you don't understand that, that's fine. But that problem exists whenever you have a default level and cannot be overcome. If you have something that changes the light level when the light turns on, if you have requested something other than that level, then your command is overriden by the default. Period. There is no getting around that.

I think you don’t understand what I’m saying. The prestaging command happens at the time I set it to happen. I can still turn on the lights to whatever colortemp and level I want by voice and it just changes to what I have requested. Also, with my lights at least, I can keep dimming them all day and they don’t turn off with the generic zigbee rgbw driver, they dim to the lowest setting. I use Alexa and a mix of Hue and Sylvania button controllers with my lights.

Then that behavior changed in a recent release. With regular sengled Element Classic bulbs, the Generic Zigbee bulb driver always dimmed to off and I hated it. I just tried it and now it doesn't. I would always dim right past the lowest level and it really annoyed me. Doesn't seem to do that any more.

Yes....what I am saying is, when are you setting that? When the light turns off? When the light turns on? Random times throughout the day? Also, level prestaging only works if the level isn't the same as what it is set to. So, if you setLevel and the level is already set to that, the light comes on.

Also, level and color prestaging is not available for all lights.

What you are saying about prestaging has nothing to do with setting a default level.

I realize there is no "default", only ways to make it seem like there is. I was only trying to help find a solution using methods we currently have at our disposal.

I forgot about that. I had to change all of my rules to use setlevel 0 instead of using switch off, but Alexa turns the lights off, not to zero, which is a problem. I would love it if these issues could be fixed, but in the mean time I'm happy with the way my lights are working with the generic driver.
Now if there was a way to slow down my GE zigbee dimmers. They come on like a flash, and the only way I have been able to solve it involves introducing a half-second delay.

The generic driver for Sengled Classic bulbs does not support transition time. That's why that driver isn't used for the regular Sengled bulbs. You only get a very VERY short transition.

Sorry, that was off topic. I'm talking about the GE zigbee in-wall dimmers using the GE driver that has a transition time to set in the preferences. It doesn't seem to make a difference with the lights turning on abruptly even if I set it to 5 secs.
EDIT: I bought a bunch of these a couple weeks ago at Lowe's for $5.50 each and replaced some of the z-wave dimmers I had that were annoying me due to how slow they were. GO FIGURE :wink:

I was talking about the difference between using the Sengled Element Classic driver an the Generic Zigbee bulb driver for Zigbee bubls...what we were talking about above.

Not sure anymore. I've never used any of the other Sengled drivers, just the color one.

I basically just want my color bulbs to default to Warm White when they receive an On command. I don't care if they receive the On command from a dashboard, voice assistant or by some other means. If the bulb was Off and it's being told to come On, it should come on at Warm White.

Alternatively, if the bulb comes on because it received a color command, then it should do as instructed and override the default Warm White.

I realize some color bulbs and device types might have the ability to do this but was looking for something that could work with all color bulbs.

I'm playing around with RM and Mode Lighting App to see if this can be done.

No rgbw bulb on the market or driver is going to do this automatically.
You'll need to modify a driver or set the ct via prestaging it...

1 Like

Download the Hubitat app