Sengled E21-N1EA RGB zigbee bulb

Ok I have been fighting the E21 Sengled RGBW bulb issue for a while, almost a year. I had 4 working with no problem. I bought 4 more for my daughters house and they just wouldn’t work. They paired fine but you could not control them. No on of off and definitely no color. Sometimes they would get a weird bluish color. I tried a number of combinations, drivers, pairing sequences, zigbee channels, different hubs, etc. I got so frustrated trying I gave up and bought some INNR bulbs but they cost about twice what the Sengled bulbs did.

Anyway. I had a box of these sitting around and my daughter wanted some more color lights for her house, so I picked up the Sengled bulbs and started diagnosis of the problem again. After about 3 hours of factory resetting and messing around here’s the solution that I stumbled on.

When you pair the NEWER E21 Sengled RGBW bulbs they appear to pair but they don’t really complete the pairing. It lies…. So factory reset the bulb. Have them close to the hub (this matters) and pair them. The hub will show they paired and they will usually get the Sengled RGBW driver. THEY ARE NOT COMPLETED PAIRING EVEN THOUGH IT LOOKS LIKE THEY ARE. Don’t do anything else to the bulb except immediately after pairing rerun the manual zigbee pairing on Hubitat AGAIN and it will pick up the bulb and complete the pairing. Once they are complete pairing for the second time they seem to work fine.

I hope this helps.


I just purchased these, and come across this thread due to the same issues. What I discovered is using a button controller with “Toggle” doesn’t turn the bulb on. After further investigation it appears the bulb does not report “off” when it is off. Therefore it won’t send an “On” command to an already on bulb. At least it thinks it’s on.

Toggle is working for me with these bulbs but in RM.

You need to change the driver. the default driver is the issue. try different drivers. i have this issue on some devices and find different drivers tend to work better. I think they lumped some device signatures into certain drivers without complete testing/verifications.

I've been fighting with one of these bulbs for a couple of months now - not sure what changed, but it would not consistently take commands (had been using Sengled Element Color Plus driver). I could turn it on and make it GREEN, but I could not make it RED. I tried playing with Set Color as well as Set Hue (0) and Set Sat (100) - just didn't want to work. It also could be turned on/off, but on device page it would not properly report on/off.

I tried the Advanced Zigbee RGBW Bulb driver today - still didn't want to completely work. Switched to Sengled Element Color Plus (legacy) driver and it is now working as expected - will continue to observe.

FYIW I use this bulb in a lamp in my garage to let drivers know if the garage door is open/opening (green) or getting ready to close (red). Just hate it when close routine starts before car is all the way in the garage, LoL.

Make sure after you change to the "Advanced Zigbee RGBW Bulb" driver you click "Configure" I am running 36 of these on that driver with great success.

Yep, I had configured it - didn't work 100% but the (legacy) driver does work, so I'm good.

1 Like