Sengled and Zigbee Group Messaging

I have two Sengled Element Color Plus bulbs in a group, using the same driver for both, Sengled Element Color Plus.

When I turn on Enable Zigbee group messaging, I have problems turning on both bulbs. If I disable Zigbee group messaging, the bulbs turn on and off, but with a popcorn effect. I have disabled on/off optimization.

What can I do to get both bulbs to turn on/off at the same time?

I have several such Sengled pairs. I use the Advanced zigbee rgbw light driver. And zigbee group messaging. No popcorning - they are totally synchronous.

Try re-creating the group with zgm on and optimization off. If it still doesn’t work, then in my experience it’s a mesh issue. The Sengled devices don’t repeat, so zgm doesn’t seem to be as robust versus other bulbs.

“I have two Sengled Element Color Plus bulbs in a group, using the same driver for both, Sengled Element Color Plus.”

I switched from the Sengled driver to the Advanced Zigbee RGBW Bulb and enabled Zigbee group messaging and now the lights are working perfectly! Optimize on/off is disabled.

I don’t understand why the driver made specifically for the Sengled bulb does not work with Zigbee group messaging, but the bulbs work perfectly with the Advanced Zigbee RGBW Bulb driver.

One thing I didn’t try was the Sengled Legacy driver.

1 Like

It is because Hubitat changed the Sengled drivers to try to make them behave more like other Zigbee bulbs, and to add some additional features. IMHO, this has caused more issues for users than it is worth.

This would have most likely solved the issue as well.

3 Likes

Zigbee group messaging is not a function of the driver.
Zigbee group commands are sent from the group application, not the device driver.

1 Like

I have been using the Sengled Element Colour Plus drivers and they work great but try the Advanced Zigbee rgbw driver and there is no colour control, I can turn the bulb off and on but none of the other features work. Loaded the driver, saved it, configured and then issues. Revert to the Sengled driver and no issues. anyone else have this issue?
B.

You have to load the Advanced driver and then hit "Configure" and the driver will talk to/test the bulb, during which time the bulb will turn on and change color.

Then it should work fine.

1 Like

Huh, I am using the "Sengled Element Color Plus" driver on 8 of my recessed den lights and 2 of my den table lights. Both are grouped as such with "Enable Group Messaging" on and "Optimization" off... everything seems to be okay but I don't generally change colors or do anything beyond turn on and off.. yeah the color thing seemed like a good idea at the time but is pretty useless for our situation. When I get Alexa hooked back up maybe will do some testing and report back.

Yeah but no, I get all the way to the "driver will talk to/test the bulb, during which time the bulb will turn on and change color." and there it ends. The test cycles the bulb through colours and stops at blue, I can turn the bulb off and on but no change in level/hue/saturation etc can be effected. the Sengled Element Colour Plus works fine for me. It is no major issue but if there is a better driver out there then I would like to use that one.
I will continue to look at it and see what the logs give me.
B

Strange. What firmware version on the bulbs?

I’ve been using the Generic Zigbee RGBW driver with mine as it seems to be faster and generate less traffic on the mesh.

The generic driver actually creates the most traffic, dedicated drivers are in the middle, the advanced drivers the least traffic.
However, use whatever drivers work best for your use case.

4 Likes

@the-leafs - And the bulb is on (has power) when you hit configure? I know, obvious, but just in case... :slight_smile:

1 Like

the bulb is * firmwareMT: 1160-80CC-00000026

yes bulb on when it is config'd

This is what mine are at:

firmwareMT: 1160-03EC-00000047

What platform version? I’m running the latest.

if by platform, if you are referring to Hubitat, yes the latest as well.

Only thing I can suggest is updating the bulbs firmware.

BTW, the second item in the firmwareMT tuple is the device type, ie numerical model number, the first is the manufacturer, the last is the firmware version.
so 80CC and 03EC are different devices, with possibly different firmware versions...

2 Likes

Download the Hubitat app