Sendmail - Send email and text notifications, (notification device) no local server needed

Does your SMTP server require the use of TLS? Your mail app probably supports TLS. This Hubitat app does not support TLS, because the platform doesn't permit it.

Looks like it's would need to turn it off if it is enabled.

1 Like
  1. Are you using the base64 encode of the Password for authentication?
  2. 2525 is the right port number to use. (correct)
  3. email server should be: (you have it correct)
  4. the from field should be a verified (in smtp2go) sender e.g.
  5. your host name field should be left blank
  6. I'm not sure about this, but I think that Username should also be base64 encoded

P.S. The new GMAIL server program, will also work with any gmail address (if you can't get this working):


couldnt get sendmail to work. Got this to work. Verizon blocks email to text from Gmail, or severely delays them. Now trying to filter and forward emails so I can text myself. lame.

Ya well just saying it doesn't work is not helpful where are logs of you trying to use it.

Also the parameters you show above are
totally screwed so that would never work.
From and to are obviously emails and that is not what you have.

1 Like

ok here is correct configuration for smtp2go.. it does need auth and also uuencoding of the username and password.. note one confusion is th username and password used isNOT the username and password you use to log into the smtp2go site but the user name and password under sending/smtp users ..

i used port 25 but port 2525 works as well for those who have isps that block 25 (common)
also, the from address needs to be a validated from on smtp2go or you need to validate the entire domain with dns cname records. see below for link of site to encode your username and password.


use this page to encrypt your username and password


When is base64 encoding of the username and password required?

I think that depends on the email service you're using...IIRC the email service determines those requirements.


To test the connection from my network to my desired SMTP server, I can telnet and issue what command?

depends on whether it needs helo ehelo etc. but telnet to port 25 or whatever port

220 R900 (IMail 2746-1) NT-ESMTP Server X1
250 hello R900
250 ok
250 ok its for
354 Please start mail input.


250 Mail queued for delivery.

for more info on various commands search for smtp rfc

1 Like

Telnet appears to work?


but I'm getting errors when using the Driver:

The first attempt which resulted in "bad response for Username = 535" was not base64 encoded. The second attempt was base64 encoded and did not generate the same error.

Thats not working 500 is an error message.

I hate to write this, but Sendmail has stopped working for me maybe a week ago.
It's been so rock solid for such a long time.
So long, in fact, I have to re-educate.

Has anything changed recently on the app's end?

I should probably take baby steps to get to the root of the problem.

I am using version 4.7.

This is what the log looks like:

Looks. Like your server is no.longer answering in whatever port and ip you have set up.

1 Like

Updated to 4.93, now nothing in logs.

I guess I didn't take baby enough steps.

oops: had only info logging on.

edit: New version didn't help.
Will have to delve further...ugh.

Just thought I'd paste this here to compare:

It's Spectrum (Charter).
Has anything changed lately?
I verified that Charter email works.
Verified password.
Sent text to phone.

Current Settings:
email server:
port #: 587

you need to test with telnet from inside your network.. i just ran my spectrum test and it worked fine..

telnet 587

have you changed your router or firewall etc.

also try the network diags in the hub maybe it is not resolving