Secure SSR302 - Dual Channel ZWAVE Heating Controller - ISSUES

@simon Including you as you have been helpful in the past.

The SSR 302 using the Fibaro FGS-222 Double Relay Switch work great all last Winter.

As the heating kicked back in this year been encountering issues with it being extremely unresponsive for periods then Ok for quite a while.

The Device does not respond to APPS asking to Turn On Off, there is no record in the SSR302 Device Logs to show that APPS had made repeated requests.

Going into the Device and pressing On/Off does not cause any action to occur or even register in the Device Event Log.

I have replaced the SSR302 with a new one

I have moved the HE to within 10 feet of the SSR302 and recorded excellent speed and connection.

I have put a SSR302 on my other HE and it is the ONLY wave device on the HE.

Still I am encountering issues of the Device going through periods of unresponsiveness.

Any ideas would be welcome

NOTE - The first HE does have 2 persistent zwave GHOSTS that I am working on removing.

I'm having horrible Z-Wave issue with HE every since I moved onto a C7. It's like the system needs a full-time Z-Wave radio technician just to keep a dozen or so devices online.

Sounds like you are in the same or a similar boat. Interesting that with only one Z-Wave device on a hub that you still have issues.

I'm planning on Wi-Fi switches for my 4 heating zones to replace the Horstmann/Secure Z-Wave devices. I just need to work out the wiring to the boiler and the zone actuators on the pipework.


Ghost removal may solve your issues, mesh can get very erratic with only one, let alone more than one.

Yes I would hope so. I getting Windows pc up and running and a zwave usb stick and dl the SI PC Controller so I can fix the HE zwave issues.

But unfortunately, the issue remains on an HE c7 that has only ever had one zwave device, the secure ssr302 :frowning:

Not familiar with the SSR302 but if it isn't responding from the device page then nothing else will work. With only one device there is nothing for it to route with outside of a direct connection. If the zwave details show a good connection then the issue could be the driver and/or the driver w/security - some drivers may not have the security coded.

The driver and the device worked solidly last winter.

So a great pity it is playing up now.

A work around maybe to drive HE from Node Red and move the boiler controller to Indigo and and drive it from NR as well.

The second HE is close to the boiler so getting a good connection :slight_smile:

Is this a built in driver or a community one? If the driver supports it, it may be worth turning on all of the debug options to see if it shows something that isn't being handled or seems to be coming in the wrong order.

It is a community one.

Looking into it appears I have two issues with the device/device driver (tried multiple, 4 different devices).

It ran reliably last winter (although on reflection, I had to add a periodic timer so may have been experiencing same issue and just put it down to an unreliable Rule)

1st issue is the device is just unresponsive and ignores commands for periods of time 10-20 mins.

2nd issue I am now seeing, because I have turned off periodic 10 min trigger, that the device is reporting on or off and is actually the opposite.

The true state of the device can be determined by a poll.

So a short term workaround is to add a poll and a delay into any rule calling it before performing any function on it.

Unless a more reliable way to drive the boiler becomes available, I can move 5he heating logic to Node Red and add another zwave hub which supports the device and supports node Red and use that.

Looks like this is a ZWave+ device so it shouldn’t need polling unless it was having issues with the mesh and getting back to the hub. What does the Zwave Details page show for this device? Thinking maybe some electrical noise interference…

@habitat [quote="habitat, post:4, topic:84282"]
But unfortunately, the issue remains on an HE c7 that has only ever had one zwave device, the secure ssr302

If this is your only z-wave device, try this in this order.

1: Remove the z-wave device from the z-wave details page.
2: Check devices page and make sure it is gone. Remove any instances you find.
3:Go to settings>>Backup & Restore and click download at the bottom and save your database to your pc.
4:go to yourhubip:8081 and do a soft reset
5: Restore your database that you saved to your pc
6: Go to settings>>z-wave details and scroll to the bottom and reset your z-wave radio (this will also reset the z-wave database itself)
7: Factory reset your ssr 302 and then re pair

Note: If you have a failed pairing, stop and check for ghosts. Remove ghost then exclude unit before re pairing.

See how that works for you

@rlithgow1 Thank you for the advice.

This issue was occurring on the HEATING HE Hub and I have developed two ghost devices which I am in the processor cleaning up (using the SI PC Controller method - which requires I get a Windows machine up and running to do it) but your suggestions have merit and will try that with the HEATING HUB.

But more importantly the ssr302 is the 1st and only ZWAVE device added to the MASTER HE Hub and the issue with the device remains.

Given that I have tried 4 different ssr302s and they were working solidly on the Indigo hub for a couple of years I suspect the issue is the HE Zwave/device driver.

I can code in a Poll in the Rules that control the Boiler so will give me a workaround - and if push comes to shove I drive the Rules using periodic timer so it just keeps hammering the device until it responds.

I have run up a maxed out Mac mini M1 for running Plex, 4 TV Tuners/DVR, Sonos Music Library, Audio book library etc and have also added Docker/Node Red.

If doesn't stabilise with additions to the Rules to Poll, I can move the ssr302 onto Indigo on the Mac mini M1 and use Node Red to manage it as Node Red can span multiple hubs.

Given that the Mac mini has a lot of processing power and is only drawing 18w and is on a UPS running Home Automation on it makes sense for me.

Node Red will allow me to abstract logic from the controlling Hub and give me more flexibility on how to make it all work.

If that is the only z-wave device on that hub, I would reset z-wave just to eliminate a possibility.

Thanks for all your help, much appreciated

I can get the HE MASTER hub another 5 feet closer to the Boiler ssr302, so it will be 5feet from it rather than the current 10ft

Direct connect as expected (would be a real problem if it wasn't :smile:), 40kbps not great, but definitely workable, RSSI of 7 is a little low but I've seen worse. Adding a repeater or moving the hub closer might work depending on what is in between but maybe @bcopeland has some better ideas.

BTW - What driver are you using with this?

I am using the *

  • Fibaro FGS-222 Double Relay Switch Device Type - For use on Hubitat
  • Author: Robin Winbourne
  • Date: 2018-03-24
1 Like

FYI - The SSR302 is not Z-Wave Plus..... Hence the polling.

Are there multiple versions because this has the plus logo on it:

Your right - new ones shipping now are Z-Wave Plus.......... A recent development. Most of the existing ones in the wild will be the non-plus

1 Like

That would explain why the rule last year worked (was wondering about that). So the thing to do here would be to either implement the Zwave Poller app or do the polling with a rule like the OP had last year and see if that fixes the issue.

1 Like

Ok it has stabilised by adding a periodic timer.

A thought…

Can I use Predicate on the thermostat state so that the periodic timer only kicks in when required?