Schlage Zwave connect not working after update

Updated the other day. Then there have been several updates every day since. I assume hot fixes. Ever since my Schlage Zwave lock is not working. I have to send a lock or unlock command twice to get it to work. Works very reliably on the second command to lock or unlock.

Tried resetting by removing battery. Unpair, re-pair, zwave repair, hub reboot, changed drivers, etc etc etc.

have you tried doing a full reset of the lock?

I didn't try it initially. But just did per your suggestion and no change in performance.

Is this the old Zwave or Zwave plus?
Are you using the "Schlage BE468/BE469 lock" stock DH?
Do you have any other Zwave devices? If so try power them off one at a time and test the lock each time. Maybe one of them is interfering.

This is zwave plus. I bought the lock in September.

I'm using the Be468/469 driver. Tried the one that is in the 500 series also. also tried the "generic zwave lock" driver.

I have a few zwave devices, yes. closest one physically is an aeotec repeater 7

to be clear you do not need to remove the other devices just power them off one at a time and see if they are causing interference.
Have tried new batteries?
I have a Zwave plus model and I am not seeing that behavior. I do also have the zigbee version and prefer it over the Zwave. I find the Zwave plus slightly slower to fire.

If you unplug a Zwave device and the lock doesn't fire at all the lock was routing through that router device and I would suspect a problem with that device.
Then doing a Zwave repair should fix the lock and leave the other device offline. Find a different brand.

1 Like

Thanks for your help so far.

I have powered down each z wave device one at a time. I then retried the lock. Still have to send lock or unlock command from the device page twice to get it to fire. Fires reliably 100% of the time almost instantly after I send the second command.

I then did a repair after removing each device. Same result.

I did this until I had all other zwave devices offline. (I have only a few. Repeater, siren, one contact sensor, and a mains powered switch outside.

the lock is now the only zwave device I have online. Same issue, same performance when sending two commands to lock or unlock.

I will try to move the hub. Its a foot from my router and 2 feet from my smartthings hub. It has always been there, and lock has worked fine. But getting desperate.

Any other ideas appreciated

edit: also of note, when I reboot the hub, if I go directly to the lock and tell it to lock or unlock it fires immediately on the first command. but thereafter it takes two commands.

did you try powering off your SmartThings hub?
if that didn't work can you exclude the lock from hubitat and join it to SmartThings and see if the lock has the same issues or if it works fine. To confirm it is not an issue with the lock itself.

I thought of that after I posted above. I did power down smartthings. there is nothing on it. I switched to hubitat almost immediately after I got the smartthings.

This is my first go at a smart home.

I will try to put lock on smartthings hub and see what happens.

have you also tried different batteries?
alkaline AA batteries. Some say Lithium batteries may cause undesirable operation.
When I did use batteries I only used rechargeable alkaline batteries. (mine are all hard wired now)
Since the other Zwave router devices didn't make a difference you can power them all back on again.
Only other thing I can think of is to put a Zwave router device (that is are ready paired and working correctly with Hubitat) near the door lock and then pair the door lock to Hubitat again.
I have GE jasco Zwave plus motion switch next to my lock.

I haven't tried new batteries. They are the ones that shipped with the unit. Reporting 95% in both hubitat and smartthings.

I paired it with smartthings and it works flawlessly

The repeater I have was already in the closest physical outlet to the lock.

are you using a C5 or a C7 hub?
for the C7 I believe there was a Zwave firmware update awhile back
If you go to settings, then Zwave details, then select firmware update.

Mine is on a C5 hub

its a C7. I had tried a few days ago when this started to update the zwave firmware. It says I am already running current version.

Checked again just now and it still says I'm current.

maybe a different router device next to the lock.
to test if range is the issue first.
If you can put the lock next to the hub and then pair it fresh (after excluding from Smartthings) and see if you still have the same issue while the lock is next to the Hubitat hub.

You are on today's latest hub firmware update correct?

I don't have any other repeaters to try unfortunately.

I can try to get the hub closer. Not sure I will have much luck. Its only about 15 feet from the hub currently with no walls in between. The smartthings hub is only a few feet further away. 20' maybe.

yes I'm on .158

give it one more try and do a full reset (maybe a couple of times) like I posted earlier before pairing to hubitat again.

If that doesn't work try email hubitat support


thanks for your help!

Also on the lock device settings page have you tried to hit configure, refresh and save preferences?
Does it still do the same thing?

all my preferences are off (enable lock code, enable debug, enable description)

also like I mentioned the zwave locks are a bit slow to respond after you first select lock or unlock do you give it 30 seconds to see if it responds before hitting a second command?
usually it is only a second or two but sometimes mine take up to 8-10 seconds (when a rule fires)

I didn't try that. Try those in order? I do have the logs and debug turned on I think.

Before I updated the lock was responsive and fired within 2-3 seconds everytime. Its seriously instant with smartthings.

I will try to give it 30 seconds and report back.

refresh should not matter but try it after you select a command that does not appear to fire.