Schlage Connect Camelot Pairing Issue

I’m trying to pair my Schlage Connect Camelots and have factory reset one but it seems to try and pair for about 3 seconds before beeping to say unsuccessful. I can certainly try bringing the hub nearer but isn’t this 3 second thing a bit limiting?

1 Like

I don't own Schlage locks, but 3 seconds sounds like it's not actually reset. Factory reset MAY not have Excluded the device. Try using Hubitat's Exclude: Settings: ZWave Details: ZWave Exclude. You probably also want a live log running in a new tab/window.

Once Hubitat's exclude is running, do the click/button/triple click... etc. whatever it needs per the Owner's Manual. Look at the logs to see that it excluded some unknown device.

I'm having the same issue. Wouldn't pair with SmartThings or Hubitat. I removed it from Lowe's Iris before the service went dead. I've done a dozen factory resets, still no luck.

I have 3 of these and spent an entire day before each was "successfully" paired and configured....You have to have the hub literally right next to the lock (whether it's bringing the hub to the lock or the lock to the hub), then try the excluding process (if it doesn't exlude, skip to next sentence). Once excluded I then factory reset them, then I did a "hub shutdown" as this day long trial and error process ended up several times making my zwave radio in the hub stop functioning, which is fixed and refreshed with a shutdown and a 30 second power cycle of the hub. After you have a fresh power cycle and the lock is factory reset.....THEN do Exclude once more it should take it immediately (IF the hub and lock are right by each other) then you should be able to Include them, after including them Open a tab with your logs then hit "configure" on the device screen and wait until the logs goes through scanning all 30 lock codes and the logs stop activity BEFORE powering anything off and relocating to it's use locations. It's a huge hassel but this process is what ended up working for me, and now all 3 work fine and work well with lock code manager

Thank you for your help. Even though I removed the lock from Iris, I'm still suspicious it isn't unenrolled from Iris despite numerous attempts at factory reset and exclusion via Hubitat.
Maybe I'll have time to try it tomorrow. I literally held the Hubitat or ST hub against the lock as I tried different procedures.

Since I'm new to any system other than Iris, I'm not sure I completely understand the exclusion process. I think it's you perform the reset while the hub is in exclusion mode. If that's it, what is the proper process on the lock itself? I've been doing schlage-6 digit key - 0.

Thanks again.

It won't matter even if it's still enrolled in Iris with doing a factory reset (hold the schlage button, unhook battery, wait a few seconds, plug battery back in, then after green check blinks release schalge button) and also using the exclusion process.....this is how the process works say you were to buy the lock from someone who didn't exclude it prior to selling starts it from factory. After you do the factory reset process , I'll guide you the simplest way possible (that I found)

  1. Go into your settings tab and select "Shutdown Hub" , when red light appears on hub, unplug the power cable for 30 seconds, during this time make sure hub and lock are literally beside each other, and then plug it back in.
  2. After hub boots back up (green light) go into "Discover Zigbee and Zwave Devices", then select Zwave (I'm assuming yours is the same as mine), which will bring up the "SCREENSHOT" provided
  3. Click the "Start Zwave Exclusion", then immediately enter in your 6 digit password on the lock then select "0" on the lock, the green check should blink. And you should get a notification on the hub screen that a device was excluded.
  4. Repeat the above steps UNTIL you get the green check to blink.
  5. After you get a successful exclusion, you can then click "Start Zwave Pairing" and then again enter in the 6 digit password in the lock followed with "0" A green check indicates successful pairing (be patient this may take up to 90 seconds, even past when the countdown timer ends). However MANY times my lock got stuck during the device "initializing" phase, so wait a good couple minutes before doing anything else as if it doesn't get to the frame that allows you to enter the name of the device you have to start all over (and this happened REAL frequently when attempting this process NOT with the devices next to each other)
  6. After a successful pairing and device name description added, go the the devices page and select that device, also open up a separate tab with the logs tab so you can view the progress. Then on the device page click "configure"
  7. Verify the logs check that lock codes of all 30 available codes and after that once the activity stops in the logs you should be good to go!
  8. If you don't get the discovered device pop up on the screen after entering the 6 digit password + "0" and the red X on the lock appears, you have to start over trying to exclude it again.....I found it had to be successful in the exclusion before I got it to successfully may take several try's as it took me a full day to do 3 locks, but most of that day was realizing I had to get the lock and hub closer together, not 100ft apart in the pairing process even though I had repeaters close by.

Thanks for the detailed response. I did all of that, but the powering down of the hub. Ran exclusion with the hub powered on and the process on the lock. I'll try your way tomorrow.

When doing my garage doors today I also ran into the part where it would identify them quickly, but stall at initializing or take a long time to complete. They're both paired now, but not always operating as directed or reporting their open/close status correctly. Even on open/close commands sometimes it comes through immediately, others up to 10 seconds or more.

Thanks again

@waynespringer79 is spot on with the advice given but you have to set the Secure Join mode (Under Z-Wave Details) to "All Secure Z-Wave" rather than "Locks/Garage Doors".
This seems counter-intuitive but trust me it works. It took me a while to figure this out. I have 2 Schlage BE469 touchscreen deadbolts that I manage with my Hubitat HA, mostly just with the lock code manager.

Hope this helps.

1 Like

Thanks so much, because I've gotten nowhere so far. It won't even recognize the lock. I hope to look into it tomorrow. I'll report back.

Never tried the "all secure" method, mine was just on locks and garage doors.....I'll take your word for it as I feel for @awraynor I don't want to personally mess with that again, so far it has been my ONLY problems making the migration over to HE......

1 Like

I was surprised on how much difference the exclusion/inclusion process was better with a freshly power cycled hub.....

1 Like

The lock is a bear, but the garage door opener issue almost has me wanting to replace my lift unit and the controller.

If I had a dollar for every time I cycled the hub...

The execution of the commands have been from instant up to many seconds for me. In the next few weeks I'm looking to replace my mesh wifi with ubiquiti equipment to get a more solid experience.

One other word of advice is to take notes on all of the pairing methods for all of your devices and keep them catalogued for future reference (I use an Excel sheet). This has saved me countless hours re-pairing all the different devices when rebuilding my Z-wave mesh.



1 Like

You are so right. I forgot how to do some of them and there's a lot of wrong information out there. Most of the Iris devices still have good videos. The garage door openers once again have numerous methods listed incorrectly. Another pain point was the CT-101 thermostats. I've got those up and running. I do miss the scheduling interface I had on Iris for them.

These are the devices I took the most notes on. I logged what worked for me, willing to share if it helps.

1 Like

Anything you can provide would be great. Even discovered a phone app by the manufacturer for the CT-101's because I would like remote operation of the t-stats and GDO's. If you install them under SmartThings and link them, do you still get the benefits of both systems?

I've been having issues with one of my BE469's since I moved to Hubitat. Today I decided to unpair and repair since OZWCP was showing no manufacturer or anything for this lock. I couldn't get the lock unpaired (exclude didn't work), so I force removed. Then I had to use my ST hub to do an exclude (worked perfectly). Then repaired the lock with HE, but now it's just in this state where it doesn't respond, doesn't give any info, etc. Not sure what to do... =(

finally got it paired. and kind of working... but can't get it reprogrammed. it won't take codes. I got the factory codes deleted, but it won't take new codes programmed, or get it to recognize that they are 6 digit codes. =(

Even manually when entering in the keypad your 6 digit passcode + #1 then your new code......of course the default is set to 4 digit codes, and I don't have the manual close as to which # after the passcode changes this to 6 digits as I only use 4 digit