Scenes not applying correctly

I’m trying to use Zignito RGBW GU10 lamps with Hubitat and I’m having trouble getting scenes to apply correctly to the 9 lamps in our kitchen ceiling.

The basic problem: The lamps don’t come on correctly (random/mix/most in prior state) if call the scene with them initially turned OFF. If the lamps are ON when I call the scene all lamps set to the right colour.

What have I tried:

*Turn on “Enable optimisation”
*Turn on “Enable metering” and set to 1000ms
*Turn on “Enable discrete on for activation”

Now, I thought the last one would crack it but none of the above fixed the problem. Why did I think the last one was the solution?.....

What I then found was that if I send a colour setting directly from the device page in Hubitat the lamps come on BUT DON’T change to the correct colour. I think this is closer to the root cause, but that makes me wonder why “Enable discrete on for activation” didn’t fix it?

Indeed, with “Enable discrete on for activation” turned on I cannot see two stages (on then colour change) in any of the lamps that change to the correct colour. The same is true if I add metering at 1000ms, there seems to be just one command to the lamp as opposed to two (on + colour). It’s like that switch isn’t working in Hubitat.

Finally, instead of building the scene around the 9 separate lamps, I built the scene from two groups (3+6) that I have set up for other reasons and it works perfectly. So in the end I find:

*Sending a colour command to a single lamp device turns it on but does not set its colour
*Sending the command again then sets its colour okay
*Placing a single lamp into a group and then sending a set colour command to the group turns on the lamp AND sets the colour correctly
*When I send just a colour command to a group device I see the device turn on and then change colour

If this is all correct, my conclusion is that the Zignito lamps need an “On” command and then a “Set colour” command and that the “Enable discrete on for activation” switch in Hubitat doesn’t work.

But I’m probably wrong, it’s only my first day with my new Hubby lol!!!

I’m really looking forward to playing my part in the community, sorry to be here with a “need” as my first post. Anyone got any thoughts or suggestions for me? Thanks!


1 Like

@bravenel I just tested this and found the same. It appears the discrete on isn't sending the on command as expected (Scene-1.2)

Discrete on has nothing to do with it, and applied only for some odd CT device that would not turn on when command to set CT (which should turn it on).

This sounds like the driver doesn't work correctly, or the bulbs don't work correctly. They are not on our list of compatible devices. What is the driver that you are using?

@tony.fleisher For what bulbs and driver are you using. Show logs. discrete on sends the color, ct, or level command, then on. It will show in the logs.

Here is the log from a Scene with Segled CT bulb, Inovelli RGB Lightstrip, Hue Bulb, and Hue Group:
The first activation the lightstrip was off and the on was sent. The second they were all on and no on command was sent.

Similar with a scene with only one hue group (from CocoHue):

If only sends an On command if the device is off. It checks first. This is true irrespective of discrete on setting.

mm.. what does Enable discrete on do then?
This is what the documentation says:

  • Enable discrete on for activation: if enabled, will send an "on" command to any devices in the scene that are captured as on. This is normally not necessary, as commands like "Set Level" or "Set Color" will normally also turn a device on if it is off, but some devices/drivers may require this option (e.g., because a prestaging option is enabled).

As the document says, for devices where commands setLevel, setColor, or setColorTemperature do not turn on the device if it is off (which, incidentally, all drivers for lights are supposed to do), after sending those commands if the device is off it sends an on command.

For most devices, it is unnecessary to send a separate on command after setLevel, setColor or setColorTemperature, as those commands turn on the device.

Sound like the issues we had with some lamps before the RGBW lamp advanced driver.

We found that's most of the devices would not change colour unless they were in the on state. So the new driver sends on before a colour change.

You get a slight delay fade to colour now but works much better.

Thank you everyone for your replies so far, your input is very much appreciated.

Currently I'm using the "Standard RGBW" driver, not the Advanced version which didn't seem able to even turn the lamp on.

Scouring old posts I find this has been an issue for people before:

I don't want to be a nuisance here but if we can solve this I would love to leave breadcrumbs for others to follow to help them. So, I have new threads to follow thanks to your postings, I've contacted the supplier (Ajax) today to ask them as they do list Hubitat as a compatible hub and I want to invest some time getting familiar with the logs.

I'm away from home until Tuesday night so I will post an update then, either with the answer or more information.

Thanks again for your patience with "the newbie" :grinning:

Slightly later than advertised I've done some more work.....

  • I WAS using the Standard ZigBee Driver, I'm now using the Advanced Driver
  • The problem I was having with the Advanced driver was my error (configure button)
  • The Advanced Driver DOES turn the lamp ON when it sets the colour (unlike Standard Driver)
  • Scenes are still applying erratically/incompletely

So I've tried changing channel and checking my Neighbour table, it looks okay, good LQI:

So I've turned on logging for the scene and I do find a problem.

The scene has 9 lamps, 3 rows of 3, numbered 1.1 to 3.3 where the first digit is the row and the second the column. The scene should set 3 red, 3 white and 3 blue lamps and is called Jubilee.

Here is the log from an activation:

The error is continuing to reoccur every 2 mins.

Can anyone give me a hint where to go with this next?

May be wrong but looks like you have something else running a command?

Is this log from the device or from the app? If from the device screen shot the bottom of the device page, possible a subscription?

If a app what app.