Scene fails to turn on lights (

I have a scene that I've been using for quite a while that stopped working properly with the update to 2.2.8. It is intended to control 3 RGBW zigbee lights. It turns each of them on, sets the dimmer level, and sets the color temperature. Prior to 2.2.8, it worked fine.

When I run the scene with the lights on, it does adjust the dimmer level, and modifies the color temperature to reflect the scene settings. If the lights are off, however, it will not turn them on (which, again, USED to work fine).

I've even tried creating a new scene, but no dice. I have a C-7 and I just updated to the lateset/greatest 2.2.8 (which is .141 as of this writing). Am I hitting a bug? Or am I doing something wrong?

Thanks in advance.

1 Like

You don't happen to have enabled any prestaging preferences on the devices in question, did you? If so, that's part of how they work--the "Set Level" and "Set Color/Color Temperature" commands that normally turn on a device if off will not turn it on if it is currently off if the corresponding prestaging option is enabled.

Otherwise, I'd verify that these commands work as expected from the device page--e.g., if they are off, does running a "Set Color Temperature" command (put in a value like 3000 or 4000 if you're not sure what to do) work? If you're using one of the "Advanced Zigbeee...Bulb" drivers, you may want to run the "Configure" command on the device page to see if that helps, and give it a few seconds to finish before trying anything again (can't hurt regardless of driver but is particularly important with these).

You were spot on! They did have color prestaging turned on. Turning it off fixed the issue, so first up - my thanks. :slight_smile: This was driving me crazy.

A couple questions, if you happen to know the answers.

  1. I admit to not having looked at the documentation recently, but I THOUGHT the point of prestaging was that it would allow attributes of the light to be set before turning it on, so as to allow the device to be turned on in a specific state, rather than turning it on first and then setting the attributes. Am I just confused on this point?

  2. Any thoughts on why it worked fine before I upgraded to 2.2.8?

Your understanding of prestaging sounds more or less correct. I don't know that the intent was to necessarily eliminate a flash of previous color/level you may see when turning on a bulb (a common question, and this behavior varies by device) so much as just to allow you to send these commands when the bulbs are off (e.g., so you could have a rule that prestages color temperature based on time of day, then any of your apps could just turn the device on/off without needing to worry about CT since that is handled separately, and CT can be set without inadvertently turning on the device). The latter is really all it's supposed to do: allow you to send the relevant commands without turning the device on. So, you need an explicit "On" command at some point after to make it work.

The preference-based prestaging option is a bit awkward since it affects the behavior of "standard" commands and can affect the behavior of other apps in unexpected ways, as you've discovered. The newer "Advanced Zigbee..." drivers moved level prestaging into a special command instead, and my hope is that they'll eventually do the same for color and CT. This would (and does, for level) allow you to just run the command whenever you want to prestage without affecting the "standard" commands or the behavior of apps that don't expect this (which is nearly all of them).

Can't think of why it would have worked before 2.2.8, though. Nothing should have changed in that regard. :thinking:

1 Like

This is super helpful (not to mention interesting). It's piqued my curiosity on why it used to work and no longer does, but your confirmation of expectation and explanation of how the calls work is very much appreciated. Thanks for the info drop, and taking the time to explain it. :slight_smile:

Had the exact same issue and never had a problem till after the update to 2.2.8

Turned off color prestaging and Bob's your Uncle. No idea why it was on. I have no recollection of enabling it. Like ColeT, it worked as expected up until the update.

I am having this exact same problem. I upgraded to, from 2.2.7.*. I have three RGB Genie Zwave controllers. In my scene, two of them have scene settings for switch on, level, hue and sat values. Those turn on fine. This third has scene settings for switch on, level and color temperature. That third does not turn on. If I go into the device page for that and manually turn on, set level and set color temperature it turns on fine. All of these devices has color prestaging set to off.

So something in the upgrade broke this.

Well, no, because nothing changed with this release that would affect this. Have you tried 'metering' in the Scene. Sometimes what happens is the Z-Wave mesh gets overloaded by activating a Scene, and some device doesn't get the command sent to it. Metering slows it down a little. Try 70 msecs, see if that fixes it, or play around with it.

I just tried metering at 70 msecs, as well at 140 msecs. Third RGB Genie with CT setting still did not turn on with the scene. I then changed the scene to instead have RGB values for that third RGB Genie. It turned on fine with the scene. I then changed the scene back to CT values for that third RGB Genie. Did NOT turn on with the scene again.

It seems something changed with scenes, because I also noticed the scene device state does not accurately reflect whether all the scene devices match the scene config. I see in another thread that you recognized a bug in that regard. This scene has been working fine for many months now. Only started failing with this device after the recent upgrade. Hence, my blame on the upgrade. Seems something changed, maybe with another change somewhere that had unintended consequences on the scene?

Are you using the built-in driver for this RGB Genie device?

Which RGB Genie device is it? What is the name of the driver?

You are right, that Color Temperature methods were updated, and possibly this driver is not right.

All three are RGB Genie ZV-1008. I am using the driver I got from RGB Genie directly, written by Bryan Copeland, last update dated 2020-05-01. The name is "RGBGenie LED Controller ZW" from:

I'll go check if there is a newer version, as well as try with the built-in driver, to see if I get proper results.

There isn't a newer version.. Hang tight

This version will fix it for you
hubitat/zwave-led-controller.groovy at master · djdizzyd/hubitat (


@bcopeland That solved it sir. Thank You!

1 Like