How to take advantage of the expanded 3 parameter setColorTemperature

V2.2.28 has the following improvement:

  • New driver features:
    • Updated Color Temperature drivers to support the expanded 3 parameter setColorTemperature command.

What do I need to take advantage of this improvement? Does this require support on the device? Or driver? Or app?

I have an issue with RGBW LED strip lights that are not doing what I want when I turn them on and set color temp and dimming level in a rule. It used to work 95% of the time, but recently (probably after 2.2.28), it works 0% of the time. I removed my legacy RM rule to set color temp and level, and created a new RM 5.0 rule but no change.


The added feature in SetColorTemperature have to be coded in each individual driver. What the release note is saying is that the Hubitat native drivers have been updated. Custom drivers would be handled by the creator of that driver.

My custom drivers have had these enabled for a long time; but, my job was easy just due to number of drivers compared to native drivers.


The question here would be what device this is and, really, what driver it's using. If it's a stock driver, it should have been updated; as noted above, community drivers will need to be updated. I think platform 2.2.8 was when many stock apps started relying on the existence of the 3-parameter command, so if you have a driver that hasn't been updated and you're using an app that depends on it, that would explain the failure. If the driver has been updated, there could be a bug. Knowing more information like what driver you're using--and possibly checking your logs for errors--would be a good first step.

That being said, I'd also make sure you didn't inadvertently enable any prestaging options, as I also mentioned in the thread linked to above. :slight_smile:

Thanks for the replies.
I did read about the pre-staging earlier but did not see such an option on my device pages for the strips. I've tried the configure command but that did not yield any improvement. Do I have to re-select the driver for the device? Or should the new functionality "just work" after the system update without any user intervention like rebooting or such?

I am using the system "Advanced Zigbee RGBW Bulb" driver. The LED strips are Sylvania strips that I've been pretty happy with. I know some folks have reported issues with them but they've been working fine for me, other than this new quirk.

Being a system driver, that one should be (and I know has been) already been updated. It's odd that your device doesn't like it. Maybe start by ruling out an app problem: if you get the command directly from the devices page and fill in either 1, 2 (the second and/or third), or 3 parameters for the "Set Color Temperature" command, then click the button to execute the command, does it work? As it seems you've read, lots of Zigbee bulb/light devices are problematic, at least when mixed with other/non-bulb devices on the same network, but commands sent directly to the light usually aren't the problems you see.

Setting the level and color temp from the device page, has the same issue. It does not set the level if the device was off and at a different level. Is the pre-stage attribute supposed to be on the device page under preferences?

I turned on debug logging but it did not reveal much. I see info messages for turning the device on and setting the brightness (but not the color temp). So this probably some timing issue now between the hub and the device.

This definitely worked 95% better in a previous version of the hub software. I guess I'll have to change my automations to use two steps. Unfortunately these are in the kitchen and there are three of them and they are involved in a bunch of automations. Or just deal with it and press the buttons twice.

The "Advanced..." Zigbee bulb drivers do not have a prestaging preference; that has bewn moved to a new standard command (at least for level; I assume they're still trying to figure out how color/CT should work). Assuming you did hit "Configure" (and wait a few seconds), which the Advanced drivers will definitely need to work properly if they didn't pair with that driver, you might want to try a different driver to see if that helps. The analogous "Generic Zigbee" driver would be a good place to start (and again be sure to run Configure after the change).

I eventually got everything working by switching to the generic Zigbee RGBW bulbs and a combination of saving prefs / configure. Thanks for all the suggestions!