Samsung Smart Button Press Not Working Correctly

Hi all,

I just bought a Samsung smart button and it doesn't seem to be working correctly. I have it paired and am using Hubitat Simple Lighting.

It is supposed to toggle on/off on button press. It seems that if the lights have been off for a while and I press the button, the lights come on, then after about a second, they shut off again. If I press the button again, the lights come on and stay on. Has anyone seen similar behavior? Thanks.

Are the bulbs that the button is controlling updating their states correctly? I've had cases where the bulbs hadn't refreshed before I turned them on again so they needed a double press to synchronize their states with the state of the button. To get around that I run a refresh rule on the bulbs every 30 minutes so all states are accurate at that point.

How many Zigbee devices do you have on your system? My guess is that you’ve got at least 16.

I have 3 on my upstairs hub - using RM trigger not SL and they work really well for the most part. Fast and responsive. Once every so often there is a delay on a push and if you push it again both get executed. Also noticed that the button can be very sensitive - sometimes placing it down triggers it.

SCheck the "Events" link on the device page or the past (or live) logs (if you have this enabled). You're likely experiencing the problem where the button itself incorrectly sends multiple pushes, which is a known problem for some users of these buttons, particularly in early firmware. This thread and this post in particular is one place you can read more: "New" SmartThings 2018 sensors

To work around this, the driver in the post linked to above may work. If you have an ST hub, temporarily paring the button to that and allowing the firmware to update may also resolve the underlying problem. (No need to remove it from Hubitat; just leave it and reset the button to switch between hubs as they are put in pairing mode. That way, your Hubitat automations stay intact.)

Of course, it could also be another problem as mentioned above. The logs or events will help narrow it down. But it sounds a lot like the issue above.

Before trying to upgrade the buttons, I suggest checking logs to see if other Zigbee devices are reporting multiple duplicate events. Look for multiple reports of temperature, open/close, etc. If there are other devices with duplicate events that means it is a Zigbee issue and a firmware update on the buttons will not help.

Thanks for the responses. I'll have to check when I get home.


Yes, I have more than 16. I think between 30-40.

Check for other devices reporting duplicate event before doing anything else. If others are doing it, you’ll want to wait for the next release which should have the Zigbee improvements.

When you say next release do you mean the next Hubitat software version or something else?

Next release of Hubitat. I think the improvements will be in the next update. However, that's just a guess, only the HE team knows the real answer.

I just checked the logs and yes, I do see duplicate events, include where the toggle action for the button repeated. I assure you, I am only pushing this once.

Is there no way to work around this currently?


I would try removing the button, resetting it and then add it again. It looks like the button itself is either looping up or the clicker is just stuck.

I doubt it's a physical problem as you can see that the every event is duplicated (including the temp and battery readings). @Kato, are you seeing similar duplicates with your other zigbee devices? I would also guess that you have the issues @srwhite was referring to. Hopefully it is fixed in the next release.

It might not be a physical issue. By "looping" I was referring to the logical portion of the button. I have 5 of these and they are all working correctly. They installed easily and loaded up with the Samsung Zigbee Driver. So I can validate that, in my situation, the driver is working properly. That is what is making think there might be something gone amiss with the button itself (software or hardware wise). And, she said she only pushed the button once. So something has to be generating the continued log entires (hence the theory of a stuck button).

Has the she tried removing, resetting and rejoining?

1 Like

Correct, I am seeing this with multiple devices, not just this button.

And, as you can see from the screenshot, it isn't just button pushes that are being duplicated. It is temperature reporting and battery status as well.

Do the logs only show Zigbee? I don't seem to see any of my Z-Wave devices when I click on Logs link.

You are correct in that it is highly unlikely that the driver is the issue. The update @srwhite is referring to has to do with the zigbee stack in general and not a particular driver. Apparently the issue only presents itself when you have a bunch of zigbee devices and the symptoms match what @Kato is seeing.

This is always a good option to try as well. Can't hurt..that's for sure.

Normally a good suggestion, however it's not going to solve anything in this particular case.

That's a Zigbee mesh issue. Nothing you can do will fix that, except wait for the next update which is likely to have the improvements that will correct the duplicate event you are seeing.

Correct. It increases the size of the source routing table which has to be large enough to hold all devices. This will effectively enable many to one routing. My theory as to why the duplicate events are being received is because there is a lot of routing requests going on and the timing of those requests is causing the end devices to retransmit its messages more than once.

I don't suppose a timeframe has been published as to when the next version will be out?

I think there might be additional issues with the Samsung button (or maybe with the HE simple lighting app). I got one of the sylvania lightify dimmer button switches and it doesn't appear that I am still having the same issues with having to double push the button to get the lights to come on.

The Samsung button was programmed using SL. The Sylvania was programmed using rule machine.